Slowdown after Build 946?

Discussion in 'Technical & Support' started by James Kirk, Apr 10, 2015.

  1. James Kirk

    James Kirk Registered

    Joined:
    Apr 10, 2015
    Messages:
    17
    Likes Received:
    0
    Really strange sensation now where I have slow down on the lowest graphics following the latest build. I have tried maximising performance, does nothing. The slow down can last from anywhere between 10 seconds to over a minute and happens across multiple tracks and mods (combos I tried were the DW12, FR 3.5, Mid-Ohio and COTA). Could it be that the install has been corrupted in some way? As a spectator of a 30 car grid I'm still fine.
     
  2. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,700
    Likes Received:
    628
    Could you enable cpu time? You can map buttons for it in Controls > Misc.

    If you have a purple, horizontal bar, while you experience a maximized CPU.

    I had the problem in 930, I haven't had it in 946 yet... You could have a corrupted install maybe... Was it fresh or auto-updated?
     
  3. James Kirk

    James Kirk Registered

    Joined:
    Apr 10, 2015
    Messages:
    17
    Likes Received:
    0
    I'm not really sure what CPU Time is? Neither have I seen a purple, horizontal bar :p

    Deffo not a corrupted install as I tried a fresh install of rFactor 2 Lite and I had the same effect.

    I've updated a load of drivers to see whether that makes any difference - may try later :)
     
  4. PRC Steve

    PRC Steve Registered

    Joined:
    Sep 27, 2012
    Messages:
    1,302
    Likes Received:
    7
    Press Ctrl + C whilst out on track and that brings up the Cpu graph, check if like Bjorn says its maxing out on the purple horizontal line.
     
  5. Domenicox

    Domenicox Registered

    Joined:
    Aug 22, 2014
    Messages:
    14
    Likes Received:
    3
    even after the new build the problem is present... deeply disappointed
     
  6. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    29
    Everyone should also make sure they remove the +procmask=3 option if they were using that in 930.
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,750
    Likes Received:
    3,971
    Your post in the 930 thread said that using the procmask option reduced your FPS by a factor of 3. I would suggest you have some (other) issues, because that definitely shouldn't happen. I would also suggest your 3 brief posts and lack of technical specs make helping you very difficult.
     
  8. Domenicox

    Domenicox Registered

    Joined:
    Aug 22, 2014
    Messages:
    14
    Likes Received:
    3
    I try to do a clean install ...
     
  9. James Kirk

    James Kirk Registered

    Joined:
    Apr 10, 2015
    Messages:
    17
    Likes Received:
    0
    Right apologies for not posting in a while. Gotten round to this and yes, my purple line is maxing out whenever I go into this slowdown mode. I never had this problem with Build 930 however.

    I have no idea what the +procmask=3 option even means.

    Checking framerate, I lose about 20-30 FPS when the slowdown occurs from 70-80 to 40-50
     
  10. Terence Groening

    Terence Groening Member

    Joined:
    Oct 13, 2010
    Messages:
    169
    Likes Received:
    0
    Surprising that you would get this in 946 but not 930, unless you significantly increased the number of opponents you are racing against.

    But anyway, what kind of CPU and video card are you running? Assuming the video card is nVidia, you could try going into the nVidia control panel and setting Pre-rendered Frames to 1. Or otherwise lower your graphics settings.
     
  11. James Kirk

    James Kirk Registered

    Joined:
    Apr 10, 2015
    Messages:
    17
    Likes Received:
    0
    Nope, happens both offline and online regardless of opponents.

    My CPU is a Intel Core i5-3210M at 2.5GHz whilst I have interchangable graphics cards. My laptop card is an Intel HD Graphics 4000 whilst I also have an AMD Radeon HD 7700M. Lowered graphics settings and honestly no difference!
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,750
    Likes Received:
    3,971
    Were you on build 930 previously, without issue? Or did you jump to 946 from an earlier build?
     
  13. Terence Groening

    Terence Groening Member

    Joined:
    Oct 13, 2010
    Messages:
    169
    Likes Received:
    0
    Mr. Kirk's earlier post indicates he was running 930 without issue. And I still don't know how it would get *worse* with 946, which has quite a few optimizations and other work done to prevent this issue.

    Is there any chance your laptop is overheating, causing the CPU to reduce its clockspeed? Because your hardware otherwise seems fine.
     
  14. Ekimelyobo

    Ekimelyobo Registered

    Joined:
    Jul 31, 2013
    Messages:
    41
    Likes Received:
    2
    I suffer a similar problem. Slowdowns and cars warping a few feet backwards and forwards on track when driving, but not a problem in the world when spectating.
    Also for me this problem was present in build 930 but on a much less noticeable scale.

    Graphical settings and number of AI do not seem to be the trigger as it occurs as much on low settings with 4 AI as it does with high settings and 24 AI.

    Initially installed lite on top of b930, cleared all cbash and shaders, let it rebuild plr json file, problem still there. Did a clean install , problem still persists.

    (the graphical warping of the cars a feet feet forwards and backwards visually reminds me of what used to happen in RF1 online if you had an overclocked cpu)

    RF2 is currently unplayable for me due to this.
     
  15. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,253
    Likes Received:
    1,377
    Your CPU is very old quad core (Q9550 released 2008). Changing setting described below might help you:

    – By default, the multithreaded physics are turned off for now. Set the PLR file variable “Sim Processor Thresh” to 3 to turn on, or 255 to turn off (note that we don’t allow them to be turned on for dual cores). Please do NOT use +procmask for the purpose of disabling multithreaded physics anymore.
     
  16. Ekimelyobo

    Ekimelyobo Registered

    Joined:
    Jul 31, 2013
    Messages:
    41
    Likes Received:
    2
    I have tried every trick in the book, Stonec. Nothing alleviates the problem.

    Until build 930 I was running 25 AI at 1080, mirrors on, on high track settings, high/medium opponent, high player, high texture, medium shadows, low reflections, video sync, aa at 2 and getting 50fps at the back of the grid at silverstone and a silky smooth gameplay experience.

    Current build, same settings, same 50fps at the back of the grid, but now the car immediately in front of me stutters and warps while everything else around it runs beautifully.
     
  17. TIG_green

    TIG_green Registered

    Joined:
    Jul 21, 2012
    Messages:
    3,037
    Likes Received:
    43
    I had to turn "Sim Processor Thresh" off in our league event (EGT in Spa) because I had constant stuttering (purple bar maxed turing this). There were about total of 8 cars. I had been on other servers with build 946 before this and this problem wasn't present.

    After I turned it off everything was fine again. Same settings as always (pretty high but not all maxed). But never mind the settings, it was clearly a bug which cured by setting "Sim Processor Thresh" off.
     
  18. James Kirk

    James Kirk Registered

    Joined:
    Apr 10, 2015
    Messages:
    17
    Likes Received:
    0
    Okay so I haven't done this SPT fix but can I have a step by step guide on how to do it please? Not just fix this and enter that - not exactly tech savvy :)
     
  19. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,353
    Likes Received:
    529
    go to your rfactor 2 data folder (e.g. rFactor2\UserData\player)

    Look for a files called "player.json" and open it with notepad or other text editor.

    Search for the relevant "Sim Processor thresh" line and change the value to either 3 for on or 255 for off.
     
  20. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,253
    Likes Received:
    1,377
    It's not a fix really but it's worth testing to turn multithreaded physics on as you have a quad-core CPU (they were enabled in build 930 but it caused issues for other people so was disabled). Setting "Sim Processor Thresh" to 3 in player.JSON should do this.
     

Share This Page