Setting up triple monitors

Discussion in 'General Discussion' started by Andrew Nagy, Jan 28, 2021.

  1. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    230
    Likes Received:
    147
    At 5760*1080 you should be able to run it on fairly high graphics settings. I am running 7680*1440 but it depends on your monitors. If you are running at the lower resolution then the frame rate loss due to using the method described by Dan may well be insignificant so if you do have problems with nvidia surround I would certainly use it.
    But as these things get more technical then Comante is right, you will potentially need some hands on help as sorting out some of the problems that I have had with nvidia surround would not be possible to talk through on a forum, even I had not faced some of them and only years of experience in building and messing with PC's meant that I could sort it out, but only sitting in front of it.
     
    Last edited: Feb 12, 2021
  2. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,315
    Likes Received:
    987
    I must have been lucky. No issues here with 2070 asus. Surround on. Multiview on (rF2 launcher setting). Running fullscreen. Well, i did with the old launcher, and it always worked. Hope you get it sorted.
     
  3. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    230
    Likes Received:
    147
    Alex, what resolution did you run?
     
  4. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    230
    Likes Received:
    147
    Andrew, did you try the triple setup and if so how did it go?
     
  5. Andrew Nagy

    Andrew Nagy Registered

    Joined:
    Jan 17, 2021
    Messages:
    128
    Likes Received:
    37
    Unfortunately, no dice. I went through the steps shown in the video, but when I opened RF2 after saving the required CustomVidRes settings on the Config_DV11.ini page, it's still stuck on just the center screen when I opened RF2. All three screens went black for a few seconds when I first opened RF2 (which caused my heart to skip a few beats...), but now it's just back to the same center-screen-only display.

    Also, in the video, it describes the steps to take to set the FoV on the Graphics screen within Settings, but I don't have this screen. So, pretty frustrating at this point. Please advise as to the next steps. Thanks.
     
  6. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,750
    Likes Received:
    1,382
    Here's my Config_DX11 that works for sure.
    Code:
    //[[gMa1.002f (c)2016    ]] [[            ]]
    [COMPONENTS]
    LanguagesFile=ENGLISH.DIC
    ObjDetail=3
    TexDetail=2
    VideoGUID=00001B81-0000-0000-0000-000000000000
    VideoDriver=0
    VideoMode=21
    VrSettings=0
    EPostProcessingSettings=1
    VideoRefresh=0
    WindowedMode=1
    Borderless=0
    RunBenchmarks=0
    FSAA=32
    VSync=0
    UseFXAA=1
    ShaderLevel=0
    SubViews=1
    UseSubViewParams=2
    WorkaroundFlags=0
    ViewParams=(0.576, 0.340, 0.600, 12.600, 0.037) // screen width (m), screen height (m), eye distance (m), side angle (deg), bezel gap (m)
    LeftView=(0.539, 0.340, 0.600, 12.600, 0.017)
    RightView=(0.517, 0.310, 0.603, 12.400, 0.019)
    PreferredGPU=36247
    WidescreenUI=0
    WidescreenUIWidth=4096
    WidescreenHUD=0
    CustomVidRes=(5760, 1080)
    VRMirrorWindowVidRes=(1920, 1080)
    VRUIScale=(1.000, 1.000, 1.000)
    MinimumVidRes=(800, 600)
    MaximumVidRes=(99999, 99999)
    
    [INSTALL]
    InstallFrom=
    InstallTo=
    
    [AUTOLAUNCH]
    Mode=Off
    LaunchTime=600
    
    [VERSION]
    Version=-1.000000
     
    vegaguy5555 likes this.
  7. Andrew Nagy

    Andrew Nagy Registered

    Joined:
    Jan 17, 2021
    Messages:
    128
    Likes Received:
    37
    @Coutie,

    Thanks for posting this. Here is the comparison of the values of the parameters which differ between your system and mine:

    ObjDetail: Coutie = 3, Me = 1
    TexDetail: Coutie = 2, Me = 1
    VideoMode: Coutie = 21, Me = 70
    RunBenchmarks: Coutie = 0, Me = 1
    UseSubviewParams: Coutie = 2, Me = 1
    ViewParams: Coutie = (0.576, 0.340, 0.600, 12.600, 0.037), Me = (0.540, 0.340, 0.600, 15.00, 0.037)
    Leftview: Coutie = (0.539, 0.340, 0.600, 12.600, 0.017), Me = (0.540, 0.340, 0.600, 15.00, 0.037)
    Rightview: Coutie = (0.517, 0.310, 0.603, 12.400, 0.019), Me = (0.540, 0.340, 0.600, 15.00, 0.037)
    Preferred GPU: Coutie = 36247, Me = -1
    WidescreenUIWidth: Coutie = 4096, Me = 542

    I imagine some of these values are unimportant, but several of them (of course, I haven't the foggiest idea what any of them mean) differ by quite a bit. I'm hesitant to simply change them all to match Coutie's values; could you please provide some guidance as to which ones might be contributing to my inability to get applications to spread across my three screens?

    And I'm really bothered by the fact that I don't have a "Graphics" screen within my Settings. This seems really out of whack, because this is where I understand I'm supposed to set important things like my FoV. Do I have enable something to make my Graphics menu appear? Thanks.
     
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,598
    Likes Received:
    4,609
    @Andrew Nagy I haven't really looked at the video, but I'd say it's using the old UI.

    Ok, was wrong, he's using the new one. But the first thing he does is go into the settings and select that new resolution (for you, 5760x1080). If you don't do that it won't fill all 3 screens.

    Thing is, with the new UI you don't need to set FoV yourself. As long as you can get rF2 running on 3 screens, you can go into the settings and setup the triple screens in there (no file editing required, no manual FOV adjustment - you just enter the distance to your screens and the angle of the side ones, it does the rest).

    To my untrained eye there's nothing in that ini file that looks wrong, I'm not totally sure on the last one though.
     
  9. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,750
    Likes Received:
    1,382
    You could just save yours with a different name and just paste mine into the config file.
     
  10. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,598
    Likes Received:
    4,609
    I don't think it sounds like anything is wrong tbh; just need to select the new resolution in game. All the differences are minor/random, and the usesubviewparams is because you (@Coutie ) have used different values for left-centre-right.
     
  11. Andrew Nagy

    Andrew Nagy Registered

    Joined:
    Jan 17, 2021
    Messages:
    128
    Likes Received:
    37
    OK, now I'm completely losing my mind. I went into a screen in RF2, the identity of which I don't remember, and changed my resolution to 5760x1080. It gave me two choices: Update (I think - maybe it was Save), and Revert. So I selected Update or Save (not Revert), and nothing happened. So I closed out RF2, and re-opened it, and no change - it's still stuck on the center screen only. So I went back to the same screen, and found that the resolution was back to the original 1920x1080, so I changed it back to 5760x1080, and this time, against my better judgement, selected Revert. Everything went black, then the side screens came up with just the Windows logo against a blue background, and the center screen stayed black! Life flashing before my eyes, I rebooted my computer, and to my infinite relief, everything came back up pretty much normal (or so I thought) - At least I didn't lose all my tracks like the last time my system melted down when trying to bring the side screens into action. But now, I can't find the screen containing the resolution setting in RF2, and can't for the life of me remember which screen I found it on before! I thought it was in the Display screen in Settings, but it isn't there. And now, my side screens are black, instead of light blue with the Microsoft logo. And they're totally dead - no applications tray on their bottoms. And yes, they're powered on. Argh, I'm going to end up in a padded room by the time I get this thing working! Whoever said setting up triple monitors can be a nightmare wasn't kidding!!!!! Why does it have to be so difficult?!
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,598
    Likes Received:
    4,609
    @Andrew Nagy it's a shame that as a PC novice you're getting these issues, and people like me who have half an idea what they're doing try these same things with zero problems.

    I've tended to stay away from your threads because you really need someone holding your hand, and probably on the end of a phone or even video call. I think we're still in that situation.
     
  13. Andrew Nagy

    Andrew Nagy Registered

    Joined:
    Jan 17, 2021
    Messages:
    128
    Likes Received:
    37
    Sigh - you couldn't be more right. Driving the sim in RF2 has been an incredibly rewarding experience - I feel like I'm really learning the track, and will be very well prepared for my upcoming race class. But setting up the system, particularly the triple monitors, has been frustrating to the point of infuriation. I feel like a lot of it has been bad luck - as you say, for many people, it just works, so I have no idea why following the same steps has led to system lock-ups, and a complete lack of success for me. A video call could be incredibly helpful, as I clearly have no business setting this up on my own - it's a miracle it has worked as well as it has, 100% of the credit for which goes to this great forum. But how exactly would a video call help, and who should I have it with? The challenges I'm going through are very specific to RF2, and I don't know anyone who uses RF2 outside of the people on this forum. But as I said before, everybody was a newbie at this stuff at one time - do you really need a degree in software engineering to get up a sim up and running? How have other people gone from newbie to accomplished sim racer?

    Oh, by the way, the Graphics option has magically reappeared within my Settings. I have no idea what I did to bring it back. But I can't get the desired resolution of 5760x1080 to "stick". Here are the steps I'm going through - please point out where I'm going wrong:

    1. Launch RF2
    2. Open Settings/Graphics
    3. Change the resolution from 1920x1080 to 5760x1080 by pressing the "+" button
    4. Select "Apply" ("reset" is grayed out)
    5. Select "Confirm" before the counter that appears counts down to zero, after which apparently my change will be revoked

    At this point, nothing has changed - the side screens are still black. Opening a Race session doesn't change anything. So I exit RF2. As soon as the exit from RF2 is complete, the side screens turn back to light blue with the Microsoft logo, and they're active again. So I re-launch RF2. All three screens go black for a few seconds, then RF2 opens in the center screen only, and the side screens are again black. I go back to Settings/Graphics, and my resolution is back to its default 1920x1080. Is there something I have to enable to allow the changes I make to the resolution to stick? Thanks.
     
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,598
    Likes Received:
    4,609
    @Andrew Nagy it sort of sounds like rF2 is in fullscreen mode, hence turning off the side screens (because it's only using the one screen).

    Check that yours says Windowed in the graphics settings:

    upload_2021-2-14_17-39-53.png

    Because you don't have that full 3 screen resolution outside of the rF2 settings (but, good news, you've obviously done that correctly, because it's an option in rF2!), if it's stuck on fullscreen it won't actually 'know' that a fullscreen 5760x1080 exists.


    And the reason I talk about a video call or similar, is that it makes it easier to see what's actually going on at your end, instead of you having to describe it. Teamviewer, a remote PC viewing platform, can be very useful but it tends to not work very well with games (at least last time I tried, albeit quite a while ago). But for file editing and problem solving it would certainly be an option.
     
  15. Andrew Nagy

    Andrew Nagy Registered

    Joined:
    Jan 17, 2021
    Messages:
    128
    Likes Received:
    37
    Well, despite all appearances to the contrary, it works! As soon as I went into Race mode, the side monitors turned on! That's not how I expected it to work but I'll take it! Driving with the triple monitors is really cool - much more lifelike. It does take a bit of acclimation, but not too bad.

    Not only that, but the data logging apparently works as well, because as soon as I start my session, it says "logging, on". So my install of Lazza's great plug-in seems to have been successful. I'm not sure how to access the data, but I'll move to my thread about that for that question.
     
  16. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    I noticed that you all have vsync off. I can't run AC without it jittering.
    I hope I can do this?
    I'm so excited!!
    After driving in triples I can not go back to single screens!! Lol!
     
  17. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    I followed your instructions with my screen sizes and saved but it did not save when I went back to check.
     
  18. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,750
    Likes Received:
    1,382
    Maybe make it read only. I don't think I did anything special to get it working, so I don't know how much help I'll be.
     
  19. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    Even though I'm adding a custom res (7680, 1440) it doesn't show up in graphics configuration.
     
  20. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    I did get it to run in triples but the side screens are at a wrong angle. Changing the angle in the ini file doesn't do anything.
    And, I can't get triple screen app to come up. Probably because I don't have surround on so multi monitors is Grey so I can't select it?
     

Share This Page