Setting a Dedi Server with McLaren_650S_GT3

Discussion in 'Hosting Help' started by Ross Hawkey, Sep 20, 2017.

  1. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    I have a problem trying to setup a server with the new McLaren GT3 car.

    I create the mod/rfm, and then go to setup the server, but when I get to the 'Available Vehicle Filter' screen, there are no cars that can be selected.

    I've tried it on our RaceConnect.com dedicated server and my own PC, and have the same problem.

    I regularly create server for our sim-racing community, but am unable to work out what the issue is.

    Any help would be appreciated. - Thank You
     
  2. Gupster

    Gupster Registered

    Joined:
    May 19, 2013
    Messages:
    404
    Likes Received:
    25
  3. Marc Brink

    Marc Brink Registered

    Joined:
    Nov 25, 2015
    Messages:
    75
    Likes Received:
    58
    The majority of people can't run a server and still no improvement.

    There's no good overall guide to set this up, only referring to 'this site', 'that site', 'this thread', 'that thread' which take hours or days to read and is not going anywhere. That's not going to work. I had no issues 'till rFactor2 was ported over to Steam.

    Also hardly responds from the devs. "Yes, we read it but we can't always reply".
    Well, the number of replies by devs is very sad indeed. People ask questions, assuming but no-one really knows ... and hardly a dev in sight to reply on the subject.

    I don't want to mess around with files and folders and that CMD crap. I just want to open some ports in my router, push the 'running a server button' and voila ... server is running. How hard can it be to make it more user friendly?
    We can't be all a computer genius, can we?

    So a good written overall setup guide, step by step, loud and clear, no room for confusing.
    Is that possible or is it too much to ask for?
     
    Last edited: Sep 21, 2017
  4. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    Thanks Gupster.

    I've been to the thread, and tried what it says.

    I confirm that I have the file 'Server Keys.bin' and 'Server Unlockbin' on our dedi, I assume because I've purchased the GT3 pack both on my race pc, and also on our RaceConnect dedicated server install.

    My problem is the same as Ari Antero's reply in the thread you linked:
    The problem is that car list is empty when you launch dedicated server

    Ari Antero, Aug 2, 2017

    I have created a mod/rfm, I go to setup the dedi server, but despite including the McLaren when creating the mod, when I get to the 'Available Vehicle Filters' screen on the rF2 dedi setup, it's all just blank.

    I'm going to upload my race pc files to the dedi, in case that makes any difference, and I'll update when that's done.
     
  5. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    OK, I've wasted a bit of time on this now, and it's the same issue:

    The problem is that car list is empty when you launch dedicated server

    So, to be clear:
    1/. We have 4 other rF2 Dedi's running fine, with members joining without issue.
    2/. I create a mod/rfm for the McLaren 650 GT3 car (owned and paid for on both my Race PC and the RaceConnect Dedi Server)
    3/. The 'Server Keys.bin' and 'Server Unlockbin' files are present on the RaceConnect Dedi.
    4/. When I click to 'Initialize dedicated server', I get to the usual screen and select the McLaren GT3 mod/rfm I created.
    5/. It takes me to the 'Available Vehicle Filters' box, and there is no car data at all. Usually, I'd expect to see car models to select.

    From reading the thread you linked, I don't think I'm alone in having this issue. I see GPfan (someone who knows rf and rf2 inside out, has the same issue)

    Thank You.

    p.s. RaceConnect is a SimRacing community that's been running and supporting rfactor for a decade now, and has also been running rF2 events since it was originally released. We want to support Studio397 with this sim and with the new GT3 mod, but linking a thread which doesn't really help, isn't great help to me.
     
  6. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    824
    I got this sorted out but I just can not remember exactly how. However If i remember right I used this line with CMD to download MClaren to my dedicated server: steamcmd.exe +login username password +workshop_download_item 365960 1097229192 +quit. Before I did copy 'Server Keys.bin' and 'Server Unlockbin' from my game PC I did log in to steam with same user name and password I used to download content to my dedicated server. I believe also that before I did copy 'Server Keys.bin' and 'Server Unlockbin' from my PC I did go to single player and hit the exit.
     
  7. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    824
    It is bad English. If you can not understand my rally English I can use bit more time to make new post and explain better:(
     
  8. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    When you create the race event (rfmod) are you picking version 1.23?
    After that, are you linking that component or are you including that component in it?
    Are you by any chance using a different skinpack with your league's drivers?
     
  9. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    Yes, I use v1.23. If I try to select both, I get an error about duplicate files using with the same name.

    No skin packs. It's all standard content.

    After that, are you linking that component or are you including that component in it? Sorry, I'm unsure what you're meaning. On the create mod package, I have all the McLaren Cars 'checked', but not the actual vehicle box on the left. I'll try that maybe if that's what you're meaning?...although on the official help thread linked by the Admin, they say to NOT click the check box on the left.

    We don't use the steamcmd line for our dedi server, we're running the rf2 Dedi.exe from Steam>Steam Apps>Common>rfactor2>Bin64. That's what we've been doing for rF2 since it went to steam, and it's been fine so far.
     
    Last edited: Sep 21, 2017
    SPASKIS likes this.
  10. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    [​IMG]

    Here's an example of the issue....There's no McLaren 650 GT3 car in the 'Available Vehicle Filters'. I've set dozens and dozens of mod/rfm's before, and there are always cars (as per the ones I select when running the mod creation file) showing here.
     
  11. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    Yes, what I mean is if you are checking that box in the left.
    When using incremental updates with older content this was a remedy to solve the problem of empty list. Its biggest drawback is that depending on the size of the update it can produce a large size file. Apart from thatz which is more an inconvenience rather than a real problem, I have never had any issues with it.

    There are several other oddities using incremental updates which have made me always follow the same approach when dealing with them.

    One of them was to include always all the main files of a component. This would be hdv, gens, tbc... for cars and scn, gdb, aiw... for tracks. In some cases it would work OK without including them but as I said: after many problems and reports of behaviour changes regarding incremental updates everytime mas2.exe and modmgr.exe were updated in a build release, I decidee to go "the safe way" and never had any problems since them.

    I hope I have helped and that you didn't get lost in the speech.
     
  12. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    I tried clicking the box on the left, and yes, it was a large file.

    I still had the empty vehicle filter boxes though.

    So my issue is still unresolved.
     
    SPASKIS likes this.
  13. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    824
    I just created MClaren vmod with my game PC and all is working fine.
    I have also Steam in my server and have bought MClaren to my server. When MClaren was released I was also trying to host MClaren from rFactor 2 and was struggling with the same issue. Solution to my problem was to launch single player before creating vmod.
     
    SPASKIS likes this.
  14. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    Well I have the files that the Admin said I needed on the dedi server, but I still have no cars to select. It's tough to start rf2 in single player mode on our dedi server. It's a dedicated server, and not for gaming. Doesn't have much gfx capability etc, so stops with a DX error message....but did run long enough to create the server unlock bin file...but it still didn't work (as mentioned earlier).
    [​IMG]

    It shouldn't be an issue. If people are paying for these packs (twice in my case, 1 time for my race pc and 1 time for the RaceConnect sevrer), then it should work, without trawling through forums to try to resolve.
     
  15. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    As Ari says, before hosting a server I always check if the vmod works in single player mode. Can you check this and report?

    By the way after creating the vmod I understand that you are installing it with modmgr.exe both in your PC and in the server. You know it is possible to install the rfmod directly with mas2.exe after creating it... How did you install MCL in the server? Did you copy the files specified in the thread to host paid content?

    Forget last questions. You just clarified in the post while I was typing it.
     
  16. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    824
    @Ross Hawkey I can send you PM and link to vmod I just created if you like. You can test your server with that vmod track is Malaysia ?
     
  17. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    @Ross Hawkey I can send you PM and link to vmod I just created if you like. You can test your server with that vmod track is Malaysia ?

    That'd be worth testing. Thanks
     
  18. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    I create the mods using the gMotor2 MAS file utility, and run through that, which installs the mods to the dedi automatically.

    I can then check them on the mods manager, and they all show (including the McLaren one).
     
  19. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    You can also enter our server "Racerfactor McLaren". It is unpassworded and will automatically download it. You just require to have Mills Metro Park installed.
     
  20. Ross Hawkey

    Ross Hawkey Registered

    Joined:
    Nov 26, 2015
    Messages:
    65
    Likes Received:
    17
    ok, i'll load up my race pc and get it. Thx

    Hmm, getting the red writing 'package not available'. That's another occasional issue I see. I've got a file from another Mclaren server though. I'll try that.
     
    Last edited: Sep 21, 2017
    SPASKIS likes this.

Share This Page