Server running vmod - no "Get mod" button - only "Join" and I joined without vmod :)

Discussion in 'Technical Archives' started by K Szczech, May 31, 2012.

  1. K Szczech

    K Szczech Registered

    Oct 5, 2010
    Likes Received:
    Created vmod on dedicated server and installed it from within Mas utility.
    Then launched dedicated server and selected this new vmod.

    This dedicated server is a machine in a different city.

    Then I started rF2 on my machine. Had all the content installed (Nissan by ISI and Mid Ohio by VLM), but I didn't download that vmod from server - I expected a "Get Mod" button to appear on the list.

    Funny thing was, that I got "Join" button instead and I just joined the server without installing it.

    I did a couple of laps, then disconnected. I didn't shut down rFactor (didn't even quit to launcher - just to main menu) and went to servers list to join again.
    This time I had "Get Mod" button, but when clicking it, I had to wait some time only to get "Could not get mod" message (if I remember correctly).

    So i exitted to launcher and started rF2 again. This time "Join" button was on servers list and it worked. Exitted to menu and "Get mod" button was on the list again. And again it failed to get mod.

    I've checked server's multiplayer.ini file but the only setting I've found that could have something to do with it was "Enable Autodownloads", so I changed it to "1", but same thing was happening.

    MaXyM suggests it may have something to do with user rights on server, but since I managed to start a dedicated server on this vmod, then I guess it had necessary rights to load this file and send it to me.
    Perhaps it had something to do with the fact, that server was password protected? rFactor doesn't ask for password when i hit "Get Mod" button, only when I hit "Join" button. And I was waiting for "Get Mod" button to respond more less the amount of time you wait for timeout when you enter wrong password.

    Of course downloading that vmod manually and installing it on my end solved everything, since I had all components allready. But it was funny I was able to join server without it :)

    Just for the record - hitting "Get Mod" button on your "vmod test" server worked as expected - it downloaded the mod and failed to install it (I allready had Meganes updated to 1.1 and your vmod test server seems to be running 1.0). Perhaps that server wasn't password protected and that's why I could download mod from it (obviously I didn't try to join since I couldn't install it).

Share This Page