Salvataggio setup

Discussion in 'rFactor 2 General discussion (Discussioni)' started by Antiogre, Aug 28, 2012.

  1. Antiogre

    Antiogre Registered

    Joined:
    Jul 24, 2012
    Messages:
    69
    Likes Received:
    0
    Ciao,
    non riesco a capire come mai non trovo piu i miei setup.
    Li imposto normalmente li salvo e quando esco e riavvio il gioco i setup sono scomparsi.
    Delle volte c'é qualche procedura, a parte il salvare come si fa di solito, particolare o si devono nominare con un determinato nome?

    Grazie
     
  2. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    In rFactor c'è l'opzione di vedere tutti i setup o solo quelli per una certa macchina, tramite il bottone All/Vehicle che si trova nello schermo degli assetti.

    Se non è questo il problema è probabile, se hai Vista o Win7, che devi lanciare rF come amministratore di sistema perchè UAC (User Account Control) limita la libertà di accesso/modifica agli utenti non amministratori.

    Per lanciare rF come admin di sistema, clicca sull'icona nel desktop con il bottone destro e seleziona "Run as Administrator" (non so il testo in italiano, io ho XP).

    In questo caso però gli assetti ci dovrebbero essere, ma in una sottocartella in Documenti

    http://isiforums.net/f/showthread.php/217-Can-I-run-rFactor-on-Windows-7
     
  3. Carra

    Carra Registered

    Joined:
    Jan 14, 2012
    Messages:
    844
    Likes Received:
    1
    "avvia come amministratore" in italiano ;)
     
  4. Antiogre

    Antiogre Registered

    Joined:
    Jul 24, 2012
    Messages:
    69
    Likes Received:
    0
    NIet, mi sa che mié andato tutto a remengo azz
     
  5. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Proviamo a capire meglio ... se vai in rFactor/UserData/Nome_del_tuo_player/Settings i setup ci sono o no?
    Se non ci sono e ti ricordi il nome esatto di un setup, con un Cerca riesci a trovarlo da qualche parte?
    (Su XP click con il destro sull'icona "Risorse del Computer" e selezioni Cerca, su Vista e Win7 non saprei, ma immagino che sarà simile)

    Anche, non avrai cambiato di recente il nome utente? Perchè gli assetti sono "nominativi" e potrebbero essere nella sottocartella del vecchio player.
     
  6. ~IsR~Barabba

    ~IsR~Barabba Member

    Joined:
    Oct 6, 2010
    Messages:
    1,160
    Likes Received:
    38
    se hai Vista o Win7,ed e la prima volta che installi rFactor,puo succedere che certe cartelle si mettano in altri posti.
    Se e cosi,si infilano nelle cartelle appdata,e queste sono nascoste,quindi prima devi renderle visibili,e poi entri e le cerchi.
    meglio ancora come dice Max,usa la funzione cerca,e vedrai che si sono infiltrate Li.
    Facci sapere come e andata.

    Babs;)
     
  7. Antiogre

    Antiogre Registered

    Joined:
    Jul 24, 2012
    Messages:
    69
    Likes Received:
    0
    Riassumendo ci sono dei setup salvati, ma quelli di ieri sera sono spariti.
    Non ho cambiato nome utente.
    Ho fatto passare tutto il pc, spariti, bho non saprei proprio che pesci pigliare.
    Ma capitano tute a me :confused:
     
  8. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Snceramente, se non è un problema relativo a UAC, non saprei che pensare.

    Cmq, non ci sono procedure particolari (basta salvare l'assetto) e la scelta del nome è libera ... ti dico, mi sembra improbabile che possa essere un bug di rF (in 7 anni, a proposito domani è il compleanno, :) sarebbe stato segnalato sicuramente) ma un bug di rF2, fixato tempo fa, mi porta a chiederti: il nome del setup sparito era molto lungo? Che io sappia non dovrebbero esserci limitazioni sulla lunghezza, ma chissà ... potrebbe esserci una possibilità che la lunghezza del nome sia limitata a tot caratteri.

    Tolta la possibilità che sia un bug di gioco, hai installato recentemente programmi per la sicurezza del PC? ... che so, qualcosa che potrebbe impedire di salvare files con estensioni non standard e che magari fa rimanere in sottofondo la finestra che chiede se vuoi salvare il file con quella estensione?

    Ultima idea, il tuo PC contiene dati importanti o è solo un gaming PC?
    Nel secondo caso potresti provare anche a disabilitare temporaneamente UAC per vedere se il problema dipende da lui.

    http://www.faqwindows.com/disabilitare-uac-da-pannello-di-controllo-disable-uac.html

    (il link è per Vista, ma suppongo la procedura sia la stessa o molto simile anche in Win7)
     
  9. Antiogre

    Antiogre Registered

    Joined:
    Jul 24, 2012
    Messages:
    69
    Likes Received:
    0
    Ho notato che, se mi passano il setup, e lo salvo con un nome a mio piacimento non rimane nessuna traccia, una volta uscito dal gioco.
    Per quanto riguarda il pc, l'ho dedicato completamente al gioco, ossia ho collegato un solo hd formattato e installato RF2.
    La lunghezza del nome credo sia irrilevante, ho provato ad inserire il mio nome e cognome, ben 17 lettere, ed é rimasto il setup salvato.
    Ho anche visto nel percorso che crea il gioco questo:

    C:\Users\Giampa\Documents\rFactor2\UserData\player\Settings

    per il circuito di Mills_Outerloop e Mills_Innerloopb vi sono in totale 5 cartelle nominate con il nome del circuito in questione, pero dopo l'ultima lettera la "p" ci sono altre lettere che vanno da "a" a "c".
    Il gioco crea effettivamente queste cartelle o sono dei doppioni inutili?
    Forse é questo il problema?
     
  10. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Argh, quindi stiamo parlando di rF2 e non di rF?

    Con rF2 quello di non salvare i setup passati nel server era un vecchio bug, che però credevo fixato.

    Le lettere relative a Mills, e le relative cartelle, servono a differenziare i vari layouts, quindi non penso siano la causa del problema.

    Insomma, un vecchio bug (che non accadeva sempre e che credevo risolto) sembra essere riapparso ...
    giusto una curiosità: i setup scomparsi sono tutti della stessa classe e tipo di vettura che stavi guidando?
    Cioè, scompare un assetto Megane quando lo hai salvato mentre nel server avevi la Megane oppure scompaiono solo assetti di vetture di classe o tipo diverse, per esempio un assetto di una Eve F3 mentre sul server stai guidando una Spark F3 o un assetto della Nissan GT4 mentre stai nel server con una GT1?

    Ultima domanda: dato che è un bug online sono sicuro che al 99.9% stiamo parlando della build 101 ...
    giusto?

    Cmq, aspetto conferma che stiamo parlando di rF2, poi sposto il thread. :)
     
  11. Antiogre

    Antiogre Registered

    Joined:
    Jul 24, 2012
    Messages:
    69
    Likes Received:
    0
    Ahimé confermo tutto .
    RF2, la classe é la CLIO CUP
     
  12. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Ho spostato il thread ... ma il problema capita spesso o ti è successo solo una volta?
     
  13. Antiogre

    Antiogre Registered

    Joined:
    Jul 24, 2012
    Messages:
    69
    Likes Received:
    0
  14. Antiogre

    Antiogre Registered

    Joined:
    Jul 24, 2012
    Messages:
    69
    Likes Received:
    0
    Provo ad installare la nuova build 107, chissa che non risolva il problema!!!!!!!
     
  15. vornik

    vornik Registered

    Joined:
    Jun 10, 2013
    Messages:
    113
    Likes Received:
    0
    Ragazzi un saluto a tutti riprendo questo vecchi threadrchè ho lo stesso problema, i setup che mi passano mentre sono in una stanza li salvo metto il nome ma poi appena esco non li ritrovo in nessuna cartella dei setup, che mi dite?
    C'è qualche procedura specifica per salvarli? un saluto a tutti
     
  16. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Prima devi selezionare il layout della pista dove vuoi salvare il setup (quello dove sei in quel momento è evidenziato da un asterisco, di solito i setup si salvano li) e poi salvi.
     
  17. vornik

    vornik Registered

    Joined:
    Jun 10, 2013
    Messages:
    113
    Likes Received:
    0
    Max perdona la mia ignoranza layout? ci devo cliccare sopra? grazie
     
  18. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Il layout è il tracciato specifico, ci sono alcuni circuiti che hanno più tracciati e le cartelle dei setup sono una per tracciato (layout).

    Cmq, per prima cosa devi caricare il setup ricevuto ... lo carichi dalla cartella "Received" come qualsiasi altro tuo setup.

    Poi nella finestra "Folders" (quella a sinistra) scorri le varie cartelle finchè non torni a quella del tracciato dove sei (si riconosce per l'asterisco a destra del nome) e lo selezioni cliccandoci con il mouse.
    Il testo del layout selezionato diventa bianco, a conferma dell'avvenuta selezione.

    A questo punto clicchi su Save ed è fatta.
     
  19. vornik

    vornik Registered

    Joined:
    Jun 10, 2013
    Messages:
    113
    Likes Received:
    0
    grazie max
     
  20. MMartin

    MMartin Registered

    Joined:
    Oct 30, 2010
    Messages:
    515
    Likes Received:
    3
    Se ben ricordo quando sei nella cartella "received" puoi anche selezionare il setup e "trascinarlo" nella cartella desiderata ;)
     

Share This Page