s397 / DLC cars in devmode

Discussion in 'Car Modding' started by StoneRacing, Sep 15, 2022.

  1. StoneRacing

    StoneRacing Registered

    Joined:
    Nov 20, 2021
    Messages:
    142
    Likes Received:
    73
    Hello

    I know ... it has been asked a couple of times before and I also managed to have s397 cars in devmode months ago - but maybe something has changed, maybe I am missing something.

    It would be pretty helpful if someone could give a (detailed) instruction what I need to do on the example of Corvette C8.R or Aston Martin GTE.

    Currently I am copying Corvette_C8R_GTE_2020 from Installed\Vehicles to Moddev\Vehicles - starting devmode works, but entering the track makes rF2 crash after loading the track completely (crash to desktop).

    I have extracted car-upgrade.mas from Corvette_C8R_GTE_2020\3.11 to Corvette_C8R_GTE_2020\teams (created teams folder before) and now I can see e.g. the icons of C8.R in the menu - but entering track rF2 still crashes.

    Last lines of logfile (trace 3 and flushing):

    57.40s slot.cpp 949: Entered Slot::Restart(104)
    57.40s slot.cpp 1036: vi(1)
    57.42s slot.cpp 1040: sr(1,1)
    57.42s driver.cpp 549: unable to find RCD file for driver of NO_AI PaceCar class car
    57.42s setup.cpp 3416: Could not find LochDrummond_Long.ini
    57.42s slot.cpp 1121: Exited Slot::Restart()
    57.42s slot.cpp 949: Entered Slot::Restart(0)
    57.42s tire_manager 1425: Non-existent tire brand ""
    57.42s tire_manager 1425: Non-existent tire brand ""
    57.42s slot.cpp 1036: vi(1)
    57.43s vehload.cpp 3379: Gear 1 is not available? (Unexpected!)
    57.43s vehload.cpp 3381: Gear 2 is not available? (Unusual for most vehicles, but may be okay for some.)
    57.43s hdvehicle.cp 3435: Could not read file:
    57.48s main.cpp 343: onFatalError 11

    Any help would be appreciated.

    Thanks,

    Dietmar
     
  2. StoneRacing

    StoneRacing Registered

    Joined:
    Nov 20, 2021
    Messages:
    142
    Likes Received:
    73
    p.s:

    I was made aware, that DLC cars can never be driven in devmode because of some problems with extracting the encrypted mas-files and so on, but I would like to know about it to be sure if it is working or not (I would like to use e.g. C8.R in devmode in order to use HUD editor to align some gauges)
     
  3. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,030
    Likes Received:
    394
    Its not working driving
     
    StoneRacing likes this.
  4. StoneRacing

    StoneRacing Registered

    Joined:
    Nov 20, 2021
    Messages:
    142
    Likes Received:
    73
    Thanks - I just tried it in different ways and noticed this :-(
     

Share This Page