Run Time Errors

Discussion in 'Technical & Support' started by Bee, Dec 27, 2013.

  1. Bee

    Bee Former ISI Staff

    Joined:
    Sep 30, 2010
    Messages:
    46
    Likes Received:
    0
    If you experience crashing after updating rf2 (or if you get run time error - especially after Windows updates), please follow these instructions below thoroughly to create a clean install. This may resolve any corrupt file/license issues.

    To create a clean install of rfactor2:
    - Uninstall rfactor2 using the uninstall feature.

    - Delete the entire rfactor2 installation folder, and any rfactor2 related folder in your My Documents folder (to remove any user data files).

    - Next, delete the local license file: Navigate to your “C:\Users\<Your Windows Username here>\AppData\Roaming\.rFactor” folder and delete the files within (you can type this in your Windows Explorer address bar or navigate to it by first disabling “Hide system files and folders” in your folder settings (see windows documentation for more info)).

    - Make sure you have downloaded the most recent build of rfactor2 from the appropriate downloads page of rfactor.net and install it into a new clean folder. For rfactor2, using the Content Installer download is best because you can then test the game with minimal content.

    - Since you’ve deleted the license file in a previous step, you’ll need to reactivate your game. For rfactor2, run the launcher, select the Purchase tab, then select Reactivate.

    - Run rfactor2 with the minimum content and with NO 3rd party community created mods/addons/plugins (content you’ve downloaded elsewhere) and troubleshoot any issues with limited content.

    Once you confirm the game is working fine, you can download additional content from the rf2 downloads page at rfactor.net
     
  2. R-B

    R-B Registered

    Joined:
    Aug 6, 2013
    Messages:
    54
    Likes Received:
    0
    Try 30 BTCC Civics on Silverstone.

    After this method it still crashes, so this method is not working for runtime errors.
    rf2.exe used to much memory (exceeding 3.7 GB), with as result a crashing rF2.exe.
     
  3. Rinussie

    Rinussie Registered

    Joined:
    Jan 11, 2012
    Messages:
    75
    Likes Received:
    9
    It didn't solved my run time error message. please rename the tread name into "Maybe resolve any corrupt file/license issues"
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,413
    Likes Received:
    6,616
    It's talking about runtime errors making it impossible run rF2 at all. You can work that out by the fact the post ends with getting the game running with minimum content - what happens after that is another issue.

    Running out of memory causes a runtime error, and no amount of reinstalling is going to fix that. That's true.
     
  5. tito

    tito Registered

    Joined:
    Jan 10, 2012
    Messages:
    25
    Likes Received:
    0
    For me it's OK !!

    Thanks, Bee.
     
  6. NDRustyfan

    NDRustyfan Registered

    Joined:
    Jan 7, 2012
    Messages:
    4
    Likes Received:
    0
    This worked for me, I could not ever get rFactor2 to start with the launcher!
     
  7. fujitsu1

    fujitsu1 Registered

    Joined:
    Mar 7, 2012
    Messages:
    110
    Likes Received:
    0
    Im agree with this. Clean install doesnt solved it to me.
     
  8. brato

    brato Registered

    Joined:
    Oct 2, 2013
    Messages:
    35
    Likes Received:
    0
    Thx it's work many thx Bee
     
  9. chappielike2009

    chappielike2009 Registered

    Joined:
    Jun 17, 2012
    Messages:
    109
    Likes Received:
    1
    every time i leave track rfactor has stopped working every time i edit dedi server an reload it crash also
     
  10. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    86
    Likes Received:
    20
    My problems started when I changed gfx card from a 980ti to a 1080. Everytime I load a track and car combo it crashes to desktop. Try again and sometimes it works ok with no issues. If I go back to menu and change car or track it will crash again to desktop. Sometimes all I have to do is press escape and it will crash to desktop. I have tried every nvidia release driver for the 1080 and nothing works. I've deleted everything and started again from scratch. I've also tried the 32bit exe and that is ok, but simvibe will not work. Any ideas would be greatly received.
     
  11. kinjo

    kinjo Registered

    Joined:
    Dec 7, 2016
    Messages:
    4
    Likes Received:
    0
    I am Having SYSTEM SERVICE EXCEPTION problem in my PC.
     
  12. kinjo

    kinjo Registered

    Joined:
    Dec 7, 2016
    Messages:
    4
    Likes Received:
    0
    Here’s the mail I got recently for my problem

    Yeah, well.... This is a week old computer and I have been getting the system service exception constantly.... it is definitely related to Internet because that's when it happens... no idea what is causing it but it is continual. Hope Microsoft figures this out.... seems I'm not the only one... I am an IT manager so not an idiot when it comes to the computer.


    Or otherwise try this: http://www.deskdecode.com/system-service-exception-0x0000003b/
     
  13. Chris Shepherd

    Chris Shepherd Registered

    Joined:
    Nov 24, 2015
    Messages:
    18
    Likes Received:
    4
    Hi,

    Is there any solution for game freezes that myself and many others are experiencing?

    During any session, with or without a full grid, the game will momentarily freeze for 1-2 seconds. Its very random.

    In a 4 hour session last night, my game froze on track 4 times. I experience this at least once every time I race. :(

    Thanks for any help/feedback,

    Chris.
     
  14. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    747
    Likes Received:
    545
    Maybe:

    • Fixed sporadic nVidia driver crash on certain tracks. The fix, which is only needed if you were experiencing driver crashes and restarts, can be activated by changing the value WorkaroundFlags=1 in the Config.ini with a text editor. Please make sure to delete your shader cache manually (the files in UserData\Log\Shaders) when making this change.
     
  15. sherpa25

    sherpa25 Registered

    Joined:
    May 14, 2015
    Messages:
    234
    Likes Received:
    27
    What does this flag do? I frequently get rF2 crashes and noticed it was when I had trackmap running. Perhaps some conflict with d3d9?
     
    ebeninca likes this.
  16. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,413
    Likes Received:
    6,616
    @sherpa25

    The NVidia lockups also happen without trackmap (or any other plugins), so it's possibly not the same thing.
     
    sherpa25 likes this.
  17. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    747
    Likes Received:
    545
    I don't know exactly what they mean with "workaround flags".

    In my case, OCGuru from gygabite was causing the random freezes. I discovered by keeping windows process manager open in another screen, and looking for cpu usage.

    About plugins, i had random crashes caused by DAMplugin. Discovered when i tested one plugin at a time, but since this last rfactor build, this problem stopped.
     
    Last edited: Jan 2, 2017
    sherpa25 likes this.
  18. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,413
    Likes Received:
    6,616
    In future please let me know so I can try and find a cause and fix it :)
     
    bravotangosix and ebeninca like this.
  19. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    747
    Likes Received:
    545
    As this plugin is not vital for me during a race, like DeltaBest, I ended up disabling it before starting a race. Anyway, I'll let you know next time.
     
  20. CQR Bunn

    CQR Bunn Registered

    Joined:
    May 3, 2017
    Messages:
    1
    Likes Received:
    0
    I was experiencing the same problem after updating. Turned out that the problem was being caused by a plugin I had installed (VHUD). Some plugins are only compatible with DX9, as soon as I deleted this from the plugins folder it booted up just fine
     

Share This Page