Road material

Discussion in 'Track Modding' started by ThomasJohansen, Feb 13, 2021.

  1. ThomasJohansen

    ThomasJohansen Registered

    Joined:
    Dec 27, 2019
    Messages:
    347
    Likes Received:
    839
    In 3dsmax, I have fixed some geometrics on a track and want to export the parts back to gmt again but my material gets "mirror" like when testing the modified gmt file.

    Is there some standard 3dsmax material I can apply and then adding the original dds as main color map?

    The more I read about this the more confused I get.

    The GMT converter in 3dsmax wants it to be in a multi/sub material, and it must be gmat.
    The material imported was named ROADMAIN_WET.

    How should I setup the material?


    Udklip1.PNG Udklip2.PNG
     
  2. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,680
    Likes Received:
    1,355
    Are you sure it's there? It looks more like it's missing, and you're just seeing the background image.
     
  3. ThomasJohansen

    ThomasJohansen Registered

    Joined:
    Dec 27, 2019
    Messages:
    347
    Likes Received:
    839
    I can drive on it, but yes its transparent and I have tried to flip normals.
     
    Last edited: Feb 13, 2021
  4. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,680
    Likes Received:
    1,355
    Do you have render un-checked? I don't think it's possible to have transparency on the real road material. That's the only thing I can think of.
     
  5. ThomasJohansen

    ThomasJohansen Registered

    Joined:
    Dec 27, 2019
    Messages:
    347
    Likes Received:
    839
    just checked, it is renderable so not where the problem is but thx for feedback.
     
  6. Mauro

    Mauro Registered

    Joined:
    Oct 14, 2011
    Messages:
    1,844
    Likes Received:
    2,937
    From that picture seems that you haven't road .Gmt object at starting grid (maybe .Gen string missing?)

    As i remember zolder '79 early version had that problem too
    @philrob what do you think?
     
  7. ThomasJohansen

    ThomasJohansen Registered

    Joined:
    Dec 27, 2019
    Messages:
    347
    Likes Received:
    839
    The road surface of the track consist primarily of 3 GMT files. I have replaced one GMT to test but when I have exported it to GMT and tested it, it looks like this. It must be a shader problem, but no matter how I try to setup the shader in 3dsmax it keeps looking like this.
     
  8. ThomasJohansen

    ThomasJohansen Registered

    Joined:
    Dec 27, 2019
    Messages:
    347
    Likes Received:
    839
    anyone know a "how to" video about creating the correct road sub/multi material shader with gmat's and adding it to a roadsurfaceXX and exporting to GMT.

    The more I read about this the more confused I get. Think I need to see a video explaining this part.
    (I do know simple materials and adding that to objects, but to get it working when exporting to gmt is another thing.)
     
  9. Normark

    Normark Registered

    Joined:
    Oct 5, 2010
    Messages:
    167
    Likes Received:
    39
    Load Lock Drummond in dev mod, open the online material editor, and load the material ROADMAIN_WET.
    Then you can see witch shader and textures the material use.
    I did that for a lot af different materials, and I made screenshots and printed afterwards.
    I now have a printed library of the different materials.
    The easyes way is to export the road GMT from max with just a simple material, then you can choose the shader and load the textures from the online material editor
     
  10. ThomasJohansen

    ThomasJohansen Registered

    Joined:
    Dec 27, 2019
    Messages:
    347
    Likes Received:
    839
    I found out what happened.
    I had imported the track in wrong scale, so had to scale it up to 10000%.

    With huge help of @Frederick Alonso I have figured out how to add IBL shader.
    but my next question.
    The road is now slippery as ice. Where is that setting when using IBL Road?
     
    Frederick Alonso likes this.
  11. ThomasJohansen

    ThomasJohansen Registered

    Joined:
    Dec 27, 2019
    Messages:
    347
    Likes Received:
    839
    solved it.
    since I have changed the name of the material from roadmain to ibl_road I also had to duplicate a part in the tdf file.
     
    Corti and Mauro like this.
  12. Joan Prim Armengol

    Joan Prim Armengol Registered

    Joined:
    Feb 21, 2017
    Messages:
    28
    Likes Received:
    16
    Thomas the material needs to end with _WET for it to work properly.
     
  13. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,442
    Likes Received:
    570
    Also.... all materials need a prefix that appears in the TDF.... otherwise it will be ice. No additions to TDF needed if things are named correctly.
     
  14. PatientRF2fan

    PatientRF2fan Registered

    Joined:
    Aug 30, 2020
    Messages:
    99
    Likes Received:
    33
    Hey ThomasJohansen,

    I myself have hit a major roadblock with same topic.
    I have seen videos on how to assign sub material....



    They only show how to do one item. (one road) but no others.
    I hope you find the answer somewhere out there with all the fragmented info.
     
  15. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,442
    Likes Received:
    570
    Do you need help with multi-sub objects?
     
  16. PatientRF2fan

    PatientRF2fan Registered

    Joined:
    Aug 30, 2020
    Messages:
    99
    Likes Received:
    33
    indeed, i am starting a conversation with you sir.
     

Share This Page