Rilasciata la build 298

Discussion in 'rFactor 2 General discussion (Discussioni)' started by Max Angelo, Sep 5, 2013.

  1. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    ISI ha pubblicato la nuova build 298.

    Il change log si trova a questo link

    http://rfactor.net/web/rf2/devscorner/rfactor2-build-notes/#298

    Qui il link per il download, compreso quello della demo aggiornata

    http://rfactor.net/web/rf2/rf2dl/

    Qui il thread internazionale

    http://isiforums.net/f/showthread.php/14938-rFactor-2-Build-298-Released

    L'auto update sarà disponibile appena possibile.
     
  2. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Ricordo agli host che le porte sono cambiate

    Giorni fa accennavo ad una nuova importante implementazione: si tratta di questa

    Tiim, nel thread internazionale, lo descrive così:

    In estrema sistesi: flessibilità del telaio, più accuratezza nella geometria delle sospensioni e nel "wheel rate"

    http://ita.proz.com/?sp=gloss/term&id=3617954
     
  3. gaevulk

    gaevulk Registered

    Joined:
    Apr 23, 2013
    Messages:
    55
    Likes Received:
    0
    io ho fatto l'aggiornamento tramite l'autoupdate e non parte neanche piu' il gioco,cosa posso fare?
     
  4. ~IsR~Barabba

    ~IsR~Barabba Member

    Joined:
    Oct 6, 2010
    Messages:
    1,160
    Likes Received:
    38
    Prova a scaricare la lite e sovrascrivi e vedi se parte.
    Cmq il consiglio e di installare la Build Pulita.


    Babs
     
  5. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Sono svariati utenti a riportare il problema, causato probabilmente dal launcher temporaneo che risolveva il bug del login "non ricordato" sopraggiunto dopo il cambio del server ISI.

    Il modo più sicuro per risolvere è installare la Lite completa.
     
  6. Taranta

    Taranta Registered

    Joined:
    Oct 5, 2010
    Messages:
    92
    Likes Received:
    5
    Cancellato il vecchio launcher e fatto l'autoupdate: funziona regolare.
     
  7. gaevulk

    gaevulk Registered

    Joined:
    Apr 23, 2013
    Messages:
    55
    Likes Received:
    0
    scusami taranta ma come hai fatto precisamente?
    se cancello il launcher mica parte rf2
     
  8. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    C'è da dire una cosa: nessuno dei tester interni ha notato il problema, ma tutti hanno un account dedicato per i test.

    Dopo il cambio del server ISI, alcune settimane fa, il nuovo launcher ha risolto il problema del login salvo quando noi interni passavamo dell'account pubblico a quello "test": il file rFactor.credentials veniva cancellato ed era necessario loggarsi manuamente, solo la prima volta prima di ricambiare account.

    In altre parole, tutti i tester hanno provato l'auto update, ma loggandosi manualmente e consiglierei di provare la stessa cosa, prima di installare la build completa: a launcher chiuso eliminate il file rFactor.credentials, in

    \AppData\Roaming\.rFactor\

    poi riaprite il launcher loggandovi manualmente (solo la prima volta, poi il login rimarrà memorizzato).

    Questa, in sostanza, è la procedura usata dai tester interni, con la differenza che rFactor.credentials a noi si cancellava da solo. :)
     
  9. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    E' stato riportato che Sears Point fa crashare la build 298.

    E' una delle piste più vecchie e probabilmente è sopraggiunto un problema di compatibilità.
     
  10. gaevulk

    gaevulk Registered

    Joined:
    Apr 23, 2013
    Messages:
    55
    Likes Received:
    0
    ho provato a cancellare il file di cui parlavi,anche loggandomi non andava,ho cercato di riattivare ma mi dice che ho superato il limite,vabbe' mi arrendo
     
  11. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Dopo aver cancellato il file delle credentials non è necessario riattivare, io ho scritto sopra

    Cmq, se hai riattivato 5 volte scrivi a support @ rFactor.net (l'indirizzo giusto è senza spazi tra il egno @) chiedendo il reset e indicando l'order number e/o l'indirizzo e-mail che hai usato per acquistare rF2.

    Se hai Sears Point toglila dalla cartella Packages ... basta la sua presenza per non far partire la build 298.
     
  12. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Dunque, i componenti o le mod che hanno una descrizione lunga più di 4.000 caratteri causano un CTD subito
    dopo il lancio ... in futuro il limite massimo di caratteri sarà limitato a 3000.

    La lista, parziale, di questi componenti comprende

    Sears Pont

    Lexus ISF

    National Stock Car Racing.
     
  13. Giuseppe Toscano

    Giuseppe Toscano Registered

    Joined:
    Aug 13, 2013
    Messages:
    99
    Likes Received:
    0
    come a molti non parte , ho disinstallato tutto , reinstallato ma non va ..................ho cercato la cartella appdata ma non riesco a trovarla ho win7
     
  14. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Sembra che anche Superleague Formula 2009 mod abbia una descrizione superiore ai 4.000 caratteri.

    Se non fosse chiaro, questi componenti, in attesa di un loro aggiornamento che ne abbrevi la descrizione, vanno disinstallati e fisicamente rimossi dalla cartella Packages.

    Lista aggiornata:

    Sears Pont

    Lexus ISF

    National Stock Car Racing

    Super League Formula
     
  15. Big Engine

    Big Engine Registered

    Joined:
    Feb 5, 2013
    Messages:
    208
    Likes Received:
    0
    Per chi ha problemi di installazione scrivo i passaggi che ho seguito, magari vi fanno comodo

    disinstallato rf2, non ho toccato nulla nella cartella, installata la lite, reinseriti nome utente e password nel luncher

    Così facendo mi ritrovo con il sim che si avvia e tutte le mod installate (non so i plugin in questo momento non ho tempo di provare ad avviare una partita)
     
  16. GTClub_wajdi

    GTClub_wajdi Registered

    Joined:
    Feb 28, 2012
    Messages:
    3,013
    Likes Received:
    348
    Usato l'autoupdate e tutto e' filato bene! ho notato un incremento importante del fps!
    Permane il problema dei spechietti che uccidono gli fps!
    Cmq, buon lavoro ISI:)
     
  17. Rik

    Rik Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,174
    Likes Received:
    9
    Tutto bene anche qui.

    Ho scaricato la versione "content installer"
    ho disinstallato rf2 tramite pannello di controllo "disinstalla applicazioni"
    ho eliminato manualmente le cartelle residue
    non ho eliminato la cartella nascosta in documenti con le credenziali
    ho installato la 298
    nessun problema

    rF2 si avvia tranquillamente senza problemi.

    edit: sia come client che come host.

    :D
     
    Last edited by a moderator: Sep 6, 2013
  18. Eternum

    Eternum Registered

    Joined:
    Jan 9, 2012
    Messages:
    125
    Likes Received:
    0
    1) Disinstallata completamente vecchia build.
    2) Installata nuova versione

    Il Dedicated non parte, da solo questo errore:

    "rFactor2 has stopped working"

    Problem signature:
    Problem Event Name: BEX
    Application Name: rFactor2 Dedicated.exe
    Application Version: 1.2.9.8
    Application Timestamp: 52278d0f
    Fault Module Name: rFactor2 Dedicated.exe
    Fault Module Version: 1.2.9.8
    Fault Module Timestamp: 52278d0f
    Exception Offset: 0008835e
    Exception Code: c0000409
    Exception Data: 00000000
    OS Version: 6.1.7601.2.1.0.1296.17
    Locale ID: 1033
    Additional Information 1: 1783
    Additional Information 2: 17839cbbbaa11ecf2b97cb7754bcce6f
    Additional Information 3: d50b
    Additional Information 4: d50bf2046bbbedbd885ce917833c68c5
     
  19. fazerbox

    fazerbox Registered

    Joined:
    Oct 6, 2010
    Messages:
    187
    Likes Received:
    8
    Stesso problema!
    L'upgrade è stato fatto dalla versione precedente.

    Ho poi rimosso l'intera cartella rFactor2 ed installata la versione LITE. rFactor2 continua a non partire.
    Ho installato una vettura (CLIO) ed una pista (Limerock) . rFactor2 non parte lo stesso.

    A questo punto aspetto paziente una soluzione.

    Edit:
    Dimenticavo: Win7 64bit

    RISOLTO: Eliminati i file
    Megane_at_SearspointRW_v135.rfmod
    SearspointRW_v135.rfcmp

    Adesso il gioco parte tranquillamente.
     
    Last edited by a moderator: Sep 6, 2013
  20. Turbigno

    Turbigno Registered

    Joined:
    May 13, 2013
    Messages:
    26
    Likes Received:
    0
    Salve, anche io ho problemi, ho aggiornato con l'autoudate e non va più, disinstallato tutto e la nuova installazione lite funziona, ma è vuoto perchè ho cambiato directory, inizio ad installare macchine e piste, escludendo ed eliminando quelle segnalate che crashano, il gioco non va più, mi sa che sono molte le piste e mod che crashano :(

    Ora scarico la versione full e copio dentro la cartella Userdata speriamo bene, per ora la package provo a lasciarla vuota

    Edit:

    Installato la versione full e funziona
    Copiato la cartella UserData e funziona
    Copiato la cartella Packages (senza installare niente) e crasha! Il problema sta qui dentro !! Come faccio a capire le descrizioni che superano i 4000 caratteri, dove si vede?

    Edit:
    Ho risolto :) cancellate anche questa: SearspointRW_v135

    Super League Formula non mi da problemi
     
    Last edited by a moderator: Sep 6, 2013

Share This Page