Rfactor2 The VR thread -settings & tips

Discussion in 'General Discussion' started by Adrianstealth, Apr 30, 2017.

  1. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    196
    Likes Received:
    57
    Good news, I'm running to download it, thank you very much, I had reviewed it recently (v0.6.3) and it was still giving me problems.
     
  2. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    196
    Likes Received:
    57
    After last night's unsuccessful tests, I give up and leave this. This circuit is impossible for me.

    With everything on Very Low or off in rF2 (When I usually run medium/high), with high FSR compression, no SS on Oculus Home (When I usually run 4480x2256 at 72Hz) and with the game more like OutRun than a Sim of the 21st century, it continued with the problems.

    In the areas where there are "no problems" everything is smooth, but in the ones that are, no matter what I do, it is horrible in VR.

    I leave you a screenshot that does not show how bad it looks, nor how bad it flows, but so you can see the SteamVR graph.

    Thanks to all for the help.

    https://drive.google.com/uc?id=1OGo...Ehkzh6&authuser=jopame@gmail.com&usp=drive_fs
     
  3. Comante

    Comante Registered

    Joined:
    Nov 20, 2013
    Messages:
    1,503
    Likes Received:
    1,018
    You can reduce rear mirror clipping distance, it help a lot, always.
     
  4. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    196
    Likes Received:
    57

    Last night I tried to download the latest version but I couldn't find it and the issue with the esc key is still active, so I understand that the thing is still to be solved.

    Also trying to test the latest DLL didn't work properly and broke my Oculus Home App on PC.

    Where have you followed this and have the version correctly working?
     
  5. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    196
    Likes Received:
    57
    I tried various configurations of the player.json regarding the graphics, I even disabled the mirrors, but nothing seems to be enough, in fact, in the video you can see that most of the time the graphic is yellow, the charge or delay does not exceed the limit of the red line.

    I only have to try one thing, change to 90 Hz to see if with ASW of 45 it is more bearable. Although I doubt it's an ASW problem...
     
    Gilles Benoit likes this.
  6. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    620
    Likes Received:
    181
  7. justposted

    justposted Registered

    Joined:
    Oct 14, 2020
    Messages:
    90
    Likes Received:
    65
    This works here, thanks. No more pit/escape crash. Nice.
     
  8. JParra

    JParra Registered

    Joined:
    Jul 13, 2017
    Messages:
    196
    Likes Received:
    57
    Can you tell me where to see the download and installation instructions?

    Thank you
     
  9. justposted

    justposted Registered

    Joined:
    Oct 14, 2020
    Messages:
    90
    Likes Received:
    65
    Go to the link. Scroll down to the "Per-game installation." Let us know if you get stuck.
     
  10. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,934
    Likes Received:
    1,527
    does it work with pimax 8k plus onwards?:rolleyes:
     
  11. Andrea Frollo

    Andrea Frollo Registered

    Joined:
    Aug 30, 2021
    Messages:
    35
    Likes Received:
    10
    For me no results. It gives me an error on startup.
     
    juanchioooo likes this.
  12. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,934
    Likes Received:
    1,527
    The same thing happened to me, I thought I was doing it wrong...
     
  13. Andrea Frollo

    Andrea Frollo Registered

    Joined:
    Aug 30, 2021
    Messages:
    35
    Likes Received:
    10
    I was not wrong because with another version of the OPENVR file it works, apart from the problem of the esc key without removing the visor.
     
  14. Magus

    Magus Registered

    Joined:
    Jun 27, 2012
    Messages:
    835
    Likes Received:
    527
    I'm running a HP revreb G1, I've installed the OpenXR Toolkit v1.1.0 & Jabbha's OCXR_WMR_ACC_0.6.3. (I've installed the files from the latter into the rF2 BIN64 folder).

    I can use the toolkits features in the rF2 menu screen to set my desired preferences. However, with the Opencomposite_rFactor2 ticked, rF2 just closes/crashes once it reaches 100% on the loading screen and wants to transition into the standings/game screen.

    Is there something up with my system or does this version of the openvr_api.dll & opencomposite.ini not work with the toolkit 1.1.0 on WMR headsets (specifically HP G1)?
     
  15. Radkappe

    Radkappe Registered

    Joined:
    May 31, 2017
    Messages:
    18
    Likes Received:
    14

    There's a new version of OC from Jabba: https://gitlab.com/znixian/OpenOVR/-/tree/openxr
    I'm using the Per-game installation. Try this one. The old ocxr_wmr_acc isn't supported anymore. I'm using the new dll and i getting good results. But don't use OpenXr Toolkit. It's crashing right on start... unfortunately.:(
     
    Magus and juanchioooo like this.
  16. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,934
    Likes Received:
    1,527
    in the game how to open the OpenXr settings?
    I try to work with pimax but I can't. Does anyone know how to do it?
     
  17. GTClub_wajdi

    GTClub_wajdi Registered

    Joined:
    Feb 28, 2012
    Messages:
    3,167
    Likes Received:
    524
    Open composite isn’t compatible with openxr toolkit.
     
    Magus likes this.
  18. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,934
    Likes Received:
    1,527
    I think that with Pimax neither
     
  19. BamBam

    BamBam Registered

    Joined:
    May 1, 2022
    Messages:
    2
    Likes Received:
    0
    I have a 5800X3D, and before that I had a 5800X. I remember that playing Rfactor 2 in VR with the 5800X and my 1080Ti on a Oculus Rift CV1 was not easy at all. At LeMans I remember not being able to play with more than 20 visible cars, otherwise the framerate would drop below the 45FPS of ASW's threshold and a lot of times it would freeze the game, forcing me to close Rf2 and restart. It was a pain.

    Now with the 5800X3D, I was testing LeMans a few minutes ago with 50 visible cars and I could play with a very smooth performance (except for watching the replay on some corners of the track; but thats the GPU, not the CPU).

    I think I can still push to more than 50, but it's late night here and I need to get some sleep.
    Mind you that I did not tested the OpenComposite dll on RFactor 2 yet bacause I just found out about it while reading this thread, so tomorrow I'm gonna try above 50 cars for sure to see how it goes, and I'll report the result here on this thread.

    The 5800X3D its a miracle for simulators. I've been seeing reports about ACC, R3E, MSFS 2020, iRacing, Star Citizen... And all those games got a very good performance bump with this CPU, even compared to the 5800X. I highly recommend it.
     
  20. BamBam

    BamBam Registered

    Joined:
    May 1, 2022
    Messages:
    2
    Likes Received:
    0
    I'm not a youtuber by any means, but I've recorded a video to show how well the new AMD Ryzen 7 5800X3D performs while running simulators like Rfactor 2 in VR using an Oculus Rift CV1 and a Nvidia 1080 Ti. It's not me driving, I let the ai control the car so I could focus on the camera controls. Its an endurance race at Nordschleife with 80 cars controlled by the AI at 2PM with Cloudy weather. I also skipped the loading screen.

    For those that don't know how the Rift works and to keep it simple: ignore the performance headroom graph; as long as the App Framerate does not dip below 45, you're not gonna get performance issues due to the way Oculus Rift works with it's ASW feature. It means that the CPU and the GPU can handle above 45 FPS and it feels like 90FPS due to the way ASW works. It only dips below 45 when watching the replay. During the race, it never dips below 45, and that's what matters. IMPORTANT TO MENTION: if it dips below 45 with the Rift while on ASW mode, you can see artifacts, WHICH DID NOT HAPPEN HERE at least in my case.

    I did this without using the Open Composite (I forgot about it, sorry). I imagine that performance could be improved by using it, but as I could handle a race at Nords with 81 cars, I don't see the point of using it unless I want to push the simulation even harder.

    TLDR: the 5800X3D does improve performance in simulators like this one by a lot. Other examples are: Raceroom, MS Flight Simulator 2020, Assetto Corsa Competizione, iRacing, Star Citizen, and many other games (those are the ones I've seen reports from people while searching for benchmarks).

    At the moment of this post, the video is still being processed and 4K will be available soon.


    EDIT:
    I recorded a video of the same race with ASW disabled as requested by people on reddit. It always drop below 90FPS because I'm bottleneck by my GPU, but never below 45. With the 5800X it would drop below 45, no matter what. The video It's still being processed by youtube, so please wait a little. Here is the link:

     
    Last edited: May 2, 2022

Share This Page