[REL] rFactor2 Log Analyzer ver. 2. With offline and league Championship Manager

Discussion in 'Other' started by Nibo, Apr 15, 2015.

  1. Arijima

    Arijima Registered

    Joined:
    Sep 21, 2019
    Messages:
    4
    Likes Received:
    0
    I wanted to know if it was possible to remove a driver/team from the standings or from the race log so he won't show up on the race or the championship
     
  2. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    There is no possibility to remove driver from log with r2la. But you can try removing driver block from xml file with some text editor. You need to remove all lines starting with <driver> and ending with </driver> for specific driver name. This block look like this:
    Code:
    <Driver>
    <Name>Fernando Alonso</Name>
    ...
    ...
    ...
    </Driver>
    
    Remove all this lines. Save changes. Press "refresh" in r2la to pick up changes.
    But I can not guarantee that just removing some driver block will not cause some issues when r2la will try to parse this file. So keep original copy of file before changing it.

    Alternatively, you can "Clone" file in r2la Result Viewer. Then select cloned file, press "Edit", and then "DQ" (disqualify) that driver. He will still appear in results and tables, but will not affect your championship.
     
  3. WSS_Mike

    WSS_Mike Registered

    Joined:
    Sep 19, 2019
    Messages:
    8
    Likes Received:
    3
    Is there an overview somewhere with all available json calls?

    P.S.: you're doing an awesome job! It's an amazing tool
     
  4. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    On web2py Help page at the bottom, last two paragraphs.
    On web2py About page, scroll to "Changelog for older versions" button, press it to unroll all changes, then use your browser on page search for "json" word.
     
    WSS_Mike likes this.
  5. ARCADIOS

    ARCADIOS Registered

    Joined:
    Sep 29, 2019
    Messages:
    1
    Likes Received:
    0
    hi! i use till last night log analyzer without problem. today i update to the latest version and i have many problems. i get errors
    Traceback (most recent call last):
    File "D:/web2py_2.14.6/applications/r2la\compiled\controllers.default.index.py", line 249, in index
    File "D:\web2py_2.14.6/applications/r2la/modules\la_core.py", line 147, in import_logs
    TypeError: cannot concatenate 'str' and 'NoneType' objects
    and
    Traceback (most recent call last):
    File "D:/web2py_2.14.6/applications/r2la\compiled\controllers.default.index.py", line 54, in index
    AttributeError: 'NoneType' object has no attribute 'track_names'
     
  6. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    Maybe something went wrong on upgrade? Are you sure you upgraded correctly? You can not just overwrite old files with new ones. You have to unzip new clean version of r2la and start it from scratch, then import champs from old one if you had champs Correct upgrade procedure is described here - https://steamcommunity.com/sharedfiles/filedetails/?id=553607744, look for "Upgrading to newer version of r2la".

    Try unzipping latest version of r2la to some new folder, start it from scratch and see if you still get errors. If yes, then look with what log files you have errors and send that log files to me.
     
  7. TOCA2FREAK

    TOCA2FREAK Registered

    Joined:
    Apr 6, 2011
    Messages:
    924
    Likes Received:
    124
    Davvid likes this.
  8. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    I tried that link and it was long to get initial request, but then all pages load fast. It does not look to me like its r2la that is slow. Maybe it is something to do with web2py server and your physical server or ISP/router config.
    You can try stopping r2la server, maybe restarting your machine, then starting again and look if pause on first request is gone.
    Or you can try starting r2la not with r2la.bat (which uses web2py gevent server), but with rF2 Log Analyzer ver. 2.058.23\web2py\web2py.exe, which uses web2py Rocket server (select public IP and press "start server", ignore "no password..." message). Maybe different server will act better.
     
  9. TOCA2FREAK

    TOCA2FREAK Registered

    Joined:
    Apr 6, 2011
    Messages:
    924
    Likes Received:
    124
    I use "r2la_live_timing.bat" to launch r2la as I like to have the live timing working. How can I go about launching r2la like you have suggested and have live timing working?

    Thanks.
     
  10. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    r2la_live_timing.bat and r2la_telemetry.bat use only web2py Rocket server and can not work otherwise. So in your case you can only try to restart r2la (with PC reboot as I wrote earlier). You can also try to start r2la by r2la.bat and see if it works without lag, then at least you will know if its the problem with web2py or something else. But I can tell you, that other then restarting web2py server, I can not propose much solutions if its some incompatibility with web2py and your system/internet config.
     
  11. Alek

    Alek Registered

    Joined:
    Oct 6, 2010
    Messages:
    109
    Likes Received:
    5
    Hi Nibo,
    I'steel trying to do working LA with Livetiming. I have multiple server on the same PC, so I set to 1 the read_global_memory setting in live_timing_settings.json file. Also turn to 1 the value of DedicatedServerMapGlobally parameter in CustomPluginVariable.json file.
    When I start live_timing bat the command Windows of read global memory go close. What's the problem? How I can fixi it? Thanks
     
  12. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    Do you mean that cmd window closes right away after you launch r2la_live_timing.bat? Look if file rF2 Log Analyzer ver. 2.058.23\web2py\r2la_live_timing.log exists and copy here what is written in it.
     
  13. TOCA2FREAK

    TOCA2FREAK Registered

    Joined:
    Apr 6, 2011
    Messages:
    924
    Likes Received:
    124
    Loading it with web2py.exe has made it load faster ;)
     
  14. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    web2py.exe uses same server that r2la_live_timing.bat. Maybe you just needed a restart, try closing web2py.exe and starting r2la with r2la_live_timing.bat again.
     
  15. Alek

    Alek Registered

    Joined:
    Oct 6, 2010
    Messages:
    109
    Likes Received:
    5
    Yest it open and close immediately after launch the bat.
    Log doesn't exist. it's relevant that I named the folder "rF2 Log Analyzer" removing the version part?
     
  16. Alek

    Alek Registered

    Joined:
    Oct 6, 2010
    Messages:
    109
    Likes Received:
    5
    @Nibo : I set WEb2py to run as admin and now work, it stay open.
    However no livetiming session was found. Steel polling…
    Having more server opened, I set to 1 the "read_global_memory" parameter in "live_timing_settings" file. Also all server has in his json file the value 1 in "DedicatedServerMapGlobally" parameter of CustomPluginVariables.json.

    This is the complete script:
    },
    "rFactor2SharedMemoryMapPlugin64.dll":{
    " Enabled":1,
    "DebugISIInternals":0,
    "DebugOutputLevel":0,
    "DedicatedServerMapGlobally":1,
    "EnableDirectMemoryAccess":0
    }

    I also can say to you, if usefull, if I set to 0 "read_global_memory" and 0 to "CustomPluginVariables", only the first serve live timing works.

    I don't know what else to say… :)
     
  17. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    Do you launch rFactor2 server from different windows user accounts or from one account? Try launching all your rFactor2 servers and r2la as admin, from the same windows user account. Try this with DedicatedServerMapGlobally and read_global_memory set to 0, then try set both parameters to 1. It should work with both on 0 (default) if you use one windows user account to launch everything.
     
  18. Alek

    Alek Registered

    Joined:
    Oct 6, 2010
    Messages:
    109
    Likes Received:
    5
    tried: in both case, lunched as admin, work only 1st server, as with no admin option :confused:.
    The account is one!
     
  19. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    2,017
    Likes Received:
    726
    Unfortunately, I can not think of anything more to try. Maybe check one more time if all rF2 servers CustomPluginVariables.json have "Enabled":1 for rFactor2SharedMemoryMapPlugin64.dll, but I think you already did that... Make sure you closing all rF2 and r2la servers before changing json files. Make sure that you are launching everything as a windows user with highest possible privileges.

    For some reason other rF2 server processes outputs are not available in shared memory. I had similar reports before, it seems that different windows versions have different memory access permissions and stuff like that. I know very little on this system management topic.

    You can make sure that all your rF2 servers are outputting info correctly by launching every rF2 server separately and see if they work on their own. If yes, then its most probably some specifics with how your Windows manages shared memory.
     
  20. Alek

    Alek Registered

    Joined:
    Oct 6, 2010
    Messages:
    109
    Likes Received:
    5
    ok, however thanks for your support!!
     

Share This Page