rFactor2 is shutting down after 100 minutes suddenly.

Discussion in 'Technical & Support' started by yashiman, Mar 26, 2022.

  1. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    143
    Likes Received:
    309
    Report

    - delete old plugins and remake CustomPluginVariables.JSON.
    - Reseted the virtual memory for Windows manager.
    (Same as last time.)


    3:09:45~

    Yesterday's race was important, so I rebooted before the race session.
    Thanks to that, I completed the race.
    But, I watched the replay file after the race, rF2 shutted down suddenly as usual.
    (see first trace log)


    4:56:45~
    Afterwards, I watched more.
    However, shut down again.
    (see next file)

    Last few weeks, I tried to find a solution for the Plugin side.
    But now, I consider the series of events is not relevant to Plugin.

    The trace log said controller device error at shutting down.
    My controller is Fanatec V2.5, It's general.
    And I often play other sim (RBR, DR2, ATS etc) on this device, it's not bad.
    I find it hard to believe this is bad.

    Next
    -Remake Controller.JSON and profile files.
    -The driver file reinstall.

    And hopefully this will be resolved in the next build.
     

    Attached Files:

  2. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,612
    Likes Received:
    3,254
    It may not be a bad controller, but your USB hub may be momentarily interrupted, possibly due to poor power or worn connections in the port. rF2 may be more sensitive to such disruptions.
    Try and remove any other USB connected devices that are not important to your racing. Also try using different USB hubs. The older Fanatec may work better in a 2.0 USB connection vs a 3.0 USB port.
     
    ebeninca and yashiman like this.
  3. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    143
    Likes Received:
    309
    Report

    -Change the USB port for Fanatec CSW2.5.
    -Test the Release Candidate (Build1128).

    https://www.twitch.tv/videos/1457653012

    I tried that davehenrie told "change port" today.
    And I complete 3 hours over for the first time in 4 month.
    I will continue this setting next week.

    However this is a new Release Candidate.
    This may have been fixed in the new build.
     

    Attached Files:

    ebeninca and davehenrie like this.
  4. Craigbowie

    Craigbowie Registered

    Joined:
    Dec 15, 2017
    Messages:
    36
    Likes Received:
    13
    Could someone please have a look at this and see what the issue is... shut down after 1.5hrs of playing.. Cheers
     

    Attached Files:

  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,474
    Likes Received:
    5,312
    Unlike the OP your crashes seem to vary wildly in timing, and on the last page you seemed to indicate overheating was a factor.

    The trace has a number of errors (mainly content related) but basically all traces do. The crash point isn't very special so just looks like something has crashed somewhere and taken the game with it. Or the repeated tyre brand errors have eventually killed rF2, hard to say.

    I would disable your addon plugins and try to use standard content (cars and tracks) if you want to attempt to rule those out as factors, but if you're taking 1.5 - 6 hours before crashing it's probably going to be frustrating.

    Since heat was evidently a factor, are you monitoring temperatures to make sure they're staying in good ranges? And have you run any ram tests?
     
  6. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    980
    Likes Received:
    1,022
    I’m surprised that Windows shuts down just rFactor when your computer gets hot, I’d expect it to shut down completely. Identifying what’s causing it to overheat would take fairly smart software.
     
  7. Craigbowie

    Craigbowie Registered

    Joined:
    Dec 15, 2017
    Messages:
    36
    Likes Received:
    13
    I made some changes this is again after 1.5hrs... is there something different????
     

    Attached Files:

  8. Craigbowie

    Craigbowie Registered

    Joined:
    Dec 15, 2017
    Messages:
    36
    Likes Received:
    13
    Yeah its a very strange situation.... since i found out about the front cover last week.. it ran for 6.5hrs with no issues... i did change some graphic settings after that... reverted them for the last Trace file... and cannot get more than 1.5hrs... so hoping the last trace file may shed some light on the problem.. as it looks different to the earlier trace file!
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,474
    Likes Received:
    5,312
    It's not really much different, no. It just ends earlier.

    What's your controller situation?

    You could try disabling plugins (I mean: rF2SIMDashboardPlugin, rFactor2SharedMemoryMapPlugin64), running standard content (not Townsville 2012 etc), and not having any controllers plugged in. Not much fun to drive obviously, but right now there are too many unknowns.

    Are you monitoring temps and ram usage? Have you done any RAM diagnostics?

    *have you checked windows event viewer to see if there are any messages about rF2 shutting down? Or anything else at the same time?
     
  10. Craigbowie

    Craigbowie Registered

    Joined:
    Dec 15, 2017
    Messages:
    36
    Likes Received:
    13
    So my controller situation is Fanatec CSW 2.5, Simworx pedals, jinx shifter. I really dont think its the plugins, with the front cover off the temps are not high, checked windows event logs, nothing critical in there, nothing that points to the computer shutting down RF2.
    Crazy thing is last week i ran it for 6.5hrs with no issues, i did make some changes in the graphics nothing drastic and now wont run for more than 1.5hrs. it just drops RF2 back to desk top.
    As i play next week i will keep putting up the trace files and see if you guys can find a pattern!
     
  11. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    143
    Likes Received:
    309
    Report

    -Change the USB port for Fanatec CSW2.5.
    -Test the Release Candidate (Build1128).

    I continued the same conditions last week.
    rF2 completed 2 hours 2 days in a row.

    I will revert to build1126 today.
    The USB port ? or new Build ?
     

    Attached Files:

    ebeninca likes this.
  12. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    143
    Likes Received:
    309
    Report

    -same conditions last week.

    >I will revert to build1126 today.
    I could not test to build 1126 for almost servers updated to 1128 in Japan.

    I tried to return the USB port, but it is in good 2 times.
    The test is not perfect, however, My rF2 is in good condition.

    The cause is unknown. But, I will no longer be bothered by this event.

    I would like to thank all those who have given me so much advice.
     

    Attached Files:

    ebeninca likes this.
  13. Kurou62

    Kurou62 Registered

    Joined:
    May 5, 2022
    Messages:
    1
    Likes Received:
    1
    I had the same phenomenon
    I don't know if it's the same cause
    It has been occurring since May 3rd.
    It happened on Yashiman's server


    PCspec
    CPU:intel i9 12900K
    RAM: DDR4 4000Mhz 32GB
    MB:ASUS ROG Strix Z690 A Gaming D4
    GPU:RTX3090
    OS:Windows 10
    controller:Fanatec DD2

    Game Build:1128
     

    Attached Files:

    yashiman likes this.
  14. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    143
    Likes Received:
    309
    This is the same day's my trace log.
    During this race, I did not CTD so I completed the race.
    But, this day's race, some drivers had lag like the iR's netcode.
    And some people could not join the server smoothly.

    Build1128 is so good. but I'm worried.
     

    Attached Files:

  15. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    625
    Likes Received:
    1,804
    For people who are having over heating problems, the program featured in this video could be of help. It's a program that enables you to control all of your fans in your computer easily. I've been using it since 22-April with out any problems, it works very well, my cpu and gpu now runs cooler. It only takes few minutes to setup, I personally don't care about fan noise because I use headphones. Hope this may be useful to some of you.
     
    yashiman likes this.

Share This Page