[SOLVED] rFactor2 is not starting anymore (black screen)

Discussion in 'Technical & Support' started by Racefreak1976, Jun 4, 2017.

  1. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    Hello everyone,

    for about a week now I can't start rFactor2 anymore. The launcher does it's thing as usual and after the splash image, when the game is supposed to start I get nothing but a black screen (sometimes white).
    The only way to exit the game is through taskmanager in the process tab.

    I have recently bought a USB hub. This is the only thing I have changed to my system as far as I remember.

    Any ideas?

    o_O
     
  2. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,165
    Likes Received:
    333
    Pff, that's something.....
    Only thing I can think of, is maybe you have choosen some resolution for the game that is not supported by your monitor?
    Something like that or your vga drivers?

    If I am not mistaken; the point where it gets black, isn't that the same point where the vga kicks in?
     
  3. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    My resolution is set to 1920x1080. The launcher doesn't let me change it and I can't access the in game options, obviously.
    I did not change anything in the settings before. Only thing that has changed is hardware (USB hub).
    Not having any issues with any other game as of now either.
     
  4. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,165
    Likes Received:
    333
    It was just a gamble; could have helped you out but it didn't. I have no idea anymore.
     
  5. boxer

    boxer Registered

    Joined:
    Aug 22, 2012
    Messages:
    441
    Likes Received:
    133
    If you have a firewall try re-setting the firewall settings for rF2 in the FW software.
    or just delete the entry for rF2.
     
  6. TJones

    TJones Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,014
    Likes Received:
    190
    @Racefreak1976 - You can't change resolution? That's strange already.
    Is your display adapter correctly identified by Launcher -> Video settings?
    Some things you can try:
    - If posible try some different Video settings.
    - remove rF2 plugins
    - rename/move Config.ini and/or Player.json
    - try to start developer version
    - Verify game files by Steam
    - Roll back to a former game version.

    good luck!
     
  7. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    I verified the files with Steam. One file was replaced. I did a rollback to 1108 (not open beta). I deleted CBASH and SHADERS. No Plugins are active. Nothing helps.

    ?
     
  8. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,198
    Likes Received:
    1,271
    Have you removed the usb hub?
    Every else works fine? Other games?
    Last resort complete new install?
     
    Last edited: Jun 5, 2017
  9. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    All other games work flawless. Did just unplug the hub and.... rFactor is now, at least, officially crashing with the following message:

    Problemereignisname: BEX64
    Anwendungsname: rFactor2.exe
    Anwendungsversion: 1.1.0.8
    Anwendungszeitstempel: 5930909c
    Fehlermodulname: StackHash_1dc2
    Fehlermodulversion: 0.0.0.0
    Fehlermodulzeitstempel: 00000000
    Ausnahmeoffset: 0000000000000000
    Ausnahmecode: c0000005
    Ausnahmedaten: 0000000000000008
    Betriebsystemversion: 6.1.7601.2.1.0.256.48
    Gebietsschema-ID: 1031
    Zusatzinformation 1: 1dc2
    Zusatzinformation 2: 1dc22fb1de37d348f27e54dbb5278e7d
    Zusatzinformation 3: eae3
    Zusatzinformation 4: eae36a4b5ffb27c9d33117f4125a75c2

    Should I make a backup of the packages folder before reinstalling? It's 33 GByte. Could the error be caused by a mod?
     
  10. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,198
    Likes Received:
    1,271
    Move the whole install if need. Not sure how steam works. If you unsub from everything and move things over not how steam will deal with it. Maybe others can say.
     
  11. TJones

    TJones Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,014
    Likes Received:
    190
    Please try to start the developer version of the game, in case rF2 start here it's most likely a problem with some sort of config file, plugin or mod.
    You can also try to start in 32bit mode.
    So if you unplug your usb-hub you get an app-crash message, and with usb-hub not, is it reproducible?
    Did you have to install some sort of new/different usb-driver for your hub?
    Are you now able to change graphics-settings in the launcher with dx9 version?
    Did you make virus/malware scan?

    Google search about "StackHash_1dc2" and "BEX64" give an indication that some sort of software is interfering with rF2.
    OSD software like nvidia Experinece, Riva tuner, Fraps could cause this.
    Source: https://www.reddit.com/r/GrandTheft...i_found_the_fix_for_the_bex64stackhash_error/
     
    Racefreak1976 likes this.
  12. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    No drivers were installed with the hub. Not manually at least.
    Screen resolution is the only thing I can't change. Things like AA and PP I can still change and have tried that.
    Does this mean, I should uninstall any OSD software? None of those is actively running in the background (except Nvidia Exp but not Shadowplay) but iirc the problems started when I last started rF2 while DXtory(Fraps-like software) was running. So it might as well be the root of the problem.
    The thing is, I have since not started DXtory together with rF2 again, yet it's still not working.

    I'm confused...

    Ok, I just tried DX9 and dev mode in both cases it crashes.

    ???
     
    Last edited: Jun 5, 2017
  13. TJones

    TJones Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,014
    Likes Received:
    190
    Sometimes a virus scanner faulty identify clean files as infected and delete them. I use Kaspersky and had such issues two or three times. The fact that Steam had to add one file might be an indication here. So if possible, take a look into your virusscanner history.

    You can still try to disable nvidia experience, however i use it without any problem.
    You can also go through different tasks in the task-manager and kill such which "might interfer" with rF2, so something with "DXtory" in the name should be suspiciuous, or similar software. But be carefull, you can also desabilize your system if you kill the "wrong" task.
    Completely deinstall DXtory and restart system, might also be a more secure option here.
    BTW did rF2 start in window or borderless mode?

    EDIT: Did a google search "DXtory rFactor2", seems like there's indeed a problem with DXtory in combination with rFactor2 so deinstalling of DXtory should solve your problem.
    source: http://forum.exkode.com/index.php?topic=896.0
     
  14. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    I'm running in borderless. Uninstalling DXtory is out of the question for me. I bought this because of rF2! For making videos and such.
    However, DXtory is not always on. Only when I need it to be.

    I did a complete reinstall of rF2 just now. Same problem. I have subscribed to a lot of workshop items. So it is not exactly a "clean" install.

    I'm very grateful for all you guys trying to help me out, but I'll just give up and wait for a patch or whatever. Maybe this will fix it.
    Until then, I'll quickly run over to S397 offices and smash some windows. Hahaa! J/k. Don't sue me S397 if there actually are any broken windows. It wasn't me. ;)
     
  15. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    It works!

    Here's what I did:
    I switched off the USB slots on my hub which had my Saitek X52 Pro joystick connected and also my G25. Must have been a conflict there.
    Next step will be to switch the G25 on again and see if it's still working.

    EDIT: Ok, the problem definitely comes from the hub. G25 switched on, rF2 doesn't start. Off(whilst still in blackscreen mode), rF2 starting normally. Back on, rF2 keeps working normally but detects XBox controller as main device.

    Weird, but at least it lets me configure the G25.
     
    Last edited: Jun 9, 2017
    Louis and Nibiru like this.
  16. Yotan

    Yotan Registered

    Joined:
    Jan 17, 2012
    Messages:
    83
    Likes Received:
    6
    I was troubled by blackout only after returning from sleep, but once I pulled out logitech G27's USB plug and plugged it back in, It improved.

    The compatibility between Windows 10 ver1709 and G27 driver may be bad.
     
  17. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I use old G27 drivers. Most updated ones won't recognize my wheel despite Windows10 does.

    My colleague in the touring league has W10 a G27 like myself and the same problem.
    Unadressed by Microchoft/Logitech for months now
     

Share This Page