Rfactor2 does not launch

Discussion in 'Technical & Support' started by nicospezia, May 26, 2021.

  1. nicospezia

    nicospezia Registered

    Joined:
    May 26, 2021
    Messages:
    1
    Likes Received:
    0
    Hi everyone. I am writing because I cannot launch Rfactor2. Some time ago I downloaded the demo version of Rfactor2 from Steam and I was able to launch the game (demo version), even though a popup always appeared before the game launching. The popup said "insufficient video memory detected - 512mb Minimum Required. Do you want to continue anyway?". If I selected yes the demo version started.
    Now I bought the complete Rfactor2 version: when I launch the game the same popup appears, but the game does not want to start. I have an ASUS Vivobook laptop equipped with 16 GB of RAM, an AMD Radeon video card of 512 MB video memory (which is the minimum video memory game requirement).
    Looking into the game files I noticed that Rfactor2 reads a video memory of 496 MB even though my PC has 512. However, in my opinion, the very weird thing is that I was ( and I currently am ) able to play the demo version, but the complete game does not work. How is it possibile? Do you think this problem can be fixed? Do you have any suggestions? Maybe I have to "tell" to Rfactor2 that I actually have a 512 MB video card memory, but I don't know how to do it, neither if this is possible.
     
  2. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    525
    Likes Received:
    126
    Hi,

    The demo is a old version of rfactor2, which had lower system requirements compared to the latest full version.
    You need to check your laptops manual, to see if it allows you to increase video memory in the bios to 1-2gb.
     
  3. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,425
    Likes Received:
    1,485
    Try launching rF2 from Steam Library.
    Select "Launch rFactor 2 Graphics Configuration"
    Click "Play"
    Check if your GPU is selected, instead of "Auto".
    Click "OK"
    And launch rF2 again.
    If you get the same error, then you'll have to do what Mangoletsi sugested.
    And if you can't do this, i think that your system specs are not enough to run rF2.
     

Share This Page