rFactor2 Build 156 dedicated server problem

Discussion in 'Hosting Help' started by Marcing, Feb 28, 2013.

  1. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    That would be great.. I may have some grey hair but I think it's worse now :)

    Personally, we shouldn't be doing all this fart arsing around with +path etc etc when previously it would run straight from the Core..
     
  2. Diablo

    Diablo Registered

    Joined:
    Jan 20, 2013
    Messages:
    404
    Likes Received:
    0
    Damn, here I was, typing away, and then this. ;)
     
  3. Jim Beam

    Jim Beam Registered

    Joined:
    Oct 5, 2010
    Messages:
    824
    Likes Received:
    10
    cheers for your help btw Diablo :cool:
     
  4. Diablo

    Diablo Registered

    Joined:
    Jan 20, 2013
    Messages:
    404
    Likes Received:
    0
    You´re very welcome. ;)
     
  5. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    For people who have problems.. here is a simple guide to follow that will fix your 'missing sounds' issue..

    The Start in: line.. Mine had rFactor2\Core Removing the Core so it just read (install location):\rFactor2 worked..
     
    Last edited by a moderator: Mar 1, 2013
  6. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    Thank you anyway Diablo for trying to help.. I was lost..
     
  7. Diablo

    Diablo Registered

    Joined:
    Jan 20, 2013
    Messages:
    404
    Likes Received:
    0
    I don´t know what you do, but it works for me, have a look at this newly created Wiki article.

    Cheers,
    Marcus
     
  8. Diablo

    Diablo Registered

    Joined:
    Jan 20, 2013
    Messages:
    404
    Likes Received:
    0
    Don´t set this for the dedicated server, starting it from the Launcher takes care of this. What I was referring to, is how one starts the Mod Manager outside the Launcher, any Core application for that matter. Since the Launcher cannot take care of setting up their environment, one needs to do that manually then.

    No, you don´t, the Data Path is where your "Installed" directory resides, just leave it alone. A default rF2 installation sets all of this correctly.
     
  9. Jim Beam

    Jim Beam Registered

    Joined:
    Oct 5, 2010
    Messages:
    824
    Likes Received:
    10
    my server room window wouldnt show any cars or tracks until i set it how Radar has it above...and now is working fine...im just going with whatever works atm lol
     
  10. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    364
    Likes Received:
    2
    As we launch our servers from the dedicated.exe...and not through the GUI. Will have to wait for the powers to be to sort the exe out.
     
  11. Diablo

    Diablo Registered

    Joined:
    Jan 20, 2013
    Messages:
    404
    Likes Received:
    0
    Then you have the same messed up installation I guess. I just did an update on our server and I had to change nothing whatsoever.
    Running the Mod Manager directly inside the Core folder in earlier builds resulted in it installing to the Core folder instead of the Data Path.
    Running the dedicated server from the Core folder directly means, it cannot find Core\data.path, since the subfolder Core does not exist in there. Therefor one needs to tell it to use ".." (the parent directory, which is the rFactor 2 installation folder) as working directory by appending +path=.. to the command line, only if one runs it from outside the Launcher (!), otherwise, since Core\data.path cannot be read, the program seemingly falls back to the current working directory, which is Core.
    So, if you previously started the Mod Manager the same way, directly from Core, it installed into Core. Running the dedicated server resulted in it finding those wrong "Installed" and "Manifests" folders and thus was able to start and find the installed components.

    Since that procedure was obviously not intended by ISI, this is not a bug.

    If one wants to start those applications outside the Launcher, it is possible. One option is to use the parameter +path=.., i.e. by appending it to the command line in the startup shortcut one has created. Another one is to go to the rFactor 2 installation folder and run "Core\rFactor2 Dedicated.exe" from the command line (cmd.exe). This has the same effect, since one is in the main folder which is the working directory then. That can also be achieved by manipulating the startup shortcut:
    View attachment 6495
    Note that the started exe file contains "Core" in the path, whereas the marked line does not.

    Long story short, I´d suggest whoever has this problem, make a really fresh reinstallation and keeps the above in mind.

    Kind regards,
    Marcus
     
  12. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,827
    Likes Received:
    611
    Working for me without any change since start of rF2 beta.
    I use a shortcut on my desktop like this: "X:\Servers\rFactor2\Core\rFactor2 Dedicated.exe" +path=X:\Servers\rFactor2 +profile "Instance1" xxx.xxx.xxx.106:44297 +maxplayers 45
     
  13. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    Thanks for the run down Diablo.. As I said to JB in his TS, ISI have not released the do's and don'ts of how it should all run.. As many of us 'seem' to have installed a program the 'wrong way', then all we can do is continue to do things the way we have from who knows when..

    Wiki is only as good as the info one puts in it.. Was it created by ISI ? no.. Can anyone edit it ? Yes...

    As JB said, this way works for me at the moment so I will use this.. Until ISI set some sort of Do's and Don'ts on running a dedicated server (and let's face it, it went from being designed to run multiple profiles on one install but didn't work, to then having to run separate installs, to now running profiles again but yet no-one from ISI has said for sure which way it's meant to be done)..

    Running the dedi.exe direct is the logical thing to do.. As Dave said, he will wait till the powers to be fix it, I will use the temp fix until the powers to be fix it..

    Until some clear instructions on the 'way it's meant to be done' are produced by ISI, then we will all have different ways to run the programs correct ???
     
    Last edited by a moderator: Mar 1, 2013
  14. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    The Start in: line.. Mine had rFactor2\Core Removing the Core so it just read (install location):\rFactor2 worked..

    Thank you for that also..
     
  15. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,452
    Likes Received:
    6,630
    Well unless I've missed something setting the working folder to the main rF2 folder (the one the installer may or may not refer to as the core folder, but which is NOT the 'Core' folder.....) for both the mod manager and the dedi exe (via shortcuts) appears to work. So I'll take that as a fairly easy option until someone (or a bug) says otherwise ;)

    *Yeah, like that Radar :)

    **And if using/starting the server the other, direct way was the root of the problems we were having, or helped cause the problems in some way, hopefully this instruction helps others sort out any issues they're having as well. And for sure just running the ModMgr and the Dedicated.exe worked fine until build 156 ('worked fine', unless it was creating other less obvious errors like falling off the matchmaker, crashing, ...)
     
  16. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    Hi Mad..

    You shouldn't need the IP address nor the Port number. The Port number is defined in the Mulitplayer.ini file anyway..

    Target: "X:\Servers\rFactor2\Core\rFactor2 Dedicated.exe" +profile "Instance1" +maxplayers 45
    Start in: X:\Servers\rFactor2

    That's all you need.. I had \Core in the Start in: on mine, removing this solved the problem.. The above is all I have (except the maxplayers)..

    Not being a smart arse here, but Diablo (Marcus) could verify this as being the case? just want to ensure I'm giving correct info that's all..
     
  17. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    You will be happy to know Lazza that my servers are still running and updating (matchmaker), pretty much the same as per our dedi.exe tests before this build :)
     
  18. Marcing

    Marcing Registered

    Joined:
    Feb 28, 2013
    Messages:
    4
    Likes Received:
    0
    Adding +path variable seems to sort out problem.
    Thanks for help.
     
  19. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    364
    Likes Received:
    2
    After sleeping on it for a couple of hours, It came to me after 1/2 of the first coffee.

    "take the space out like before" and did that..and...away we go...

    All I did to launch it with a desktop icon attached to the dedicated.exe was edit it to: rFactor2Dedicated.exe ( removing any spaces )

    And re-named the field "start in" to: "C:\Program Files (x86)\rFactor2\" ( was: "C:\Program Files (x86)\rFactor2\core" )

    Hope this works for others also.

    Dave
     
  20. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    Just removing \Core from Start in: was all I ended up doing in the end Dave.. No need to rename file.. (at least for me anyway when running shortcut straight from rf2 dedi.exe).
     

Share This Page