rFactor1 to rFactor 2 Conversion Tutorial - Quick Guide

Discussion in 'Car Modding' started by dylbie, Apr 8, 2016.

  1. SmashingPants67

    SmashingPants67 Registered

    Joined:
    Oct 9, 2015
    Messages:
    76
    Likes Received:
    14
    Tried resetting all four wheels pivot points to 0,0,0, nothing
    Tried changing "CorrectedInnerSuspHeightAll=" from (0.28090,0.28090,0.28250,0.28250 to (-1) [not tested with =(0)]
    Here are my wheelbase settings as default:
    Code:
    FrontWheelTrackRange=(0.0,0,1)
    FrontWheelTrackSetting=0
    RearWheelTrackRange=(0.0,0,1)
    RearWheelTrackSetting=0
    LeftWheelBase=0.0                // if non-zero, forces the left side to use specified wheelbase
    RightWheelBase=0.0               // if non-zero, forces the right side to use specified wheelbase
    Tried assigning separate tgm's for front and rear tires, fronttire.tgm and reartire.tgm, still don't move when player controlled, only moves when AI controlled.
    This is the car when player controlled, it doesn't move.[​IMG]
    And this is the car when AI controlled, it is moving.
    [​IMG]
     
    Last edited: Nov 28, 2017
  2. dylbie

    dylbie Registered

    Joined:
    Oct 25, 2012
    Messages:
    395
    Likes Received:
    552
    Sounds like a TGM issue but not one I've ever heard of, as usually the game shits itself and wont let you on track if there's a physics problem.

    Can you double check you have the tyres setup like this:

    >TGM and TBC files inside you physics (MAIN) folder.
    >TBC filename referenced in the HDV text file.
    >TGM filename referenced in the TBC text file.

    If you're using ISI/Studio397 tyres, which I'm guessing you are, keep them paired to their original TBC & TGM.
     
  3. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,439
    Likes Received:
    673
    Is the engine running and can you rev up and change the gears?

    Have you set the pivot point of all meshes that are in the tire and spindle instances, to 0/0/0?
     
  4. SmashingPants67

    SmashingPants67 Registered

    Joined:
    Oct 9, 2015
    Messages:
    76
    Likes Received:
    14
    The engine runs and I can rev up/shift gears, but the speed still 0 mph/kmh
    Checked in simed, below results:
    Front tires: 0,0,0
    Rear tires: 0,255456,0
     
  5. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,439
    Likes Received:
    673
    Rear tires have 0,255456,0 as pivot point?
    That is definately wrong. 255456 means that they are 255456 meters away from 0.
    As i have suggested before, set the pivot points to 0,0,0 of all meshes, that are in the tire and spindle instances.
    Pivot points are very sensitive in rfactor 2.
    If two meshes, that are in the same instance, have different pivot points, you can exactly get the problem that you have.
    But to answer this in a senseful way, i would need to have the whole mod here.
     
  6. SmashingPants67

    SmashingPants67 Registered

    Joined:
    Oct 9, 2015
    Messages:
    76
    Likes Received:
    14
  7. MateLeLe

    MateLeLe Registered

    Joined:
    Jun 13, 2018
    Messages:
    13
    Likes Received:
    0
    Can anybody help me? When I import GMT files, in 3dsimed nothing appears, just empty space with colourful arrows. And when I try to export as rF2 object it says: "Encountered an improper argument". What did I do wrong?
     
  8. juanarg70

    juanarg70 Registered

    Joined:
    Feb 16, 2017
    Messages:
    35
    Likes Received:
    9
    Thats probably an encrypted file
     
  9. MateLeLe

    MateLeLe Registered

    Joined:
    Jun 13, 2018
    Messages:
    13
    Likes Received:
    0
    What can I do? There was one guy who managed to convert this mod (CTDP 2006) to rF2 but he canceled his project, propably due to lack of DX11 support of this mod, but it worked for him.
     
  10. gianlucap

    gianlucap Registered

    Joined:
    Dec 11, 2016
    Messages:
    4
    Likes Received:
    1
    edit: nevermind, I found a solution
     
    Last edited: Sep 13, 2018
  11. chogger

    chogger Registered

    Joined:
    May 27, 2012
    Messages:
    63
    Likes Received:
    9
    Guys, i need your help...
    Many years ago i succesfully conerted cars from rf1 to rf2 but now i failed.
    I looked into many topics und through my old tutorials but nothing.

    Car looks good in Spinner but ingame the body is half in the ground.
    I uploaded the whole project, maybe someone can point me to my mistake.
    (Put the chogger folder into the Vehicle Folder)

    Thanks
    http://www.chogger.de/chogger.zip
     
  12. SharD

    SharD Registered

    Joined:
    Apr 17, 2019
    Messages:
    56
    Likes Received:
    56
    Is it possible to convert cars from F1 challenge 99-02 to rFactor 2? And how difficult is this?
     
  13. SharD

    SharD Registered

    Joined:
    Apr 17, 2019
    Messages:
    56
    Likes Received:
    56
    I converted a car from rFactor 1 using 3DsimED, the car loads, but appears as a grey box and it states that "carbfbd.tga" and "carbdbf" failed to load.

    Any idea?
     
  14. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,679
    Likes Received:
    612
    Check which material that needs this texture and make sure it's located with the gmt's which are needing that texture
     
  15. SharD

    SharD Registered

    Joined:
    Apr 17, 2019
    Messages:
    56
    Likes Received:
    56
    Thanks, is the grey box related to that problem? Or is that a different issue?
     
  16. SharD

    SharD Registered

    Joined:
    Apr 17, 2019
    Messages:
    56
    Likes Received:
    56
    And the car works. It even looks good, lol.

    Though the driver inside steers at the bottom of the car. I'll fix that some other time.
     
  17. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,679
    Likes Received:
    612
    Glad you found the issue! Keep at it...
     
  18. SharD

    SharD Registered

    Joined:
    Apr 17, 2019
    Messages:
    56
    Likes Received:
    56
    After some work I am now the proud owner of a 1985 F1 mod. The cars drive like milk cans and crash constantly, but the biggest work is done.

    Whoever wants it can PM once it is finished, as I don't have permission to upload it.

    GRAB_003.JPG
     
    Corti and Mauro like this.
  19. Mauro

    Mauro Registered

    Joined:
    Oct 14, 2011
    Messages:
    1,643
    Likes Received:
    2,370
    Btw you could also ask permission to Valiante and Markus for a pubblic release.
    They already give permission for gtr conversion, so i think no problem if you ask them
     
    Corti likes this.
  20. SmashingPants67

    SmashingPants67 Registered

    Joined:
    Oct 9, 2015
    Messages:
    76
    Likes Received:
    14
    I'm getting crashes when loading new conversions to dev mode, I found a suspect line in the trace that says:
    42.29s vehload.cpp 3141: Gear 1 is not available? (Unexpected!)
    42.29s vehload.cpp 3143: Gear 2 is not available? (Unusual for most vehicles, but may be okay for some.)
    42.29s hdvehicle.cp 3297: Could not read file:
    It crashes at the end of the loading screen and the track is the default Joesville
    @Bernd I sent you the crashing mods via PM
     

Share This Page