rFactor1 issue

Discussion in 'Other Games' started by Angus94, Nov 29, 2017.

  1. Angus94

    Angus94 Registered

    Joined:
    Oct 6, 2010
    Messages:
    87
    Likes Received:
    0
    im trying to get 1 troublesome car to go to a track, i select the track, click 'LOAD CIRCUIT' and when the progress bar gets to the end the game 'hangs"

    LOG file =
    slot.cpp 440: Vehicle GAMEDATA\VEHICLES\DRAGFACTOR\NOSTALGIA FUNNY CAR\69 MACH1 MUSTANG\TEAMS\FRANTIC FORD\RIVERO.VEH:
    slot.cpp 441: CollisionBodyChecksum=2096887679

    what i have done so far.......
    1. removed all bar 1 part from the gen file - game still hangs
    2. copied the spinner gen (edited what i needed to) then renamed it as a gen file - game still hangs
    3. consolidated all the parts in 1 mas file and eliminated the need for UPGRADES - game still hangs
    4. been over both gen files looking for typo's, (gen file is a copy of the spinner gen and spinner gen works fine so that pretty much eliminated that) - game still hangs
    5. added a 2nd car to see that game still functions properly, 2nd car went to track no probs
    6. ive compared the structure of both gen files with gen files from mods that i know work, and the setup of my files appears to be fine
    7. ive had problems with Checksum's in the past and they have usually been related to tyres/wheels, so this time i 'commented out' the wheels from the gen file - game still hangs

    i dont know what to do to get this to work

    a knowledge base of Checksum errors would be real handy but i dont think one exists

    can anyone offer up any suggestions, thanks for reading
     
  2. Carr

    Carr Registered

    Joined:
    Mar 23, 2013
    Messages:
    116
    Likes Received:
    133
    I think you are looking in the wrong place for the error. It is a .veh error you are getting so I would be looking at that and the .hdv for incorrect file references or other errors to start with and working through the rest of the physics files, potentially the damage having a collision error too.
     
  3. Angus94

    Angus94 Registered

    Joined:
    Oct 6, 2010
    Messages:
    87
    Likes Received:
    0
    the hdv and damage files wont reveal any issues in relation to this car, there are 35 cars in the mod and all cars use the same core files.........(damage, gears, headphysics, tires, engine etc), when i make 1 car and successfully test it, then i use that cars' files as the basis for the next car, i simply rename the files to suit the next car, thats what i have done here but for some reason this car has 'bucked' the system
     
  4. Angus94

    Angus94 Registered

    Joined:
    Oct 6, 2010
    Messages:
    87
    Likes Received:
    0
    also, this car is a unique car, doesnt need upgrade option for anything so i have put all files in the 1 mas file, so maybe the reference to the upgrades.ini file in the veh file is causing my issue, do you think, im not sure if rFactor needs and upgrades ini file to make the car work properly
     

Share This Page