RFactor failing to open in single player mode

Discussion in 'Technical & Support' started by Bryceal57, Jun 9, 2018.

  1. Bryceal57

    Bryceal57 Registered

    Joined:
    Jun 9, 2018
    Messages:
    2
    Likes Received:
    0
    A blackout occurred while I was playing on RFactor the other day. Today when I tried to open it for the first time since. I clicked on the single player option and it began its loading screen. Instead of opening into the game, it gives me an error message saying: “Config Error: [JSON] failed to perform operation, unsupported type.” If y’all have any fixes to this issue, it would be greatly appreciated.
     
  2. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    406
    Likes Received:
    238
    1. Close rF2
    2. Navigate to your ...Steam/steamapps/common/rFactor 2/userdata/player folder and delete the player.json file.
    3. Start rF2.... It will generate a new player.json file for you.
     
    Bryceal57 and Grey like this.
  3. Bryceal57

    Bryceal57 Registered

    Joined:
    Jun 9, 2018
    Messages:
    2
    Likes Received:
    0
    Tried this and it no longer crashes, but instead of starting the single player mode, it just redirects me to the main menu.
     
  4. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    406
    Likes Received:
    238
    Couple of things to try....in your steam library right click on rFactor 2 => select properties, then on the local files tab select verify integrity of game files. The other thing to try is from the rF2 launcher screen select settings (the "cog" icon) and make sure the settings are correct.
     

Share This Page