Rfactor 2 won't recognize my NVIDIA.

Discussion in 'Technical & Support' started by Alexxx0, Apr 21, 2017.

  1. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    Its the same with a stock track? Try Portugal GP for example.
    Best to first run and configure the game without any pluggies. If you could uninstall it for now?
     
  2. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Yeah I know, but currently I can't even fix the lag. This game is a huge let down for me. I've been fighting with it for 3 days now, and I still can't fix it.
     
  3. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    I'll try it
     
  4. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Okay. So I run an IndyCar at the Portugal track and the lag is gone. At least on that track with the stock car
     
  5. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    So its most likely a mod problem!
    Test the F ISI 212 too. On Silverstone maybe or any other stock track.
    When this works you can install trackmap pluggie again.
    Be careful with random mods of random sites!
    Test first workshop items via steam or the things that are available in this forum under downloadable cars and tracks. There you have enough to do for the next year! :cool:
     
  6. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Okay,so I've put some minutes into the game,and it turned out that the only track that's buggy and laggy with the cars is the one I downloaded..Barcelona.. Tho I still get some lag on other tracks too. The cars aren't lagging,but like every minute the game and the sound stops for,well not for a whole second but for half a second...And I know it's not the biggest problem and it's easy to fix,but the screen is still tearing.
     
  7. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    If tearing so annoying for you, you can still fix it with syncing. But like I said it adds some lag to the controller input.
    Look if its ok for you (most times its not that bad that people recognize).
    This "stuttering" or "pause for half a second" thing was a topic here a few times, dont know exactly how to solve it (especially as its different at every system).
    But fine that it works for you so far!
     
  8. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Okay, I'll look around here. Thank you so much for the solutions,you just saved me 30 Euros ! Thank you ! :)
     
  9. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    Youre welcome!
    If you have further questions, just ask right away!
     
    Alexxx0 likes this.
  10. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    734
    Likes Received:
    520
    Turn Sync off and try limit fps to 120.

    Riva tuner has the limit framerate function, this program cames with msi afterburner.

    Works perfect too me.
     
  11. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    Well you dont need Riva tuner for that!
    Use ingame FPS cap.
    Can be found in Player.JSON --------> open with notepad under graphic options
    "Max Framerate":

    Edit: sorry Alex, could have said this earlyer....
     
  12. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Thanks for the suggestion,but if I turn sync off my screen tears up so much it's not playable
     
  13. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    Besides sync:
    Is stuttering away now? Maybe FPS limit can help in this? Dont know...
     
  14. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    No, I'm still experiencing stuttering. My fps is limited to 60 but my game looks like it runs with 25-30 fps. On the straights it's okay,it seems like it's really 60 fps, but when I turn the car it looks like it goes down to 10 fps. I'm running on the lowest graphics. It's worse if I turn up the graphics. Checked the GPU and CPU, everything works perfect,it's the game, and I don't know what to do. It's like 15-20 minutes to load a track,when I use wet weather it can go up to an hour. This game is a huge disappointment for me.
     
  15. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,305
    Likes Received:
    6,550
    Press Ctrl-C when in the car and keep an eye on the purple horizontal bar. It shouldn't reach the right hand side.
     
  16. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    the purple bar is constantly full. it doesn't even move. what does that mean ?
     
  17. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,305
    Likes Received:
    6,550
    @Alexxx0 Assuming you mean the fat horizontal one, and not the skinny vertical one(s), that would mean your CPU isn't keeping up with the simulation.
     
  18. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,305
    Likes Received:
    6,550
    Your CPU has a base frequency of 2.6GHz, which is a bit borderline. This sim is very demanding on constant CPU use, so other CPU measuring tools/programs (like task manager) don't really show the full picture; that's what the Ctrl-C graph is for.

    Press I (that's letter I, as in ghijk from the alphabet) in game to switch to AI control. If we're talking about the same purple bar, it will come right down to maybe 15-20%, because the AI physics are much simpler than player physics.

    For your quad core, I'd be disabling everything laptop-ish (power saving etc), turn off speedstep, turn off hyperthreading so each core isn't interrupted, and make sure you don't have anything in the background that could be taking CPU time.
     
  19. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    no, I mean the small horizontal one under the green one is full. I don't even have more,only these two. the vertical won't even show up
     
  20. Alexxx0

    Alexxx0 Registered

    Joined:
    Apr 21, 2017
    Messages:
    30
    Likes Received:
    1
    Already done these. If I press I, it's still the same.
     

Share This Page