Rfactor 2 Stuttering.

Discussion in 'Bug Reports' started by Shadowbounty, Mar 11, 2018.

  1. Shadowbounty

    Shadowbounty Registered

    Joined:
    Mar 11, 2018
    Messages:
    5
    Likes Received:
    0
    Having this issue, sometimes it will go 30 minutes without doing it, other times it will just do it like this video. Tried different game settings, tried different priority for the CPU usage or whatever, tried both DX11 and DX9. Different sync settings. Happens on both modded and official content.

    Tried windowed mode, borderless, fullscreen. Having this issue for a few weeks now out of nowhere. Like I said, sometimes it will do it only every few minutes, just one stutter and sometimes it goes mad like this. I'm not sure i've tried looking for a fix but I dont seem to be able to find anything :|

    Ignore the car switching in the video, that's just me manually changing the view and isn't related.

     
  2. DrivingFast

    DrivingFast Registered

    Joined:
    Mar 1, 2018
    Messages:
    498
    Likes Received:
    232
    I have stuttering also extremely frequently since the beta dx11.

    Possible solutions :

    1) CTRL + F to display FPS / CPU / Temperatures / GPU information. Leave this display playing. Works 100% of the time.

    2) Back to the office via Windows + D key. Only works temporarily and not always.
     
  3. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    446
    Likes Received:
    166
    Ctrl+c in the track to see CPU usage bar (purple). If the bar is more than 75% you got the problem.

    Probably you have a random windows background process that is consuming too much CPU making rf2 slow down, it's a very commom problem in rf2.

     
  4. Kelju_K

    Kelju_K Registered

    Joined:
    Sep 1, 2013
    Messages:
    185
    Likes Received:
    112
    I had the exatcly same lags!!!
    try enabling aggressive threading in config menu. in my system it pushes 1 core to constant 100% usage but it gave me much better overall performance, ie higher fps (i5 3570K @4.2)

    also try disabling replays, even hotlap recording. the video looks to me like disk writing issue as the lags are so long in duration, exactly like i had. i had it in ssd aswell, and even now that my game has been moved to hdd, these stutters are still absent and the game is running good.

    Could be possibly cured by lowering replay quality but for me it didn't go away completely before i disabled them (replay&hotlap recording).
     
  5. Shadowbounty

    Shadowbounty Registered

    Joined:
    Mar 11, 2018
    Messages:
    5
    Likes Received:
    0
    Tried everything you suggested before, nothing fixed it. I am on an SSD, GTX 1080, I7-4790.

    Performance isn't an issue, just this stuttering is game breaking. I have removed some motherboard software since and haven't had any stutters yet, it's hard to tell if I fixed it because sometimes it is fine for 30 mins etc.
     
  6. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    1,701
    Likes Received:
    863
    If it happens after a while, maybe it's overheating.
     
  7. Shadowbounty

    Shadowbounty Registered

    Joined:
    Mar 11, 2018
    Messages:
    5
    Likes Received:
    0
    Not overheating, CPU temps dont go above 70 degrees.
     
  8. Kelju_K

    Kelju_K Registered

    Joined:
    Sep 1, 2013
    Messages:
    185
    Likes Received:
    112
    Hope you got it fixed!
    if the stutters come back i would suggest extensive monitoring with afterburner software.
    enable the following:

    Frametime
    Framerate
    GPU temperature
    GPU core clock
    GPU memory clock
    GPU bus usage
    GPU voltage
    GPU usage
    GPU memory usage
    Ram usage
    Pagefile usage
    CPU1 usage
    CPU2 usage
    CPU3 usage
    CPU4 usage
    CPU1 temperature
    CPU2 temperature
    CPU3 temperature
    CPU4 temperature

    And see if there is any indication there about the cause. these kinda stutters are defenitely visible in the graphs.
    If, for example your core loads jump to 100% or bus usage hits something like +50% when the stutters happen.
    This makes it easier for you to pinpoint the cause and is also usable information to devs and other forum members to help you find/fight the cause.

    best of luck!
    K
     
  9. Shadowbounty

    Shadowbounty Registered

    Joined:
    Mar 11, 2018
    Messages:
    5
    Likes Received:
    0
    It seems as though removing that Optional motherboard software worked, GIGABYTE motherboard.
     
  10. GeakosF1

    GeakosF1 Registered

    Joined:
    Mar 17, 2018
    Messages:
    2
    Likes Received:
    1
    Hello to all.
    Unfortunately same issue here.
    Before i post i tried several things (also gigabyte mobo) and removed additional software.

    Here is a video


    My pc specs
    OS: Windows 10 Pro, MoBo: Gigabyte Aorus 7 X299 CPU:Ι9-7900X ,RAM: G.Skill DDR4 32GB 3200 MHz, GPU:Msi GTX Titan X
    Monitor: Asus PG278Q WQHD G-SYNC ROG 2560x1440
    Display settings
    [​IMG]


    [​IMG]

    [​IMG]
    Any ideas pls
     
  11. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    96
    Likes Received:
    30
    Try lowering settings for circuit detail, shadows and shadow blur.
    And since you have an gsync card/monitor, you could try enable vsync.
    If you do an new video, enable video info with ctrl-f so performance info is seen as well.
     
  12. patchedupdemon

    patchedupdemon Registered

    Joined:
    Jan 3, 2017
    Messages:
    1,448
    Likes Received:
    936
    This might not be connected but since the latest windows 10 update,every time I boot my pc I have to set max performance in windows,it no longer saves the setting.
    I had this happen in every game until I noticed windows was using balanced power setting unless I change it every time I boot pc
     
    SteveK likes this.
  13. caterkiller

    caterkiller Registered

    Joined:
    Oct 7, 2010
    Messages:
    87
    Likes Received:
    12
    I'm also having the exact same problem. Gigabyte mobo too... I'll try to uninstall every Gigabyte software because I already had issues with the RGB control app.

    Like others, it starts to happen after ~30-40mn of race and then I have stuttering every 2-3s for the rest of the race. Very, very annoying to drive like that.

    EDIT : Ryzen1600X on Gigabyte B350 Gaming Pro, GTX 970, 16GB of RAM, rF2 is on a SSD.
    Windows 10 Home 64 bits, version 1803.
     
    Last edited: Jun 12, 2018
  14. Rinussie

    Rinussie Registered

    Joined:
    Jan 11, 2012
    Messages:
    75
    Likes Received:
    8
    Hi all,

    last few weeks I'm having the same problem again.
    With the latest rf2 update it was gone for a while but now it's back sadly enough.

    .Edit: Graphics Cards: MSI GTX1080 | CPU: Intel Core i7 4770K @ 4Ghz | Motherboard: MSI z87-g45 gaming | Memory: 16 GB Corsair Vengeance DDR3 1866 Mhz | OS: Windows 10 64bit


     
    Last edited: Jun 12, 2018
  15. Shadowbounty

    Shadowbounty Registered

    Joined:
    Mar 11, 2018
    Messages:
    5
    Likes Received:
    0
    I fixed this many months ago, for me uninstalling the optional gigabyte software the motherboard uses fixed the stuttering and I have not had it since.
     
  16. Rinussie

    Rinussie Registered

    Joined:
    Jan 11, 2012
    Messages:
    75
    Likes Received:
    8
    I don't have any gigabyte driver installed
     
  17. Dumedo

    Dumedo Registered

    Joined:
    Nov 8, 2016
    Messages:
    18
    Likes Received:
    3
    I have stuttering only in curves, in straight line I have no problem at all. Stuttering is present only online and with 7/8 other drivers connected to the server.
    1920*1080 (single monitor)
    i5- 4670k no OC
    GTX 970
    win7 64bit
    16gb
    SSD
    Adaptive vsync by GPU

    If I set all graphic details to minimum I got some improvement but I still have problems if there are more then 10 drivers connected to the server.

    With 30 IA offline I still have stuttering but it is less present
     
  18. DaVeX

    DaVeX Registered

    Joined:
    Feb 7, 2015
    Messages:
    485
    Likes Received:
    462
    I suggest you guys to disable fullscreen optimization.

    It's easy. If you want to disable fullscreen optimization for just rF2, navigate to rf2.exe, right click > properties > compatibility > check "disable fullscreen optimizations."

    If you want to disable it for games across the board (which is what I did), go to your general Windows settings (windows key > type "settings" > gaming > game bar > "record clips, screenshots..." OFF > UNCHECK "show game bar when I play fullscreen games microsoft has verified").

    Note that you have to turn the game bar off AND uncheck "show game bar when I play..." Just doing one doesn't fully disable the overlay.

    Cliffnotes

    After Spring update the path is settings>games, disable all Xbox game bar stuff from there.
    Disabling the game bar is a common suggestion, but alone is not a fix, as the overlay is still there. You need to disable the actual "optimization" setting to truly disable everything.

    I'd recommend trying it even if you aren't having specific issues. Disabling it seems to increase smoothness and decrease input lag. Also, in my case, it dramatically decreased GPU load for some reason.
     
    juanchioooo likes this.
  19. AMillward

    AMillward Registered

    Joined:
    Apr 4, 2017
    Messages:
    1,027
    Likes Received:
    769
    Mine turned fast start up back on which makes the computer freeze after an hour or so.

    Spoke to an IT guy on Tuesday in Birmingham and he said he's spent the last month or so fixing people's computers after the latest massive update. So it's not just gamers that are affected.
     
  20. Dumedo

    Dumedo Registered

    Joined:
    Nov 8, 2016
    Messages:
    18
    Likes Received:
    3
    Thanks but if you read correctly my post I said I'm on windows 7 64bit
     

Share This Page