rFactor 2 Online Tools by Chris “redapg”

Discussion in 'Modding' started by Slow Motion, Oct 11, 2016.

  1. Nicola59

    Nicola59 Registered

    Joined:
    Dec 5, 2014
    Messages:
    164
    Likes Received:
    185
    Hello Chris
    Thank You so much:)
    The general tyre tool seems to work….but, trying the last window tool ( conversion of metric, etc etc ), I just tried a value in the penultimate window string with..
    6/21/13
    And I had again the grey screen without conversion
    Maybe now it’s working….I have to check
    Thank you
    Nic
     
    redapg and Nick9320 like this.
  2. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    Hello Nicola,
    which Tool exactly is "trying the last window tool"? :)
    I tried the 2 Other Tools from the preselection Page and both work as it seems.
    What sometimes can be a Problem, is a Setting in the Windows Internet Settings, where Websites get loaded from Cache Files instead of completely new.
    That may load Sites faster, but can cause that you don't load a Site that was updated.
     
  3. Nicola59

    Nicola59 Registered

    Joined:
    Dec 5, 2014
    Messages:
    164
    Likes Received:
    185
    Hello Chris
    Before to replay here, I tried again in the tire tool, tire designations metric, and I got again the issue.
    The problem is this ( for me…): if you open this tool, and you digit in the 4th line of windows ( from top )

    Width(inch)/Diameter(inch) - Rim-Diameter(inch)

    these values: 6/21/13 and then Calculate,
    You won’t get anything…only the grey screen.

    I take the occasion to report another small bug, this one in the Engine generator, first option ( you have to put only basic values of power and rpm ).
    When you have done the engine file, and you have put it in the game ( I mean, mod dev for example ) I check alway it with Carstat because in the torque curve some values, with decimal numbers, are generated without the final 0.
    So, torque curve is appearing with some low important peaks.
    Easy to fix, manually, the engine file…..but You need to check it always before to use it in RF2.
    Hoping my reports may be useful.
    Thank you so much, Chris
     
  4. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    @Nicola59 Thank you again for reporting. :)
    But please upload a Screenshot, i need to exactly know where you enter the Values 6/21/13.

    And with the missing 0, you mean that the Numbers e.g. are 245. instead of 245.0?
     
  5. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    @Nicola59 The Problem, with the "cutted" 0 from a Value that e.g. was 350, is solved.
    But the Formatting of the Numbers is not good Looking now. :D
    But Functionality comes before Design.
    That was another Thing that worked different in php 7.4.

    But i still need to have a Screenshot of the Tire Tool, that i can exactly see, where you enter the Values 6/21/13.
    It tried to reproduce the Problem, but couldn't do it yet.
     
  6. Bastian Paisler

    Bastian Paisler Registered

    Joined:
    Dec 28, 2017
    Messages:
    15
    Likes Received:
    8
    Hey guys,
    is anyone here who works with sound.json files at a regular basis an is willing to take a look into my file to diagnose any potential problems or sounds that will be missing because of some faulty lines of code?
     
  7. Pales

    Pales Registered

    Joined:
    May 9, 2017
    Messages:
    437
    Likes Received:
    431
    You can attach the .JSON file to your reply and we can have a look at the structure.
     
  8. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    I think i did read an official Info about it, in that was said, that all available Events are listed in the DevMode Sound Debugger Tool.
    So if there is none that smells like "DRS", there probably won't be one. :(

    We also can only check it with a JSON "Parser" Program, on - or offline.
    Do you miss any Sounds, that are defined in the JSON File, but doesn't get played?
     
  9. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    Just as an Information: i've updated the Tool, with that you can extract the Nm Torque Values from a rFactor1, rFactor 2 and GTR 2 Engine File.
    I've added a simple Routine, that checks for Offsets in the RpM Steps and you can directly paste the copied Values into the Spreadsheet now.
    Before, you had to paste them as HTML formatted Data.
    As always, PLEASE report Problems here, especially, because there seem to be some after i've switched from php 7.4 to php 8.3 on the Server.
    Thank you :)
     
    philrob, davehenrie and Emery like this.
  10. philrob

    philrob Registered

    Joined:
    Jan 12, 2012
    Messages:
    590
    Likes Received:
    1,239
    new tool worked well with an RF2 engine file, thanks Chris
     
    redapg likes this.
  11. Nicola59

    Nicola59 Registered

    Joined:
    Dec 5, 2014
    Messages:
    164
    Likes Received:
    185
    Yes, all the Tool sections seem to work well now.
    Thank You Chris, as always
     
    redapg likes this.
  12. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    @Nicola59 and all Others.
    Just a "Warning" if you click a Calculate Button in the Tool "Tire Designations metric <-> imperial" when all Cells are empty, the Script again goes totally to it's grey background only.
    This newest php Version has some "strange" new Functionalities and it's hard->impossible to detect, if they cause Problems or not, by testing.
    I can not test every possible "Configuration", because that would last Years, especially in the Tools where is use hundreds of Calculations.
    I will fix this Problem later Today.
     
    Gilles Benoit likes this.
  13. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    The Tool "Tire Designations metric <-> imperial" is updated.
    To avoid, to have to add a lot of Lines with additional Code, to keep the Site being visible, even if you click a Calculate Button when all Fields are empty, i did add a Warning, that reminds you to Enter Values into all 3 Fields. :)
    I hope that works in all of the millions of possible Combinations of entered Values.
     
    davehenrie likes this.
  14. JEmilio

    JEmilio Registered

    Joined:
    Dec 13, 2023
    Messages:
    57
    Likes Received:
    22
    Hi redapg, I've noticed that in Croft the ai in the 992 GT3 touches the wall in the right side when exiting the pitbox, does your patch fixes this behavior?
     
  15. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    To be honest, i was mainly focussed on fixing the Problem, with the Cars on Track crashing into the Cars that came out of the Pits.
    But i mean to remember, that i also narrowed the Corridor at Pitout a little bit, but i'm not sure about it.

    Just try it out.
    It's only a small File and can be installed and removed quickly, if it doesn't solves the Problem.

    And if it doesn't, you can report it in the according Thread, that i can take a Look into it. :)
     
  16. gangstorm

    gangstorm Registered

    Joined:
    Mar 21, 2019
    Messages:
    49
    Likes Received:
    46
    Hello Chris!

    First of all thank you for providing a tool for us to take some of the tedious time to make some changes! IT is MUCH appreciated and saves a TON of time for us!!

    Just wanted to let you know that your "Modify Mass and CG" entry is broken after your update. The field after you upload the mass/chassis goes blank. Hopefully, it is an easy fix!

    Thanks again and keep it up!
     
    redapg likes this.
  17. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    Thank you very much for reporting it. :)
    It lasted a While until i've found the Problem, because i tested with "too clean" Files.
    Howsoever, the modified Version is online now and i hope it works under all Conditions now.

    If not, please report again here and upload the Files, that you did upload into the Tool, here too.
    Thank you.
     
  18. JEmilio

    JEmilio Registered

    Joined:
    Dec 13, 2023
    Messages:
    57
    Likes Received:
    22
    I can't download it, Chris. The server doesn't seem to respond.
     

    Attached Files:

  19. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    Sorry, my Fault.
    I restructured some Things and forgot to update some Entries in different Files.
    It should work now.
     
    JEmilio likes this.
  20. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    Just as an Information and a kind of Excuse, for Problems that may appear now, after the switch of the used php Version on the Tools Server:

    The new php Version 8.3 e.g. stops to load a Tool Site, if a Path/File, from that i want to extract Data, is empty.
    That was ignored in the former php Version.
    But that gets shown, when i activate the php Error Parsing.

    And it's the same when there are Divisions by 0.
    But that also gets shown in the Parsing.

    But there are also Problems that, for whatever Reason, sometimes doesn't get shown in the Parsing and that are hard to detect then.
    One of these is the Function count(), that i often use to check if something is there at all.
    If count() was empty in the Past, it was taken as false and the Script continued loading.
    Now it stops loading and sometimes no Error gets shown in the Parsing.

    And so i really need your Help.
    Because i can not test every possible Combination of Numbers/Data, that gets entered manually or extracted from uploaded Files, it is very important that i get to be made aware of Problems.

    So PLEASE report all Problems that you encounter here, that i can try to fix them. :) Thank you
     

Share This Page