[SOLVED] Rfactor 2 Does not start.

Discussion in 'Technical & Support' started by Fer, Dec 24, 2017.

  1. Fer

    Fer Registered

    Joined:
    Dec 24, 2017
    Messages:
    4
    Likes Received:
    1
    I thought the problem was windows 10 because it started to fail after the last update(fcu).
    I installed earlier versions, and still failed. I installed windows 8 thinking that it would work, and nothing.
    I do not know if the problem is steam or rfactor, but my pc is a paperweight.
    It does not pass beyond the window synchronizing with steam workshop.and throw this error.
    Any suggestions, thanks.
     
  2. Joanne Sharpe

    Joanne Sharpe Registered

    Joined:
    Dec 22, 2017
    Messages:
    1
    Likes Received:
    0
    I seem to have a similar problem. I bought RFactor 2 for the first time yesterday, downloaded and installed it and it just wont run.
    I get the launcher window and looking in the content tab (carton) all the content seems to be there and it says it's installed.

    However, when I try to go to single player mode, initially I get the RF2 logo, then a blank screen, then back to the loader.

    Steam say they won't refund me because I've 'played' the game for 3 hours - 3 hours trying everything on the loader but not one second of access to the simulator - grumpy.

    I uninstalled the system and reinstalled it and got no change whatsoever.

    I have other things on my PC, so it's not a paperweight like yours Fer, but my Christmas present from Steam is a bill and no system - not at all happy.

    Joanne
     
  3. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,723
    Likes Received:
    1,004
    Video config looks OK? Try running all 4 runtime executables in the Support\Runtimes folder.
     
  4. oppolo

    oppolo Registered

    Joined:
    Dec 7, 2015
    Messages:
    102
    Likes Received:
    34
    try to delete player.json
     
  5. Fer

    Fer Registered

    Joined:
    Dec 24, 2017
    Messages:
    4
    Likes Received:
    1
    I think I've tried all the recommendations you can find in google. I think the problem is because of the part that is related to steam, because the game has worked a couple of times. I do not know if we have to wait for steam to fix something that does not work well, or if studio-397 has something to do about it.
     
  6. Fer

    Fer Registered

    Joined:
    Dec 24, 2017
    Messages:
    4
    Likes Received:
    1
    By the way, of the two times he has managed to start, I can say he is looking very handsome. It would be great if it always worked, for me now it's like playing the lottery, there is very little chance that it will touch you. :)
     
  7. Fer

    Fer Registered

    Joined:
    Dec 24, 2017
    Messages:
    4
    Likes Received:
    1
    It seems that in my case the problem was the power supply, I had a bequiet purepower9 400w, i5, gtx960, I changed it and everything works again.
     
    bwana likes this.
  8. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    1,921
    Likes Received:
    686
    Good to hear Fer , can you add’ Solved ‘to thread title , helps others who may suffer the same
     

Share This Page