[REPLACED] rFactor 2 Build 342 Released

Discussion in 'General Discussion' started by 88mphTim, Oct 24, 2013.

  1. Jim Beam

    Jim Beam Registered

    Joined:
    Oct 5, 2010
    Messages:
    824
    Likes Received:
    9
    Thanks ISI for removing smoke and rain from the special effects slider... now its the same for everyone which is awsum...another admin headache I can lose :cool:
     
  2. F1Fan07

    F1Fan07 Member

    Joined:
    Jan 11, 2012
    Messages:
    625
    Likes Received:
    46
    Still borked with HDR + Multiview on my triple monitor SLI system :( but to be fair the release notes don't indicate improvements in this area. Otherwise this build seems great.

    Multiview only, C6R at Lime Rock: 150-180 fps
    Multiview + HDR: 30 fps

    Fix this one issue ISI and I will be very happy.
     
  3. [NAR]Steve

    [NAR]Steve Registered

    Joined:
    Oct 20, 2010
    Messages:
    324
    Likes Received:
    15
    Auto update worked fine for me, seem to have gained a little performance too. Nice update !!
     
  4. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60

    Oh yeah :)
     
  5. GCCRacer

    GCCRacer Banned

    Joined:
    Dec 12, 2012
    Messages:
    1,318
    Likes Received:
    1
    Is sun occlusion working again in this build? That's the one thing in 300 driving me nuts...
     
  6. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    28
    You used to be able to auto update in a dedi with credentials but not activated and then a few builds back this option went away (update tab grayed out) unless you activate. Kind of a pain for servers because you don't want to waste an activation on a server. The only option right now is to install the lite build over the top.

    I hope this gets resolved because autoupdate was sooooo much faster. You could down a server, update then bring it back up within a few minutes.
     
  7. GCCRacer

    GCCRacer Banned

    Joined:
    Dec 12, 2012
    Messages:
    1,318
    Likes Received:
    1
    Hmm, seems like all visual settings need to be reset? Because at same like 300, my framerate is trough the bottom now. Is there any guideline which new settings equal old settings?

    Also, I'm seeing an artefact that I had in 300 with HIGH road reflection, now on LOW road reflection. Shaders have been recompiled (changed screen res, ran the track...)
    View attachment 10487

    Not so happy.
     
  8. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    28
    Reflections have the biggest impact on framerate in the current build. Focus on both of the reflection settings until you find a happy medium.
     
  9. Guimengo

    Guimengo Guest

    My wheel force feedback disappeared and the reset was not working. Exiting to menu and fiddling around didn't help, I had to exit the game.
     
  10. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    28
    Can you supply more info? Mainly, what wheel do you have and what OS. If I had to guess, Logi and Win8.
     
  11. GCCRacer

    GCCRacer Banned

    Joined:
    Dec 12, 2012
    Messages:
    1,318
    Likes Received:
    1
    Thanks for the pointer. Thing is, in 300 I run both on "low" and that looks good and is plenty fast. Now in 342 if I had to turn them off, I'd actually be losing visual quality to get back same amount of FPS... so if really the reflections are the big change then maybe we need one more intermediate setting that is the old "Low". If the new "Low Roadreflection" is the old "High Roadreflection" it would actually explain why my artifacts came back and where my FPS went.

    @ISI: If above paragraph is guessed correctly, then that seems a bit the same issue as with Silverstone's much larger textures... when releasing "higher" graphics, I really suggest to add option on top of exsisting settings (FULL/ULTRA Textures, FULL/ULTRA Reflections) so people don't have to change their previous sets around...
     
  12. Guimengo

    Guimengo Guest

    Hey Noel, I added my info to my sig. It's Windows 7 with Fanatec Porsche GT3 v2. I'd not think too much about the wheel since the FFB disappearing isn't a rare occasion with gmotor2 and rF2.
     
  13. TIG_green

    TIG_green Registered

    Joined:
    Jul 21, 2012
    Messages:
    3,037
    Likes Received:
    42
    atm I have two separate installs, both 300 and 339... is it ok to delete the other one and auto-update the other? Or are you still recommending clean install every time?... it's so pain in the ass to remember my graphical settings and button mapping every time and change the plr. values :/
     
    Last edited by a moderator: Oct 25, 2013
  14. GCCRacer

    GCCRacer Banned

    Joined:
    Dec 12, 2012
    Messages:
    1,318
    Likes Received:
    1
    I don't seem to have any issues just using the Lite Installer to update an exsisting install folder with the new core data. It doesn't affect mods, GFX settings, control setup or other stuff. To roll back to 300 I actually was able to delete the CORE folder of B342 and install from 300 Lite to the same folder, again no issues (wouldn't recommend this regularly obviously).
     
  15. N0body Of The Goat

    N0body Of The Goat Registered

    Joined:
    Oct 5, 2010
    Messages:
    42
    Likes Received:
    0
    Is anyone else getting flickering black artifacts?

    Running best graphics settings @ 1920x1200, AA level 5, HDR

    Been doing the practice session of a full weekend at Northampton with the Formula ISI with 9 AI, using the default weather sequence (so cool ~16C and the odd bit of rain)

    I'm getting a large flickering black artifact above the left side of the car in cockpit view, plus a small black sqiggly artifact appearing against the sky, high up and to the left of centre.

    Was panicking for a moment because I'm using a 9 day old Matrix 7970 graphics card!

    Will try other track/car combo and see if there is a pattern to this.
     
  16. speed1

    speed1 Banned

    Joined:
    Jul 26, 2012
    Messages:
    1,858
    Likes Received:
    0
    Thx for another update which i haven't tryed yet but i'm doing hard when i read the changelogs whith some baked in parts they seem never to change or move from the list. I'm missing the bits of tire, drivetrain physics which are part of the most important part and sense of this software, the physics imho. I really don't understand why is that. I don't need 50 cars with bad/incomplete tires or differentials when it represents wrong or unnatural behaviour in some case. Don't get me wrong but i can wait for eye candy but i can't take the driving part fully serious until the fundamental parts are ready to use and the wtf moments are eliminated. I hope we are not far away from another step forward in this as it is currently with the rest of it .:)

    Btw the overall representation of the whole rf2 project is becoming much better. The online presentation is nice and easy to use as it looks more up to date in general as well. Nice work, keep it up.:)
     
    Last edited by a moderator: Oct 25, 2013
  17. Esteve Rueda

    Esteve Rueda Registered

    Joined:
    Jan 14, 2012
    Messages:
    562
    Likes Received:
    7
    All can I say is... GOOD JOB!

    I have just a GTX650, but despite playing in mid graphics, I can now play with road reflection and sun oclussion activated with almost same framerate than before, and this looks fantastic.
     
  18. C3PO

    C3PO Member

    Joined:
    Aug 31, 2012
    Messages:
    1,088
    Likes Received:
    84
    You're allowed to say Silverstone here :)
     
  19. Prodigy

    Prodigy Registered

    Joined:
    Nov 2, 2012
    Messages:
    946
    Likes Received:
    59
    Wow, that's a big impact!
     
  20. Domi

    Domi Registered

    Joined:
    Oct 11, 2011
    Messages:
    747
    Likes Received:
    44
    Same here (not for the black artefacts), framerate is clearly worse with the same settings. And even reducing them...

    I am very disappointed.
     

Share This Page