[REPLACED] rFactor 2 Build 300 Released

Discussion in 'General Discussion' started by 88mphTim, Sep 6, 2013.

Thread Status:
Not open for further replies.
  1. Stephen Bacchus

    Stephen Bacchus Registered

    Joined:
    Sep 12, 2012
    Messages:
    29
    Likes Received:
    1
    Updated without a problem and either this or deleting the cbash(?) files did net me a FPS improvement, around 10% at Silverstone although I'm still suffering with micro stutter. Did do a quick torture test in the rain at Silverstone (settings as listed in profile) with 29 other Corvettes. 40 FPS mid pack wasn't bad but I did notice this game can really hammer the CPU, above 90% utilisation on two threads. Looking forward to the release of Ivy-E to help try and alleviate this bottleneck.
     
  2. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    125
    CPU reduction would be to reduce AI for biggest impact in my experience. Might also get rid of your stutter? Do you get it with single car sessions?
     
  3. ForthRight

    ForthRight Registered

    Joined:
    Jan 12, 2012
    Messages:
    231
    Likes Received:
    4
    Just confirming that road reflections are no longer working properly for me either.

    They seem to reflect the sky/clouds, but they don't reflect any trackside objects.
     
  4. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    I did the autoupdate thing from 240->298 and then 298->300. I sure as hell don't know what went wrong. But it's, at least for me, all good now. Apart from the framerate problem, which btw. is only really noticable in replays.
    (Maybe I'm driving too slow so I don't notice in cockpit view ;) )
     
  5. Marc Collins

    Marc Collins Registered

    Joined:
    Jan 11, 2012
    Messages:
    3,167
    Likes Received:
    162
    Well, I'm even older than you...yes, that's what they look like. They are intermittent for me--can't reproduce them by using a particular car/track combo.
     
  6. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,595
    Likes Received:
    1,898
    just a thought, but could the FPS increase be attributed to the road reflections not working properly? I.e. if they're not working as intended then could it be giving a false FPS reading?
     
  7. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    My GPU is supposed to be overclocked! At least that's what the marketing guys say on the product info. However, I'm not a big fan of doing these things myself because I'm not exactly a tech guy. So if (or "when" I should probably say) burn the whole thing down I won't be able to afford a quick replacement.
    I'm happy as it is. But thanks for your reply. ;)
     
  8. BazzaLB

    BazzaLB Registered

    Joined:
    Aug 14, 2012
    Messages:
    289
    Likes Received:
    3
    Has anyone else got jerky reflections on the car? Frame rate of reflections since upgrading to 298+ is very low. Env reflections on High. If this is indeed somehow controlled in a .cfg or .plr file can someone indicate which setting?

    Cheers
     
  9. brook

    brook Registered

    Joined:
    Dec 7, 2011
    Messages:
    198
    Likes Received:
    3
    I dont think, because this bug was not present in 298
     
  10. Stephen Bacchus

    Stephen Bacchus Registered

    Joined:
    Sep 12, 2012
    Messages:
    29
    Likes Received:
    1
    Thanks, I was just looking to push my system after having updated my motherboard BIOS. The micro stutter is present without any AI too. It seems to be related to the use of multiview in combination with running SLI. The Nvidia profile for RF2 works great in SLI with multiview disabled, as soon as multiview is enabled the frame rate tanks to the low 20's and GPU utilisation on both cards never gets past 50%. With my own profile I can get good GPU utilisation, around 95% both cards with the odd dip when my CPU can't keep up, but get micro stutter.

    Maybe needs Nvidia to update their profile for RF2. If I can get round to single card testing and confirm the problem is only present in SLI I'll contact them but to be fair I wouldn't expect them to do much while the game is still in beta.
     
  11. BazzaLB

    BazzaLB Registered

    Joined:
    Aug 14, 2012
    Messages:
    289
    Likes Received:
    3
    Better yet, can someone verify that they DON'T have jerky reflections on the car from cockpit view (eg skippy bonnet, car mirror casings etc) since update to 298/300?
     
  12. o0thx11380o

    o0thx11380o Registered

    Joined:
    Jun 28, 2013
    Messages:
    454
    Likes Received:
    2
    I just played for a while with various cars and did not see any jerky reflections. They look better than they did before.
     
  13. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    I didn't notice anything like this. All good here.
     
  14. Ricknau

    Ricknau Registered

    Joined:
    Nov 12, 2011
    Messages:
    760
    Likes Received:
    31
    I am not trying to hound you but I had the same attitude as you about OCing until about a month ago when I just gave up hope in optimization ever producing a big FPS gain. My vid card was OCed from factory like yours but the "twin frozr" means it has an extra fan and OC head room left. And it is very easy. Use MSI Afterburner. You simply bump some sliders for Core, Shader, and Memory clocks. Run an app within Afterburner called Kombuster to test it out. If it fails you can tweak up the voltages a bit and test again. If that doesn't help then back off the clock a bit. Yes it is a bit of trail and error iterations but man it can be worth it. I gained about 10-15% in FPS.

    Of course first you need to figure out why build 300 is hurting you. You can't really be happy with 20-27 FPS. If in fact your latest install process worked as it should and the sim is in fact working correctly then you need to check you settings. there must be something your not aware of that's killing you. Like said about my system some things I do not do, like AA. Also no multiview. How many screens do you use? Please don't say one!
     
    Last edited by a moderator: Sep 8, 2013
  15. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    I now have around 80 fps thanks to the tweaking tutorial by Bart S. Thanks mate you really helped me a lot. I even did overclock my GPU. Just a little bit though. ;)

    For those who might have missed it:
    http://isiforums.net/f/showthread.php/12633-4x-Better-Graphics-and-way-more-FPS-Guide
     
    Last edited by a moderator: Sep 8, 2013
  16. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    I figured it out. See my last post before this one. Thanks for trying to help me out. And, yes, I am using a single screen... ;) until Oculus Rift HD is available that is :D
     
  17. jamesowen

    jamesowen Registered

    Joined:
    Jan 30, 2012
    Messages:
    21
    Likes Received:
    0
    I installed the new build yesterday and it seems to be working ok except for the spotter not giving the laps times. I ran the "verify" check and noticed that that quite a few of the files failed verification. here are just some of them:

    Support\DirectX\dxdllreg_x86.cab failed verification.

    Support\DirectX\dsetup32.dll failed verification.

    Support\DirectX\Jun2010_d3dx9_43_x86.cab failed verification.

    Support\DirectX\Jun2010_d3dx11_43_x86.cab failed verification.

    Support\DirectX\Jun2010_d3dx10_43_x86.cab failed verification.

    Support\DirectX\Jun2010_d3dcsx_43_x86.cab failed verification.

    Support\DirectX\Jun2010_XAudio_x86.cab failed verification.

    Support\DirectX\Jun2010_XACT_x86.cab failed verification.

    Support\DirectX\Jun2010_D3DCompiler_43_x86.cab failed verification.

    Support\DirectX\DXSETUP.exe failed verification.

    Support\DirectX\DSETUP.dll failed verification.

    Support\300.uninstall failed verification.

    Installed\rFm\allcarstracks_10.mas failed verification.

    Installed\Vehicles\Clio_PC\1.0\clio_pc.mft failed verification.

    Installed\Vehicles\Clio_PC\1.0\clio_PC_common.mas failed verification.

    Installed\Vehicles\Clio_PC\1.0\clio_PC.mas failed verification.

    Installed\UIData\rFactor2 UI\1.0d\rfactor2 ui.mft failed verification.

    Installed\UIData\rFactor2 UI\1.0d\UImaps3.mas failed verification.

    Installed\UIData\rFactor2 UI\1.0d\UImaps2.mas failed verification.

    Installed\UIData\rFactor2 UI\1.0d\UImaps.mas failed verification.

    Installed\Sounds\TMTires\1.0c\tmtires.mft failed verification.

    Installed\Sounds\TMTires\1.0c\TMTires.mas failed verification.

    Installed\Showroom\rF2 Showrooms\1.0f\rf2 showrooms.mft failed verification.

    Installed\Showroom\rF2 Showrooms\1.0f\garage.mas failed verification.

    Installed\Showroom\rF2 Showrooms\1.0f\Reflected Floor.mas failed verification.

    Installed\Showroom\rF2 Showrooms\1.0f\Car Screenshot.mas failed verification.

    Installed\Nations\nations\1.0\nations.mft failed verification.

    Installed\Nations\nations\1.0\nations.mas failed verification.

    Installed\Commentary\Commentary\1.0\commentary.mft failed verification.

    Installed\Commentary\Commentary\1.0\CommentaryEnglish-USA.mas failed verification. Installed\Nations\nations\1.0\nations.mas failed verification.

    Installed\Commentary\Commentary\1.0\commentary.mft failed verification.

    Installed\Commentary\Commentary\1.0\CommentaryEnglish-USA.mas failed verification.

    Would I be wise to do a fresh installation or are the files not needed? All help would be welcome.
    Cheers!
     
  18. Ricknau

    Ricknau Registered

    Joined:
    Nov 12, 2011
    Messages:
    760
    Likes Received:
    31
    terrific!
     
  19. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    I'm no expert but I would go with a clean install. It just recently helped me.
     
  20. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    125
    Naa


    Sent from a mobile device using Tapatalk
     
Thread Status:
Not open for further replies.

Share This Page