rFactor 2 Build 1108 (Update 3) Now Available

Discussion in 'News & Notifications' started by Christopher Elliott, Feb 28, 2017.

  1. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,206
    Likes Received:
    5,243
    rFactor 2 Build 1108 (Update 3) is now available through Steam

    This is a minor update in preparation for NOLA Motorsports Park release.
    NOTE: Dedicated servers do not need to be updated

    Changelog:


    - Added Thrustmaster TS_PC controller profile
    - Added new shaders to the core to support latest track NOLA Motorsports Park

    Add any comments below :)
     
  2. ApainPlost

    ApainPlost Member

    Joined:
    May 6, 2016
    Messages:
    83
    Likes Received:
    121
    Hi Christopher,

    Is it possible to have an OSW/MIGE profile in the next build ? I would love that.

    Best regards.
     
    lagg likes this.
  3. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,440
    Likes Received:
    848
    Thank You .

    Am i the only one seeing massive flicker and crawl as i leave the pits on the grandstand next to the ferris wheel ?
    Really distracting .
    I can only imagine at 1080p how bad this must look as i'm at 3840x2160p and it still looks huge even the tyre barrier over at the back of the circuit has lots of flicker .
    Will this be one of the things that DirectX11 will help ? because we will be able to run even higher AA settings
    Im currently maxing out in game AA and using Inspector to force even higher AA but the crawl on those fences is pretty awful .
    Sorry to diss on this otherwise great release .
     
    Last edited: Feb 28, 2017
  4. diabolus79

    diabolus79 Registered

    Joined:
    Dec 23, 2016
    Messages:
    20
    Likes Received:
    7
    Can you please tell me when will you update Fanatec SDK so we CSL Elite users can enjoy rF2 properly, thanks.
     
  5. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,375
    Likes Received:
    1,666
    I've restarted Steam a couple of times but no update yet, I have it set to Always keep up to date.
     
  6. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,219
    Likes Received:
    608
    same here
     
  7. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,375
    Likes Received:
    1,666
    works now :)
     
  8. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,219
    Likes Received:
    608
    yep works :)
     
  9. Korva7

    Korva7 Registered

    Joined:
    May 22, 2014
    Messages:
    657
    Likes Received:
    151
    How i know if my rf2 got updated?
     
  10. Eddy

    Eddy Member

    Joined:
    Jun 27, 2013
    Messages:
    1,626
    Likes Received:
    380
    Run Nola if the grass is green you're okay if grass is purple-isch then rF2 didn't update. You than could do integrity check or restart steam client
     
    Last edited: Feb 28, 2017
  11. Uff

    Uff Registered

    Joined:
    Oct 5, 2010
    Messages:
    272
    Likes Received:
    49
    @Christopher Elliott @Marcel Offermans Can we expect full support for CSL Elite too? :)
    In the meantime thanks for the update!
     
    diabolus79 likes this.
  12. Korva7

    Korva7 Registered

    Joined:
    May 22, 2014
    Messages:
    657
    Likes Received:
    151
    Okay, it was updated then. Another thing that happened propbably because of update, URD JT5's carbonfiber transformed to classfiber
     
    Last edited: Mar 1, 2017
  13. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,403
    Likes Received:
    1,019
    I had only one hitch with the update: after adjusting video settings in-game, rF2 showed color only on center screen of triples with the side screens showing black with less black outlines of images, so rebooted and had to run video setup from launcher.
     
  14. Depco

    Depco Registered

    Joined:
    Jun 16, 2014
    Messages:
    796
    Likes Received:
    463
    I have found that when I prepare a Vmod for my server containing Nola, if I try to package it with only the C track layout, when I attempt to run it in the dedicated server no track shows up. In order to get a track to show up in the track selection screen of the dedicated server I have to have all of the tracks enabled during packaging of the V mod. Anyone else having this problem?
     

Share This Page