[REL] rFactor 2 Build 1108 Now Available!

Discussion in 'News & Notifications' started by Christopher Elliott, Dec 20, 2016.

Thread Status:
Not open for further replies.
  1. Empty Box

    Empty Box Registered

    Joined:
    Mar 4, 2013
    Messages:
    343
    Likes Received:
    29
    Can I just mention - it'd be really nice to be able to see if a server is running AI as it's "player count" displayed?
     
    Deadpedal, Alex72, sg333 and 5 others like this.
  2. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    2,134
    Likes Received:
    1,031
    Agreed, there is already a few servers l now avoid due to false numbers
     
    Deadpedal and Flaux like this.
  3. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    2,134
    Likes Received:
    1,031
    Yes interestingly l raced with 27 online plenty where asking questions as new players would, there was a noticeable difference in times from experienced rf2 users and new guys and there was also a very good respect shown by all . I believe the new era has certainly started this weekend
     
    Alex72 and Comante like this.
  4. daredbarn

    daredbarn Registered

    Joined:
    Dec 30, 2011
    Messages:
    42
    Likes Received:
    10

    Check inside the 32 bit or 64 bit folder. The package folders are not in the root directory as they used to be. If it's not in either the 32 or 64 bit folders, you can just create it.
     
  5. Nimugp

    Nimugp Registered

    Joined:
    May 27, 2011
    Messages:
    878
    Likes Received:
    139
    erm, for me it is??? I have .....\Steam\steamapps\common\rFactor 2\Packages, and in there I do see some content auto-downloaded from servers. I don't know if it will work in that location as you suggest something else, but without trying I'm pretty sure that that is still the correct place to put it...
     
  6. John

    John Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,085
    Likes Received:
    113
    My folder structure is this : I:\Steam\steamapps\common\rFactor 2\Packages Default clean install. If the folder doesn't exist, simply create it and drop a rfcmp file into it, then launch rf2 and click on the packages icon.
     
  7. drako90

    drako90 Registered

    Joined:
    Aug 28, 2012
    Messages:
    53
    Likes Received:
    0
    Same here with CLEAN install.. packages folder doesn't exist. (but with the old build installed + Update, works fine)... :(
    Instead, i have a data file (477kb) called "packages". And if I try to create a folder with that name,
    my windows10 says it is impossible to create, because that name is used by another file..
    So at the moment i'm only able to play with Workshop Mods.. Good one.....
    PD:: sorry for my basic English. :)

    No, packages folder doesn't exist in any rfactor 2 subfolder. I go to try to create one inside 64bit folder.
    ***Edit: tried and not work. but Thanks for help us :)
     
    Last edited: Dec 26, 2016
  8. Miro

    Miro Registered

    Joined:
    Jul 14, 2012
    Messages:
    1,357
    Likes Received:
    107
    Uhm, I did a clean install aswell, had the same problem. Noticed instead the packages folder there was a packages file within the rF2 root folder. Deleted that and moved my old backed up packages folder into the rF2 folder .
     
  9. Marc Collins

    Marc Collins Registered

    Joined:
    Jan 11, 2012
    Messages:
    3,168
    Likes Received:
    162
    Packages folder...this isn't that complicated. In the rF2 Launcher, just click on the icon that looks like an open box, or "package," and you will see where the folder is in the window at the bottom of that screen. It will either be in your Steam folder or in Documents with the other rF2 stuff.

    "Packages" is where you can manually install or uninstall packages that you have put in that folder.
     
    Ho3n3r likes this.
  10. drako90

    drako90 Registered

    Joined:
    Aug 28, 2012
    Messages:
    53
    Likes Received:
    0
    This is the first time i have problems whit that folder. And i have rfactor2 since 2012 i think (Terrible Build49).
    Creating dedicated servers and mods for my community since that year. BlaBlaBla my life haha :D
    So I know what is "packages and rfmods, etc" :p

    That's the problem. The route is correct. "Steam \ steamapps \ common \ rFactor2 \ Packages"
    it's simple, that folder do not exist in a Clean install, and it's imposible create one in the main folder, because windows says that name "packages" is already in use by another file. And yes it's true, exist a FILE named packages, but not a FOLDER. So WTF.. :)
    And yes, i know it's posible change or create a new route for the packages folder in the launcher, but.. really guys... why not work the original folder. haha

    Thanks guys for help
     
  11. Euskotracks

    Euskotracks Registered

    Joined:
    Nov 29, 2013
    Messages:
    1,093
    Likes Received:
    189
    I confirm that packages folder is not being created when making a clean install through steamCMD to host a dedicated server.

    I understand that steam makes it easy to solve these minor issues so I expect it to get sorted shortly.
     
    Flaux and drako90 like this.
  12. TIG_green

    TIG_green Registered

    Joined:
    Jul 21, 2012
    Messages:
    3,037
    Likes Received:
    42
    I recommend not doing any hasty conclusions. For example, when our members (VRC) go to practice in one of our servers and there aren't any drivers on the server at that time, they might add few AI drivers to have more rubber on the road and maybe practice some racing situations. We practice on our servers and not offline even when there aren't nobody else around because we use Liveracers. When a member or a visitor leaves our server they might forgot to remove AI. By any means we aren't trying to give anybody false information. It's just slow to remove AI (not for server admin but he can't be there all the time controlling this).

    So big +1 for showing only human players in servers' player count. Liveracers don't register AI times anymore (or at least we have set it that way) so I hope servers don't display AI either. But don't blame leagues right away for giving you false information by purpose. We do have plenty of racers in our official racers and on some odd times every now and then.

    -Matt
     
  13. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    2,134
    Likes Received:
    1,031
    I see your point but I'm sure everyone is aware of that server with 4 in its title and avoids it , it doesn't help anyone doing that ..
     
  14. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    2,134
    Likes Received:
    1,031
    Bring this point up AGAIN but rfmod refuses to install from official server when trying to join, Ive been on half a dozen other servers today without issue but the same as last session cant get studio397 server to work ,it suggest manual installation but from where ??
     
  15. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    799
    Likes Received:
    550
    @bwana check out your packages folder, for a corrupt rfmod file ie if the problematic one is abc.rfmod, have a look for a file that is just called abc( no extension) and delete....I've had this happen a couple of times when joining a server and deleting the offending file fixed it for me.
     
    bwana likes this.
  16. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    2,134
    Likes Received:
    1,031
    tried agin as open server now race event at Palmbeach and same result download bar gets to around 98% and fails withe same message , ,deleted and tried again a dozen times. check with a number of previously unused server and no issue. gut me buggered.
     
  17. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    799
    Likes Received:
    550
    Just tried to join the server and got the same message.....digging around in the rfmod I found that I don't have a couple of the tracks installed...check the list below and see if you have them all installed...Server has Sao Paulo up at the moment

    [​IMG]
     
    bwana likes this.
  18. Farflame

    Farflame Registered

    Joined:
    Mar 30, 2015
    Messages:
    34
    Likes Received:
    1
    Just a a quick question regarding the TGM display, I'm able to show it on screen only modifying manually the value in the ini file, setting il to 1 for temperatures and 2 for load. I've tried the ALT= shortcut (US keyboard layout) but nothing happens, which is the right shortcut to cycle trough the various modes (hope that there is one)?
     
    MMartin likes this.
  19. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,923
    Likes Received:
    319
    Dont know, if this was mentioned before, but the car headlight is very dim, especially during sunup and sundown. It seems to be with standard cars and modded cars. I`m not sure, if this is a new issue, introduced with the latest build? Any suggestion?
     
  20. Euskotracks

    Euskotracks Registered

    Joined:
    Nov 29, 2013
    Messages:
    1,093
    Likes Received:
    189
    Just posted in the FB page
    rF2 has added a button to start the game easier. Eager to hear about it!
    Screenshot_20161228-212015.png
     
Thread Status:
Not open for further replies.

Share This Page