rFactor 2 Build 1080 Now Available!

Discussion in 'News & Notifications' started by Christopher Elliott, Apr 14, 2016.

  1. baristabrian

    baristabrian Registered

    Joined:
    Dec 23, 2010
    Messages:
    141
    Likes Received:
    0
    Well keep in mind that "looks good" or "looks bad" is a highly subjective thing, and a matter of personal taste. I don't think its a monitor calibration issue as all other games, photo/video editing software ect.. looks fine. I also don't think it is an track issue because it is not so much the tracks themselves that look over saturated to me it is the cars. They look so "garish" it hurts me eyes to look at them. for me they look much more natural and realistic in LDR mode. But as I said in last post Im all good because I reverted back to LDR and Im happy with that.
     
  2. baristabrian

    baristabrian Registered

    Joined:
    Dec 23, 2010
    Messages:
    141
    Likes Received:
    0
    Here are my actual numbers from testing. I used both CONL+F and FRAPS (which agreed with each other) so I trust the results:

    Sitting in garage: HDR=182 LDR=220 That's a 38FPS drop
    Full speed down start/finish straight: HDR=165 LDR=190 That's a 25FPS drop.

    Test car= URD P1 Revolution
    Test track=Barber motorsports park

    System specs in my sig.
     
  3. Prodigy

    Prodigy Registered

    Joined:
    Nov 2, 2012
    Messages:
    944
    Likes Received:
    56
    How about testing with ISI content?
     
  4. Lefteris Axiotis

    Lefteris Axiotis Registered

    Joined:
    Apr 19, 2016
    Messages:
    22
    Likes Received:
    4
    BINGO!!!!!!!!!!!!!
    That was it. We did follow your advice with our league members and it finally worked! Thank you big time!!!! "Invalid Password" issue solved!!!
     
    Last edited by a moderator: Jun 13, 2017
  5. Lefteris Axiotis

    Lefteris Axiotis Registered

    Joined:
    Apr 19, 2016
    Messages:
    22
    Likes Received:
    4
    BINGO!!!!!!!!!!!!!
    That was it. We did follow your advice with our league members and it finally worked! Thank you big time!!!! "Invalid Password" issue solved!!!
     
    Last edited by a moderator: Jun 13, 2017
  6. Lefteris Axiotis

    Lefteris Axiotis Registered

    Joined:
    Apr 19, 2016
    Messages:
    22
    Likes Received:
    4

    BINGO!!!!!!!!!!!!!
    That was it. We did follow your advice with our league members and it finally worked! Thank you big time!!!! "Invalid Password" issue solved!!!
     
    Last edited by a moderator: Jun 13, 2017
  7. Tuttle

    Tuttle Technical Art Director - Env Lead Staff Member

    Joined:
    Feb 14, 2012
    Messages:
    2,480
    Likes Received:
    773
    That delta is pretty high for your system and sounds odd to me, but still, you have a Titan card and those frame rates are totally useless as all you can see on your monitor is equal or minor the frequency speed of the panel. Rendering more than that number results in tearing because of the phase difference between scan per second and frame per second.

    Said that it's evident you can run a capped 60FPS with HDR ON, as probably a 144FPS with HDR ON. You should not really switch to LDR, at all.

    As we stated several times before, LDR is a dead feature, not supported anymore. We do not develop on it, we do not test on it, we do not provide any kind of support for it. We do not want that function on UI anymore as it is just making the game producing wrong output and possible generating random problems because its legacy status.

    We are not locking that function (yet), so instead complaining that much you should be happy you can still edit that file (10 seconds job) and go back to LDR.

    This is a pretty much end of the argument.
     
  8. Joe Campana

    Joe Campana Member

    Joined:
    Jan 19, 2012
    Messages:
    129
    Likes Received:
    2
    Judging performance by FPS is very misleading. Based on your reported numbers, HDR processing on your system takes 790 to 950 micro seconds per frame, let's say avg of 900 µS. If your LDR frame rate was 1000 (1 ms frame time), adding HDR would increase your frame time to 1.9 ms and drop FPS to about 526 FPS, a loss of 474 FPS, and you would hate me. If your LDR frame rate was 60 (16.67ms frame time), adding HDR would increase your frame time to 17.57ms and drop FPS to about 57 FPS, a loss of only 3 FPS, you would still hate me but not as much. :D 900 µS HDR = OK.
     
  9. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    I have owned Asus Sabertooth X79 and did have problems with PCI-E @ 3.0 gen 3 cards. Maybe BIOS update can solve also your problems ?
    https://www.asus.com/Motherboards/SABERTOOTH_X79/HelpDesk_Download/
     
  10. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,664
    Likes Received:
    595
    Okay... New rant.

    Wanted to race the lovely classic F3 around some track with some friends. We were super-excited, because of the awesomeness of this car.

    Set up the remote desktop-non Steam server as has been done for over a year now. Some ISI tracks (plus ISI Eve and Spark Historic) auto-subscribed to through Steam... Yay it's all good, but also a few 3rd party track such as Laguna Seca, RacerFactor GP tracks (Hock, Monza, Spa to be anal) Everything is of course getmodded to perfection on the remote desktop-non Steam server.

    Tried to join the server through the launcher, because... I had no missing components. It installs the mod, fine.
    [​IMG]


    And then it just hangs here... I get a race button but if I click it, it just installs the mod again. lel
    [​IMG]

    So I uninstall the rFmod (F3_fun (no spaces, no nonsense)) because we can't have conflicts, right?!

    Hell, I even uninstall the rfcmp's that AREN'T ISI and auto-subscribed to (Laguna, RacerFactor Hock, Monza, Spa)

    So I try with the lovely new Launcher serverlist... I get this
    [​IMG] I, we've seen that before, haven't we? :)

    So... Steam serverlist it gets AS FAR AS downloading components!
    [​IMG]

    [​IMG]

    [​IMG]

    Another hang, after succesfully downloading the non-ISI components.

    There's NO way to join that server. Pre B1080 build? No damn problem.

    One friends expression of frustration: "How can they have ****ed it up so badly... It really annoys me they can't put out a hotfixed build or revert to the previous build"
    The other friend didn't make it this far because we called it off before he made it back to his PC.

    Come on, guys?!
     
  11. baristabrian

    baristabrian Registered

    Joined:
    Dec 23, 2010
    Messages:
    141
    Likes Received:
    0
    There IS no argument. Ive said in my last 3 post I prefer LDR and others prefer HDR. That's an OPPINION not an argument. You may also note in my last 3 post Ive ended them by saying "Im good as Ive reverted back to LDR". Seems like you are the one with the attitude....
     
  12. Knackko Lovitch

    Knackko Lovitch Registered

    Joined:
    Feb 22, 2013
    Messages:
    22
    Likes Received:
    0
    Thanks for this, it solved the following problems:
    - can not join passworded server
    - can not download and install rfmod
    It works for me with Steam rFactor2 and for a team mate with non Steam rFactor2.
    My PC runs with ESET NOD32 antivirus 9 and the team mate have ESET NOD32 smart security.
     
  13. Knackko Lovitch

    Knackko Lovitch Registered

    Joined:
    Feb 22, 2013
    Messages:
    22
    Likes Received:
    0
    Concerning servers visiblity in steam server list, in my league we own 4 instances of rf2, each with separate ports of course, before b1080, we had:
    * instance1:
    "HTTP Server Port":65001,
    "Simulation Port":54301,

    * instance2:
    "HTTP Server Port":65002,
    "Simulation Port":54302,

    * instance3:
    "HTTP Server Port":65003,
    "Simulation Port":54303,

    * instance4:
    "HTTP Server Port":65004,
    "Simulation Port":54304,

    Since b1080 with steam rFactor2, some of those servers were not displayed in server list anymore. With cports, i've found the UDP port 65002 opened for instance1 and the TCP port 65002 opened for instance1, significating that more ports are opened by an instance now.

    So now, instances are now conifgurated as this:
    * instance1:
    "HTTP Server Port":65101,
    "Simulation Port":54301,

    * instance2:
    "HTTP Server Port":65201,
    "Simulation Port":54302,

    * instance3:
    "HTTP Server Port":65301,
    "Simulation Port":54303,

    * instance4:
    "HTTP Server Port":65404,
    "Simulation Port":54304,

    ...
    For instance2, now, TCP/65201, UDP/65201, UDP/65202 are now opened.
    For instance3, now, TCP/65301, UDP/65301, UDP/65302 are now opened.
    ...

    So now without consecutive ports for HTTP Server Port, all the servers are available in server list !
     
  14. endonesia

    endonesia Registered

    Joined:
    Oct 5, 2010
    Messages:
    79
    Likes Received:
    0
    +connect on the desktop shortcut has worked for me to able to race as admin in my league tonight, thank you.
     
  15. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
    I got a "jumpy" performance with 1080 build. Not measured or benchmark yet but is quite clear there was a smoothness hit.
     
  16. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,329
    Likes Received:
    6,111
    @Bjørn, did you try removing the actual packages (rfcmps) from the server's default package folder?
     
  17. Comante

    Comante Registered

    Joined:
    Nov 20, 2013
    Messages:
    919
    Likes Received:
    533
    IT must be a hit and miss situation, personally, switching from 1052 to 1080 allowed me to raise track details and textures (from medium to high) and still have GPU margin (fps capped at 90) .. but I have a AMD and in the last month I upgraded GPU driver too, so it may be a combined effect.
     
  18. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,329
    Likes Received:
    6,111
    Glad that worked for you :)
     
  19. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,329
    Likes Received:
    6,111
    You've more than made your point, just revert to LDR if you want, and leave it at that.
     
  20. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,664
    Likes Received:
    595
    Yes, the ones that weren't ISI-ones.

    And I reverted to 1052, worked like a charm <3 Sad that has to be done, ey?
     

Share This Page