[REL] rFactor 2 automated camera plugin

Discussion in 'Other' started by HorCsa, Jul 23, 2015.

  1. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,732
    Likes Received:
    2,097
    Thanks for the update, this continues to be one of my most favourite plug ins.

    Just one note, with the default settings it missed two Yellow Flags completely when watching an AI race.
     
  2. HorCsa

    HorCsa Registered

    Joined:
    Jun 13, 2015
    Messages:
    23
    Likes Received:
    4
    Thank you all for your feedback. It's important to me. :)

    Currently not listening yellow flag status. Only incidents with Immovables or another vehicle. (Maybe good for the yellow flag, but which driver should be the focus? I think about it.)
    You need testing incidents intensity settings to find balance replays and live. Good intensity settings may be different for each mod.
    Why only immovables? We are testing incidents on Daytona RC and the cars continuously in incident with parts on oval. It is a safe option.

    "TV display" output (we "lost" GRtv plugin output):
    I do not think I can do the ingame overlay display (like GRtv). But... rF1 autocam plugin using text files to output realtime data (actual drivername, laps, session time etc...). This is an easy way, and so far been good for us.
    So the next update: Plugin create realtime output text files, and i will share my templates to xSplit and OBS (I think many people use these programs to stream.)
     
  3. HorCsa

    HorCsa Registered

    Joined:
    Jun 13, 2015
    Messages:
    23
    Likes Received:
    4
    W.I.P. Xsplit template, and some auto REPLAY test :)
    [video]https://youtu.be/Rs8qWTmK6es?t=1h40m[/video]
     
  4. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    612
    Likes Received:
    108
    This is probably a silly question but which file do I edit to make the changes such as camera etc. There is the INSTALL, CHANGELOG, and the DLL file. When I install this plugin I move the dll file into the plugins core file but the INSTALL and CHANGELOG just go to my desktop (am I meant to move these elsewhere as surely if I edit the INSTALL or CHANGELOG it would need to be in the games file to change anything)?

    Also for some reason the plugin works in practice and qualifying but not in race? Any help would be appreciated :)

    EDIT: I just figured it out... this always happens. I found the ini file in the player/settings folder where I could change the values. Thanks again for your awesome plugin! :D
     
    Last edited by a moderator: Sep 30, 2015
  5. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    612
    Likes Received:
    108
    I am having another problem however as when I go to exit the race and proceed to watch just the AI the auto camera isn't working. It work's when my car is in the race but not when I exit to the monitor. I find it weird because before the last update it worked fine, any solutions? Also is there a way to remove the automatic replays?
     
    Last edited by a moderator: Sep 30, 2015
  6. HorCsa

    HorCsa Registered

    Joined:
    Jun 13, 2015
    Messages:
    23
    Likes Received:
    4
    I don't know what's happening if you exit from race. I'm testing only AI mode in offline (start race, and press ai control. default "I"). But i will watch it. (I think the reason the onreplay/onlive mode different online and offline.)

    Just set lowinc and highinc parameters higher than 1 (higher than maximum incidents intesnity in rF2).
     
  7. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    612
    Likes Received:
    108
    Thanks mate that helps :) I am too now using the AI control but it's a shame with that ugly AI control button in the top left corner, especially when streaming races.
     
  8. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,732
    Likes Received:
    2,097
    not sure if this would work as it might only be for Flags, but try changing this to 0 and see what happens (player.JSON):

    "Display Icons":2,
    "Display Icons#":"Icons displayed if HUD is off: 0 = none, 1 = flags only, 2 = all",
     
  9. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    612
    Likes Received:
    108
    Sadly it didn't work but it did get rid of the flag icons on screen which is nice, thanks anyway though. :)
     
  10. JeDa

    JeDa Registered

    Joined:
    Jan 3, 2012
    Messages:
    57
    Likes Received:
    0
    Hi,
    I really like this plugin a lot! Because I also still play rFactor1 and AMS, I was wondering if you could update the plugin with the latest feautures which we now only have for rFactor2.
    I would love to be able to have a key to enable/disable the plugin (like we have in rf2) and the option to enable/disable the autostart.
    Is this possible?
    Thanks!
     
  11. Euskotracks

    Euskotracks Registered

    Joined:
    Nov 29, 2013
    Messages:
    1,093
    Likes Received:
    191
    My only suggestion would be not to have it on by default. I only use it for replays and every new build notice I didn't change that value some metres after leaving my garage :)

    Enviado desde mi SM-T530 mediante Tapatalk
     
  12. JeDa

    JeDa Registered

    Joined:
    Jan 3, 2012
    Messages:
    57
    Likes Received:
    0
    Hi Euskotracks, thanks for your reply. How do I enable or disable it in AMS or rFactor1?
     
  13. toebee

    toebee Registered

    Joined:
    Oct 5, 2010
    Messages:
    380
    Likes Received:
    390
    This is great. Thanks for this. Does anyone know if it works in dev mode? It created the ini file in the dev mode player folder but it doesn't seem to be working like it does in single player.
     
  14. Nazirull Safry Paijo

    Nazirull Safry Paijo Registered

    Joined:
    May 28, 2011
    Messages:
    1,417
    Likes Received:
    35
    What did u do to fix the plugin to work in race? Mine having the same problem. It doesnt work in races.

    Great plugin. Saves alot of steps into making race broadcast. :)
     
  15. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    612
    Likes Received:
    108
    I'm sorry, I think I've forgotten what my fix was. Make sure that you aren't in 'replay' mode when in the race, this will make the plugin not work properly I have found.

    I do have another issue I've got though.

    [AUTOCAM]
    auto=1
    autokey=0x41
    waitsec=20
    interest=12
    interestdiff=3
    onboarddiff=0.4
    onboardcam=5
    rearview=5
    rearviewcam=6
    camtest=no
    walkthrough=1
    showinpit=onboarddiff
    lowinc=0.4
    highinc=0.8


    I want the on board cam to be automatically this https://gyazo.com/9af489dc2d4c54bf06d5b1535bb200db when it is changed. Instead I get the on board TV cockpit cam (hands on steering wheel is all I can see). I understand '5' equals to onboard000 which is the camera I want from the image. Can, or does anyone please have a fix for this?
     
  16. ECAR_Tracks

    ECAR_Tracks Registered

    Joined:
    May 1, 2016
    Messages:
    456
    Likes Received:
    465
    I don't know how difficult would be but it would be great if plug in sort of have class priority (E.g. 60% coverage prototypes and 40% GT)... Just wondering, but plug in is already very nice
     
  17. Fraggon

    Fraggon Registered

    Joined:
    Aug 27, 2013
    Messages:
    200
    Likes Received:
    8
    Does this mod work with dx11?
     
  18. DaVeX

    DaVeX Registered

    Joined:
    Feb 7, 2015
    Messages:
    635
    Likes Received:
    701
    HI guys, I know I am a little off-topic but I am tryng to make this work for AMS, suggestions?
    Download link doesn't work!
     
  19. AMillward

    AMillward Registered

    Joined:
    Apr 4, 2017
    Messages:
    1,810
    Likes Received:
    1,754
    Looks great! The YouTube video was like watching an AI race in one of the Geoff Crammond games!
     
  20. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,580
    Likes Received:
    658
    Is this plugin now broken in the new UI?
     

Share This Page