RF2 server crashing after custom plugin update

Discussion in 'Plugins' started by rigodon, Feb 17, 2020.

  1. rigodon

    rigodon Registered

    Joined:
    Dec 26, 2012
    Messages:
    188
    Likes Received:
    4
    Hi everybody. I created a custom server-side plugin thas has been working for more than 1 year. I made some changes in the code, compiled it and moved it to my test server in a Windows 2008 VM. Now, everytime I try to start the server, it dies with no error message. Enabled RF2 trace, but got no error on it. Had a look at Windows Event Viewer, no error. It's obviously a problem with my code update, because server starts if I remove the plugin.
    I'm completely lost as I don't know how to get more info about this crash. Can you please help me?
     
  2. Tygernoot

    Tygernoot Registered

    Joined:
    Feb 26, 2012
    Messages:
    109
    Likes Received:
    55
    Can you compile in debug mode and attach the debugger to the process before it crashes?
     
  3. rigodon

    rigodon Registered

    Joined:
    Dec 26, 2012
    Messages:
    188
    Likes Received:
    4
    RF2 server process is alive for less than 1 second. Could I attach the debugger into it?
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,101
    Likes Received:
    2,877
    Throw in output messages (close file each time to flush buffers) through the startup code and see where it stops. Insert new messages, repeat.
     

Share This Page