[REL] rF2 Pedal Overlay Plugin

Discussion in 'Other' started by TechAde, Sep 7, 2012.

  1. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    Thanks!
    Unfortunately brake wear isn't available via the rF2 API.
     
  2. darcidm

    darcidm Registered

    Joined:
    Jun 24, 2013
    Messages:
    191
    Likes Received:
    104
    TechAde

    You can make individual settings to position the pedals and no background?
     
  3. Coanda

    Coanda Registered

    Joined:
    Jun 9, 2013
    Messages:
    689
    Likes Received:
    3
    Tested on the new beta 767 64bit build. The plugin doesn't work.
     
  4. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    I've no plans to do that sorry.
    32-bit plugins won't work in the 64-bit build of rF2, I'll need to build a 64-bit version of the plugin.
     
  5. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    Version 11 released, see first post. This adds a 64-bit build of the DLL for use with the 64-bit rFactor2.exe.
     
  6. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,830
    Likes Received:
    611
    So quick, thank you !!!
     
  7. sg333

    sg333 Registered

    Joined:
    Nov 3, 2010
    Messages:
    1,600
    Likes Received:
    206
    Awesome, thanks so much!
     
  8. Coanda

    Coanda Registered

    Joined:
    Jun 9, 2013
    Messages:
    689
    Likes Received:
    3
    Cheers Techade. Much appreciated. Although the plugin is now working for me on b767 64bit I copied over my previous rF2PedalOverlayPlugin.ini file with my custom coordinates however they have not altered its position & size. This is odd as both files replicated each other. Have you had such issues?
     
  9. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    Odd, must admit I didn't try editing the ini. You've put it in the right place, User data?
     
  10. Coanda

    Coanda Registered

    Joined:
    Jun 9, 2013
    Messages:
    689
    Likes Received:
    3
    This has changed and that fixed it :) The previous plugin version I had on B660 the ini & dll were both under the plugins folder and worked fine.
     
  11. rer8

    rer8 Registered

    Joined:
    Dec 19, 2010
    Messages:
    492
    Likes Received:
    22
    Excellent! Thank you for planning ahead. I appreciate your anticipation of the 64-bit change and preparation for that event. Best regards! Randy
     
  12. Mydriaz

    Mydriaz Registered

    Joined:
    Jan 16, 2012
    Messages:
    952
    Likes Received:
    41
    Works fine.
    Many thanks :)
     
  13. Coanda

    Coanda Registered

    Joined:
    Jun 9, 2013
    Messages:
    689
    Likes Received:
    3
    Hi. I just went from b767 to 772 and the plugin is not working again on 64bit.
     
  14. jimcarrel

    jimcarrel Registered

    Joined:
    Jan 15, 2012
    Messages:
    1,720
    Likes Received:
    24
    Worked okay here Coanda, you made me remember I didn't add it back in on 772 64.
     
  15. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    Must be something odd at your end, v11 works fine here in 32-bit & 64-bit in 770 & 772.

    I'll be releasing v12 soon. No functionality changes but I've removed the pragma and re-compiled both 32-bit and 64-bit DLLs, as per Joe's suggestion.
     
  16. datanode

    datanode Registered

    Joined:
    Oct 23, 2012
    Messages:
    457
    Likes Received:
    0
    Notice DRS lights orange, flickering to green when using the overlay plugin.

    Rf2 build 770 64bit
    Pedal overlay v11
    Silverstone / FR2014
    (No other mods)

    Anyone else notice this? It is very easy to miss as it changes at such a high frequency.

    Graphics are the latest beta nvidia, 340.43

    Full specs in system profile, but a quick run down

    Win 8.1 x64
    GForce 780
    AMD 8320 black ed 8 core
    8gb ram
    Asus rog formula-z crosshair

    Edit: starting to doubt this is an overlay issue ;) will test some more and update.
     
    Last edited by a moderator: Jul 9, 2014
  17. mrsmr2

    mrsmr2 Registered

    Joined:
    May 13, 2013
    Messages:
    89
    Likes Received:
    17
    Hero. Thanks
     
  18. F3n3k

    F3n3k Registered

    Joined:
    Feb 18, 2012
    Messages:
    81
    Likes Received:
    6
    Hello can't find the newest version on the firt page, just the version 10...

    Help me please ;)

    thanks
     
  19. TechAde

    TechAde Registered

    Joined:
    Oct 13, 2010
    Messages:
    605
    Likes Received:
    36
    The first post contains 1.0.0.11.zip, version 11. Version 10 isn't there any more.
     
  20. F3n3k

    F3n3k Registered

    Joined:
    Feb 18, 2012
    Messages:
    81
    Likes Received:
    6
    Ha ok thanks you, but i try this version and it's don't work with built 798.
     

Share This Page