RF2 not working properly anymore

Discussion in 'Technical & Support' started by Baldeagle611, Feb 13, 2018.

  1. Baldeagle611

    Baldeagle611 Registered

    Joined:
    Apr 4, 2017
    Messages:
    22
    Likes Received:
    6
    Hi everyone.

    I presume this happened after one of your updates, because it worked ok before, even on the higher settings.

    Firstly, I get a message saying 'not enough video memory', but it seems to run otherwise.
    However, certain tracks don't display properly, e.g. the Monte Carlo 1966 one. I now get a load of jagged polygons all over the screen, making it unplayable. My computer has an Intel Iris Pro GPU 6200 and 8GB ram, running Windows 10. Therefore my questions are:

    Is it the GPU?
    Is there a setting I can change to fix it?
    If not, do you have a workaround?
    If not, do you still keep the previous versions on your servers so I can revert to one that works please?

    Please don't ask me to buy a new graphics card, as I only bought the machine 10 months ago!

    Thanks in advance for your help.
     
  2. Nibo

    Nibo Member

    Joined:
    Oct 12, 2010
    Messages:
    1,141
    Likes Received:
    230
    Try removing shader cache. Remove this folder - steamapps\common\rFactor 2\UserData\Log\Shaders
     
    Baldeagle611 likes this.
  3. Baldeagle611

    Baldeagle611 Registered

    Joined:
    Apr 4, 2017
    Messages:
    22
    Likes Received:
    6
    Will do.

    I'll let you know if it works.
     
  4. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,513
    Likes Received:
    573

    • RECOMMENDED:
      • OS: Windows 7, 8, 8.1 or 10, with latest Service Packs
      • Processor: 3.0 GHz Intel i5 or 4.0 GHz AMD FX
      • Memory: 8 GB RAM
      • Graphics: nVidia GTX 760 or AMD 7870
      • DirectX: Version 11
      • Network: Broadband Internet connection
      • Storage: 60 GB available space
      • Sound Card: DirectX Compatible

    • MINIMUM:
      • OS: Windows 7, 8, 8.1 or 10, with latest Service Packs
      • Processor: 2.8 GHz Intel Core 2 Duo or 3.0 GHz AMD Athlon II x2
      • Memory: 4 GB RAM
      • Graphics: nVidia GTS 450 or AMD Radeon 5750
      • DirectX: Version 9.0c
      • Network: Broadband Internet connection
      • Storage: 30 GB available space
      • Sound Card: DirectX Compatible
     
  5. Baldeagle611

    Baldeagle611 Registered

    Joined:
    Apr 4, 2017
    Messages:
    22
    Likes Received:
    6
    Tried that. Still broken I'm afraid. :(
     
  6. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    364
    Likes Received:
    109
  7. Baldeagle611

    Baldeagle611 Registered

    Joined:
    Apr 4, 2017
    Messages:
    22
    Likes Received:
    6
    Thanks. Will try that over the weekend, although I think I already did that.
     
  8. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    517
    Likes Received:
    182
    Try lowering shadow settings. I got some problem like this but it was mod related issue. Not my side. But it could work for you
     
  9. Baldeagle611

    Baldeagle611 Registered

    Joined:
    Apr 4, 2017
    Messages:
    22
    Likes Received:
    6
    I suppose this could be mod-related too. The Monte Carlo 1966 track is from the workshop. I'll give that a go too thanks.
     
  10. Baldeagle611

    Baldeagle611 Registered

    Joined:
    Apr 4, 2017
    Messages:
    22
    Likes Received:
    6
    Well guys, having spent most of the weekend trying all the above suggestions, including re-installing the whole lot, I can safely say that it's broke.
    Can I roll back to older version? If not, it's coming off the HD.
     
  11. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    164
    Likes Received:
    51
    disable post possessing effects
    set AA to the lower number you can
    disable shadows
    set graphics to low
    your graphic card is not for gaming
     
  12. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    517
    Likes Received:
    182
    btw: rfactor not showing beta anymore. DidnĀ“t notice
     
  13. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,513
    Likes Received:
    573
  14. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    133
    Likes Received:
    30
    Intel graphics do not have hardware DirectX hardware Transform and Lighting, that's why all gaming/simulator software manufacturers ask for Nvidia Geforce or AMD Radeon based graphics cards as minimum requirements.
     
  15. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    364
    Likes Received:
    109
    An IGP (Integrated Graphics Processor) like the Intel Iris Pro GPU 6200 is an integrated graphics chip on the processor.
    Most of us use a dedicated video card for gaming like an AMD or nVidia video card.
    Not having any own dedicated memory, the Intel Iris Pro GPU 6200 shares your 8GB RAM memory, often quite conservatively .
    In your BIOS you can increase the amount of IGP memory to be shared.
    If you say it worked before then post your PC specs (mainboard make/model /processor/ memory/ Windows version) and we can see if we can help.
    If you are not sure of this info then run HWInfo and post the data:
    https://www.hwinfo.com/
    Remember, the more complete your PC specs info, the easier it is for us to analyse.
     
    Last edited: Feb 20, 2018 at 6:12 PM

Share This Page