[SOLVED] rf2 not launching

Discussion in 'Technical & Support' started by Cote Dazur, Jul 4, 2019.

  1. Cote Dazur

    Cote Dazur Registered

    Joined:
    Jun 23, 2017
    Messages:
    117
    Likes Received:
    31
    RF2 not launching any more, was fine 3 days ago. it shows the rf2 red and blue logo and then comes back to the launcher.
    I am in VR, only difference is that I changed my flat screen, I am not using it to drive.
    all other sim work fine.
    checked steam integrity, checked resolution, 1920 x 1280
    what else do I need to do
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,017
    Likes Received:
    4,146
    Try moving your player folder out and try again. Could be corrupt json files.
     
  3. Cote Dazur

    Cote Dazur Registered

    Joined:
    Jun 23, 2017
    Messages:
    117
    Likes Received:
    31
    tried that, removed player folder in D:\SteamLibrary\steamapps\common\rFactor 2\UserData, did not change anything.
     
  4. BrianBosch

    BrianBosch Registered

    Joined:
    Jun 16, 2018
    Messages:
    18
    Likes Received:
    14
    Did you have a recent WIndows update? I had the same last week. Hours of trial and error and tried to find out any changes. At the end in my case it had to do with a new default sound source. During the update it seems that the TV monitor was selected as default in stead of my Voicemeeter. For some reason that created conflicts and resulting in rF2 not starting anymore. Hope it helps?
     
  5. Cote Dazur

    Cote Dazur Registered

    Joined:
    Jun 23, 2017
    Messages:
    117
    Likes Received:
    31
    No, thank you, no recent Windows update and my sound source has not changed, still Rift Headphones.
     
    Last edited: Jul 5, 2019
  6. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,017
    Likes Received:
    4,146
    Did you go into the video settings in the launcher and check they're correct?

    Also try running each of the files in the support\runtimes folder.
     
  7. Cote Dazur

    Cote Dazur Registered

    Joined:
    Jun 23, 2017
    Messages:
    117
    Likes Received:
    31
    Yes I checked, they look fine, what would not be correct in the video settings that would prevent the game from launching?

    where is the support\runtimes folder?
     
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,017
    Likes Received:
    4,146
    I don't know what would cause it, but you mentioned changing screens so it's worth checking the game has the current config correct.

    The support folder should be in your rF2 folder.
     
  9. Cote Dazur

    Cote Dazur Registered

    Joined:
    Jun 23, 2017
    Messages:
    117
    Likes Received:
    31
    Thank you.

    What is a correct config?

    One thing about the resolution even though I am in VR, does the resolution had to exactly match the resolution of the flat screen? Or is there a particular resolution that needs to be there?
     
  10. Connor

    Connor Registered

    Joined:
    Sep 24, 2013
    Messages:
    95
    Likes Received:
    40
    having the same problem here .. no changes no new hard or software
     
  11. wrxxy

    wrxxy Registered

    Joined:
    May 17, 2012
    Messages:
    337
    Likes Received:
    90
    Try removing your *RCD files in your settings folder if you have thousands of them........
    Let me know how it goes..
     
  12. Connor

    Connor Registered

    Joined:
    Sep 24, 2013
    Messages:
    95
    Likes Received:
    40
    OK so I Uninstalled it & Reinstalled it .. deleted the few files ( results & replays ) and did a PC restart ..rf2 is up and running :)
    Hope that helps yea Cote Dazur .. Cheers wrxxy , BrianBosch &
    Lazza
     
    Cote Dazur likes this.
  13. M.Bos

    M.Bos Registered

    Joined:
    Mar 11, 2018
    Messages:
    1
    Likes Received:
    0
    Same problem occurring today.
     
  14. Cote Dazur

    Cote Dazur Registered

    Joined:
    Jun 23, 2017
    Messages:
    117
    Likes Received:
    31
    Uninstalled, deleted everything RF2 related and reinstalled, now working again.
    Of course lost all settings and will have to start as if a new game. But the good news is, it is actually working better, loading faster.
    Hopefully will stay that way.:)
     
    Connor likes this.
  15. Booth_doberman

    Booth_doberman Registered

    Joined:
    Oct 5, 2015
    Messages:
    91
    Likes Received:
    37
    Running the files in the support\runtimes folder as suggested above solved it for me. It installed the redistributable and that fixed it. I recall when I started up Steam before the launch problem seeing a quick message about the redistributables.
     

Share This Page