rF2 Multiple installs on Steam (Tutorial)

Discussion in 'General Discussion' started by danalm, Jan 1, 2017.

  1. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,007
    Likes Received:
    362
    Download of Workshop items with SteamCmd seems not working, i`m getting allways just a 2 byte file...
     
  2. Week

    Week Registered

    Joined:
    Mar 14, 2016
    Messages:
    51
    Likes Received:
    32
    I follow all the steps, but when I reach step 10 it gives me error "can not find steamcmd.exe"
     
  3. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,206
    Likes Received:
    356
    @danalm

    Thanks mate, this got me the second install I wanted.

    But now I wonder; if I go to steam and click for the open Beta, it does only the original install, right?
    How can I update the second install?

    Your tut is very good; I got it working and that should be the benchmark; if I understand, everyone will ;)
    Btw, I also had to click in the path of that second .exe and I had it unzipped right next to the first. But no problem there of course.

    Again, thanks man, very nice!
     
  4. Narrowbackwing

    Narrowbackwing Registered

    Joined:
    Jan 12, 2012
    Messages:
    428
    Likes Received:
    156
    Thank you , great tutorial .
     
  5. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,206
    Likes Received:
    356
    I withdraw my question.

    I noticed that subscribing to workshop items, doesn't give me that mod anymore. Not in the original, not in the second.
    I also got the message that there was a problem; the game had been played on another system and synchronising was some kind of problem. If I were to continue, progress might get lost.

    I deleted the complete second install, but still no content comes in when I subscribe.
    So, my install may be broke?

    Does anyone have an idea of what I can do now besides doing a complete new install? :(
     
  6. lamck

    lamck Registered

    Joined:
    Jun 9, 2013
    Messages:
    45
    Likes Received:
    2
    Have you tried the "Verify Integrity of Game Files" to repair the original copy?

    To run 2nd or 3rd ... install properly, you need to run steam first, it will login in your account, then run the launcher.exe of the install you want. It will update the workshop content automatically.

    If you run launcher.exe of other install directly, it will not login to the steam account and workshop content update will not occur.
     
  7. Sento Siete

    Sento Siete Registered

    Joined:
    Jan 11, 2012
    Messages:
    6
    Likes Received:
    0
    Same for me, what must we do?
     
  8. danalm

    danalm Registered

    Joined:
    Aug 31, 2014
    Messages:
    34
    Likes Received:
    43
    Did you download and extract the steamcmd.exe?
     
  9. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,732
    Likes Received:
    2,097
    Thanks for the tutorial, I got as far as:
    Please note though, that there are some shortcomings with this method. For one, subscribing to Workshop items will sync the content on all installed rF2 copies.

    Has anyone found a way to have one install with Workshop content and a 2nd with Vanilla/Blank and then able to install selected content to that 2nd install?
    Thanks.
     
  10. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    534
    Likes Received:
    129
    I guess I'm lazy, I just do the same as I did in rFactor1, and copy and paste the rFactor2 folder, and make a shortcut to the rFactor2.exe instead of the launcher. If I want to install a rfmod, I use the mod manager instead of the launcher.
     
  11. Hugh Crummond

    Hugh Crummond Registered

    Joined:
    Nov 20, 2018
    Messages:
    12
    Likes Received:
    62
    I was thinking about doing this very thing today but wasn’t sure if it was as easy as it used to be with rf1.

    Certain cars work well with certain tracks, then today I was noticing huge performance highs & lows while running oculus vr

    The multiple install was always a good thing with rf1, and reading this.. great news for me & rf2

    Thanks for the info..
    However, my evening with nothing planned has just been danced all over ;)

    as reported by others, cannot find cmd error...

    oh well, I may uninstall / reinstall a vanilla and just copy it
     
    Last edited: Nov 29, 2018
  12. KostasGR

    KostasGR Registered

    Joined:
    Mar 17, 2016
    Messages:
    28
    Likes Received:
    2
    First of all, nice tutorial. I followed it before 7 months and I had two versions of rF2 easily done!
    Now at the tutorial you are saying that all the installations will sync-up with Workshop Content and you are suggesting a method for not doing that.
    I believe that I found a better solution. I am using one installation for racing at FSR,SRC Academy etc. and another installation to race in another league which uses .rfcmp files and not "workshop content" subscription. Like you said if i open the other league installation I will end up stacking the workshop content mods. Well what I did is that before opening the second installation I will go to Steam and Go Offline...Then the Steam will go to offline mode and if you open whatever installation (even the official one) it will just not sync-up with the workshop content... Half of a problem solved... So what about if you need some workshop content to the second installation. Well then comes the method you said. Subscribe-->Transfer .rfcmp-->Unsubscribe...
     
  13. The Iron Wolf

    The Iron Wolf Registered

    Joined:
    Feb 20, 2016
    Messages:
    989
    Likes Received:
    974
    Guys, sorry if it is not appropriate for this thread but it is kind of related. I am followinng this https://docs.studio-397.com/users-guide/in-full-control-managing-your-steam-install-manually

    and I am stuck at the last step. I am trying to pass "offline" and "-workshop" parameters to launcher, but it won't start. If I pass parameters to rF2.exe, it would launch launcher of the primary rF2 install, and that's not what I want.

    I am trying to set up separate rF2 install for community content that does not render correctly since b1118. Any suggestions? Anyone got a b1117 separate install working? Cheers!
     
  14. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    945
    Likes Received:
    989
    Code:
    Bin64\rFactor2.exe  +singleplayer +path=".."
     
  15. The Iron Wolf

    The Iron Wolf Registered

    Joined:
    Feb 20, 2016
    Messages:
    989
    Likes Received:
    974
    thanks, but that still launches the launcher from the main steam install.

    EDIT: got it working. I think I made two mistakes: specified wrong build and ran Launcher without steam running.
     
    Last edited: Aug 31, 2020
  16. machine

    machine Registered

    Joined:
    Jan 31, 2011
    Messages:
    390
    Likes Received:
    262
    I have a feeling that running the 2nd install (installed by SteamCMD) is now broken. Whenever I try to run this install now, it runs the primary install. And throws an error " =path=".." +workshopsync ". Anyone who still has 2nd install working, please answer how?
     
  17. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,086
    Likes Received:
    761
    I have only one install, I used to get the same error as you and solved it by running steam as admin. Dunno if that will help with a 2nd install though, worth a try maybe.
     
  18. The Iron Wolf

    The Iron Wolf Registered

    Joined:
    Feb 20, 2016
    Messages:
    989
    Likes Received:
    974
    I have build 1122 with only Apex GT3 and URD T5 2012 in it, I created a shortcut to launcher and uninstalled full build. This as a shortcut seem to work: C:\Games\rF2\Launcher\Launch rFactor.exe" offline -workshop
     
  19. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,007
    Likes Received:
    362
    Same here. I cant get working a pre-newui steamcmd install.
     
  20. machine

    machine Registered

    Joined:
    Jan 31, 2011
    Messages:
    390
    Likes Received:
    262
    I don't think it is UI related. I had not ran my game for a few weeks. It worked when before, now it does not. I did not update. I have gone back to old ui, still does not work. Let's see who else has same problem.
     

Share This Page