RF2 doesn´t work properly after DX 11 updating

Discussion in 'Technical & Support' started by Leonardo Palermo, Mar 14, 2018.

  1. Leonardo Palermo

    Leonardo Palermo Registered

    Joined:
    Mar 14, 2018
    Messages:
    3
    Likes Received:
    0
    Hi all, I own a Iris 5200 pro GPU in a i5 notebook and used to play RF2 ok with DX9. So after the DX11 update the game doesn´t run properly anymore. It either appears a message indicating "there´s no enough video memory" when the game is loading or the game load, but it comes severe stuttering. This situation never occured before. I would like to know from you if when you updated from dx9 to dx11 what have changed that caused this situation and what I could do to solve it. Thanks in advance.
     
  2. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,028
    Likes Received:
    1,423
    When you load the Launcher go into the Settings (Gear Icon above Multiplayer), select Video Settings at the top and make sure the GPU is set to your main GPU and not on Auto or built-in GPU.

    Try that and please report back if it helps :)
     
  3. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    598
    Likes Received:
    201
    Last edited: Mar 14, 2018
  4. Leonardo Palermo

    Leonardo Palermo Registered

    Joined:
    Mar 14, 2018
    Messages:
    3
    Likes Received:
    0
    When you load the Launcher go into the Settings (Gear Icon above Multiplayer), select Video Settings at the top and make sure the GPU is set to your main GPU and not on Auto or built-in GPU.

    Try that and please report back if it helps :)

    Ok, I did it but it didn´t work.....
     
  5. Leonardo Palermo

    Leonardo Palermo Registered

    Joined:
    Mar 14, 2018
    Messages:
    3
    Likes Received:
    0

    Ok, I´ll do that. Thank you. As soon as I try I´ll tell you.
     
  6. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    598
    Likes Received:
    201
    This is in Dutch but the Steam screen is self explanatory.
    Pick the last DX11 beta version v1109, afterwards you want to verify the files at the tab to the left of BETA's, shut down Steam, reopen rFactor Launcher, select your video card and settings and try restarting the game

    upload_2018-3-15_20-50-55.png
     
  7. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,387
    If I am not wrong, that is default version which is not considered beta any more.
    By checking it, you simply avoid it from updating to a different build.

    The last dx11 beta version you can actually select is for build 1108 which is a temporary workaround for offline simracers (you don't benefit from 1109 features).

    For online races this is no good solution since most channels use latest 1109 build.
     
  8. Marcel Offermans

    Marcel Offermans Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    432
    Likes Received:
    1,608
    To get the latest version, just choose the default and "opt-out" of any betas.
    At the moment v1109 is identical to the latest version, but when we release the next version (v1110) you will not get that version automatically if you chose v1109 (that will keep you at that version).
    The only reason why we allow people to stick at a specific version is that we sometimes do an update right before some race and the server admin might not have had time to upgrade. If that ever happens to you, you can use this beta tab to go back to a previous version and not miss your race.
     
  9. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    598
    Likes Received:
    201
    Thank you Marcel for explaining the versions and the reasoning behind it, handy to know this now.
    The reason for this thread is someone using an Intel Iris Pro GPU 5200 IGP and is getting a "not enough video memory" message when it worked before.
    Here is the solved thread from someone recently with a similiar Intel Iris Pro GPU 6200 IGP I was looking for.
    They experienced the "not enough video memory" message when rF2 was updated after playing it before on the same computer.
    After going back a build they could resume playing.
    https://forum.studio-397.com/index.php?threads/rf2-not-working-properly-anymore.59298/#post-935851
    So presumably if you have this problem then to go back to beta v1108 until v1110 is released.
    Heres looking forward to v1110 !
     

Share This Page