SOLVED Reported crashing with new build

Discussion in 'Technical & Support' started by Domino Duhan, Dec 22, 2018.

  1. Alessio Feletto

    Alessio Feletto Registered

    Joined:
    Jun 9, 2017
    Messages:
    110
    Likes Received:
    53
    "Damplugin" activated here and it's working fine.

    Shared memory plugin doesn' t cause any problem or at least on my system.
     
    Last edited: Dec 23, 2018
  2. MileSeven

    MileSeven Registered

    Joined:
    Apr 1, 2014
    Messages:
    622
    Likes Received:
    241
    Another D3D9.dll fixed-user here. The Motec (DAM?) plugin is working fine for me.

    My heart did sink when I read the release notes about 'finishing the year with a bang' - and, thankfully, it turned out to be more of a whimper...
     
    Sexy Brigadeiro likes this.
  3. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,697
    Likes Received:
    826
    i deleted :bin32-bin64-userdata folders and save myself from heavy stuttering :)
     
  4. Daniele Vidimari

    Daniele Vidimari Registered

    Joined:
    Apr 20, 2016
    Messages:
    659
    Likes Received:
    593
    Uhm? The issue is caused by the d3d9.dll, a dll you no longer use from 1 year at least.
    No issues with damp plugin here.
     
  5. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    923
    Likes Received:
    578
    Thanks, I read this before I started the sim and removed the d3d9.dll as a precaution and have had no problem. ;)
     
  6. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    839

    Everyone should delete the d3d9.dll file or just who bought the new gt3 pack?
    ImĀ“getting a message like that when trying to joining yanucks server with Buenos aires historic

    edit: btw, i dont have this d3d9.dll file in bin64 folder

    edit2: but i have some dll from a third part plugin that i dont use anymore (rf2simdashboardplugin.dll). Is that it?
     
    Last edited: Dec 23, 2018
  7. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    839
    deleting 64 folders
    verifying files 275 failed
    Now rf2 stuck in 0% and not validating
    Playtime already ruined.

    edit: validating now stuck in 100% :mad:
     
    Last edited: Dec 23, 2018
  8. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,697
    Likes Received:
    826
    @Louis restart windows - open steam-verify integrity
    always remember that if something dont work as usual its mostly windows servises fault
    or something like that
     
  9. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    839
    Thanks. But everything but was working before the last update.
    Did what you said and it seems it will work now (already downloading the missing 275 files). Fingers crossed.
     
    mesfigas likes this.
  10. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,902
    Likes Received:
    6,294
    I hope it's not giving you an issue :)

    They aren't taking away anything. Their advice to remove the Bin64 folder is because that's the easy way to remove old files that can cause issues. They could just say delete d3d9.dll but who knows what else people have in there that could link to drawing plugins or similar.

    There shouldn't be any issues with 'current' plugins, including mine. If you isolate an issue please report in its thread. Cheers!
     
  11. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    839
    Well, validating files is finished but in mais menu of steam i got this:
    stopped.png
     
  12. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,697
    Likes Received:
    826
    @Louis believe it or not windows also change the GPU drivers for no reason :(
    you cant believe how much stuttering and bad graphics i experience today and still hant explain why it happened
    i setted the windows updater to start when i have my computer off so i will avoid updates that makes no sense and almost destroyes my computer
    i reinstalled ati drives and deleted with DDU the files at safe mode
    also deleted the files i told you in previous post and now everything works perfect
     
    Louis likes this.
  13. W Lukas

    W Lukas Registered

    Joined:
    Apr 14, 2014
    Messages:
    109
    Likes Received:
    11
    Unfortunately IT is 100% damplugin, i have deleted the file and it is working, with it i cant exit rf2, need to end in task manager
     
  14. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    839
    No luck here. Deleted bin64 folder, reestart, cbash and shaders folder. It validates all and download but now im getting this:

    Which was the first gmotor error i as getting before deleting bin64 folder gmotorerror.jpg


    edit: will try another mod
     
  15. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    839
    Jesus freaking Christ, it was mod related.
    Just 1000 hours of rf2 gameplay trying to figure this out. Ruined my party :mad:
    1001.png

    :p
    despite this emoji, im really angry
     
  16. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,697
    Likes Received:
    826
  17. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    839
    i mean, "i was about to complete 1000 hours of gameplay and missed when happened because of this". English, also my bad as doing new build test with third party mods
     
  18. avenger82

    avenger82 Registered

    Joined:
    Dec 29, 2016
    Messages:
    790
    Likes Received:
    332
    I also confirm deleting/moving d3d9.dll solved the issue. I was really frustrated about this and it saved reinstalling ton of mods.
    Thanks!
     
    Louis likes this.
  19. whitmore

    whitmore Registered

    Joined:
    Feb 26, 2012
    Messages:
    552
    Likes Received:
    142
    Yes d3d9.dll deleted to fix no start
     
    Last edited: Dec 25, 2018
  20. lucaf

    lucaf Registered

    Joined:
    Dec 25, 2018
    Messages:
    7
    Likes Received:
    4
    Renamed d3d9.dll in bin64 folder and now my single player mode works again (hanged when track loading progressbar went to 100%)
     

Share This Page