Replays running slow.

Discussion in 'Bug Reports' started by wrff.tiger@gmail, May 14, 2021.

  1. wrff.tiger@gmail

    wrff.tiger@gmail Registered

    Joined:
    May 14, 2021
    Messages:
    42
    Likes Received:
    24
    Hey guys,

    I’m new to rfactor 2 and mostly loving it however I am having some issues. I’m experiencing slow motion in replays and it really is annoying. I have seen other people mention having the same problem going all the way back to 2018. Is anyone working on fixing this? Thanks in advance.
     
  2. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,423
    Likes Received:
    1,483
    AFAIK that problem was solved long time ago.
    Currently there is a problem of stuttering that is solved for most people, in the Release Candidate.
    Does it happen with all cars and tracks?
    Could be your CPU having big spikes?
     
  3. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    540
    Likes Received:
    1,626
    The slow motion replay problem has not been solved, I still get slow replays on some track and car combo's.
     
  4. wrff.tiger@gmail

    wrff.tiger@gmail Registered

    Joined:
    May 14, 2021
    Messages:
    42
    Likes Received:
    24
    I don’t think it is a problem with my equipment. I get these slow replays only with some track car combos and even though my fps is well over 100. Everytime I try to race gtpc porsche 956/b at laguna seca as an example. Whenever I run this car track combo it is in slow motion. I run other cars at laguna seca no problem and I run the 956 at track like Monza with no problem. It is very frustrating.
     
  5. wrff.tiger@gmail

    wrff.tiger@gmail Registered

    Joined:
    May 14, 2021
    Messages:
    42
    Likes Received:
    24
    My system specs:
    Processor Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz 2.59 GHz
    Installed RAM 16.0 GB
    NVIDIA GeForce RTX 3070 Laptop GPU

    My understanding is this setup should have no problem running Rfactor 2 as long as I have it configured correctly. Which is why I'm asking, do I have something set incorrectly that is causing the replay issue?
     
  6. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,492
    Likes Received:
    4,515
    Does your laptop allow you to lock the CPU speed, so it doesn't change? (I don't know if the windows power settings will do that - I've never tested) Just as something to test.
     
  7. wrff.tiger@gmail

    wrff.tiger@gmail Registered

    Joined:
    May 14, 2021
    Messages:
    42
    Likes Received:
    24
    Hey Lazza,

    I wouldn’t know how to do this or if it would be a good idea or not. I know in graphics card settings there is physx setting you can select cpu or gpu. Someone mentioned this might solve the problem. I tried both settings and it seemed to make no difference. I left set to auto which is Nvidia’s recommended setting. I really don’t understand why only some car track combos seem to cause the issue where as other car track combos that you would think would be just as demanding on system resources don’t seem to cause the problem.
     
  8. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,659
    Likes Received:
    2,582
    I don't know if Physx was ever enabled in rF2. (it may, I don't know) But I'd try just disabling it completely. next since it is a laptop, you are probably sharing video and system ram. So try shutting down as many apps/processes as possible before launching rF2. From what we have gathered, this slowdown can be rather random, but trying larger tracks with updated graphics along with DLC cars like Ferrari GT3 and Corvette GTE may be exhausting your ram. (big 'may'. never used a laptop) It certainly seems stout enough to run rF2. best of luck.
     
  9. wrff.tiger@gmail

    wrff.tiger@gmail Registered

    Joined:
    May 14, 2021
    Messages:
    42
    Likes Received:
    24
    Hey guys, here is a twist in the plot for you. I just ran a 5 lap race at Laguna Seca with the porsche 956 with a 20 car field and the replay was in completely normal speed. The practice session was still in slow motion. So I have no idea what is going on, but I believe that proves it isn't a problem with my systems capabilities. Any ideas as to why the practice and qualy sessions are in slow motion but the race is completely normal?
     
  10. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,492
    Likes Received:
    4,515
    There's no doubt your system is capable, or all replays (and, more so, the live gameplay) would always be slow.

    It's very likely an intermittent bug you can't fix. My question re CPU speed is based on the possibility that a changing CPU clock may confuse the game's timing.
     
  11. wrff.tiger@gmail

    wrff.tiger@gmail Registered

    Joined:
    May 14, 2021
    Messages:
    42
    Likes Received:
    24
    Hey Lazza, Thanks for your interest. If you have some instructions on how I would go about trying what your suggesting, I would certainly give it a try. I am not sure how I would do what your describing.
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,492
    Likes Received:
    4,515
    If you get a monitor that can show you a CPU speed history, you should first be able to confirm whether the CPU speed is changing. Then if you find it is, you can try to lock it. Otherwise there's no point.
     
  13. Manfredk2

    Manfredk2 Registered

    Joined:
    Dec 27, 2018
    Messages:
    340
    Likes Received:
    370
    I notice this issue also on some car/track combinations. Afair VRC Indycar at Road Atlanta is one of those combos. Running 8700K with RTX 3090
     
  14. wrff.tiger@gmail

    wrff.tiger@gmail Registered

    Joined:
    May 14, 2021
    Messages:
    42
    Likes Received:
    24
    Hey guys, I just wanted to say I am still having this issue. Does studio 397 monitor these forums? Do they know about this issue? It seems I am not the only one experiencing this and it has been going on for a long time.
     
  15. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,492
    Likes Received:
    4,515
    As lagg said above, this was a more widespread bug that was mostly fixed. So if you are seeing historical stuff it may instead relate to that other, now fixed, bug. Yours is more intermittent. You are correct you're not the only one.

    Have you checked your CPU speed yet?
     
    lagg likes this.
  16. CIP060

    CIP060 Registered

    Joined:
    Oct 8, 2019
    Messages:
    53
    Likes Received:
    21
    replay now work perfectly for me
     
  17. mjo1704

    mjo1704 Registered

    Joined:
    Feb 10, 2013
    Messages:
    71
    Likes Received:
    13
    my experience with this problem is track and car specific eg studio 397 cars and studio 397 tracks do not have this problem.but some third party cars and tracks especially if some crash happens
    CPU usage rises to 100% in this case the replay is shown in slow motion but this does not apply to all mods i.e. some mods are incomplete or invalid For example, the Cart 85 mod and the Long Beach 79 track are a combination of the latest shows in slow motion
     
  18. wrff.tiger@gmail

    wrff.tiger@gmail Registered

    Joined:
    May 14, 2021
    Messages:
    42
    Likes Received:
    24
    Rfactor2.stats.PNG
    Hey guys these are the stats I was able to get from Nvidias in-game overlay/shadow play feature this is from the csv file that Nvidia generates. I don't know why the FPS is not showing.

    As you can see my max CPU utilization is 46% and the mean is 15.6%, I wouldn't think that this is bad.

    This came from a quick session with the Porsche 956 at Laguna Seca during a practice session with 20 AI opponents.

    As usual driving in the car seemed normal, but the replay the cars where crawling around the track in slow motion.

    Curious as to what you guys think?
     
  19. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,659
    Likes Received:
    2,582
    The one item that I'm not seeing, or just not understanding, is the amount of Vram being used. If your vidcard is filling up during the driving portion, it may not be flushed out prior to loading the replay. I guess another thing to try. Record a replay, exit completely out of rF2, then reload rF2 and go directly to the replay section and try to view the same replay.
     
  20. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,492
    Likes Received:
    4,515
    I guess it confirms it's not your CPU suddenly getting bogged down, but other than that it's as expected - your system is capable of running the game and replays, and does so fine much of the time. This looks like a bug.

    I'm still curious if your CPU clock is changing, and whether stopping it doing so would make any difference. (not its utilisation - I mean its actual speed)
     

Share This Page