[REL] Released New Material Editor! (Car Paints)

Discussion in 'News & Notifications' started by Christopher Elliott, Jan 31, 2019.

  1. Akela_DE

    Akela_DE Registered

    Joined:
    Jan 23, 2018
    Messages:
    380
    Likes Received:
    255
    Can anyone tell me, why my chrome is no chrome ?
    Showroom and track are very different
    upload_2019-5-17_10-38-5.png bmwM6rotchrome.png
     
  2. FuNK!

    FuNK! Registered

    Joined:
    May 26, 2013
    Messages:
    550
    Likes Received:
    383
    Great to see so many nice OSS logos on one car ;)
    What track have you tested? Could be track related, so try one of the official tracks. Also try to max your graphic settings, if you are using lower settings (the showroom is allways using max settings).
     
    Akela_DE likes this.
  3. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,039
    Likes Received:
    2,340
    Akela_DE likes this.
  4. Akela_DE

    Akela_DE Registered

    Joined:
    Jan 23, 2018
    Messages:
    380
    Likes Received:
    255
    *facepalm, just was up to say: it is already maxed out - but it was not, i had reflections turned off because of rain mirrors on track.
    Thx guys!, its working now. Man, this game makes me ready - as we germans say :D 12 chars in name has to be 8.3!

    @funk thx. i thought its boring to have always the same logo like michelin, dunlop etc. And i am using w10 only for gaming :cool: oh and gimping oc
     
    FuNK! likes this.
  5. FuNK!

    FuNK! Registered

    Joined:
    May 26, 2013
    Messages:
    550
    Likes Received:
    383
    Yes, the game makes you ready (Englishman would likely say "drives you nuts") :D:D Anyway, glad that it works now!

    So you are another Linux user, perfect! Maybe you already saw this article? At least your skin perfectly fits into that topic! ;)
     
    Akela_DE likes this.
  6. "Phil"

    "Phil" Registered

    Joined:
    Aug 13, 2017
    Messages:
    18
    Likes Received:
    3
    Just to be sure D. , this is the DDS file that can't have a "P" or the driver name? Thanks in advance!
     
  7. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    138
    Likes Received:
    116
    Hi guys,
    I have painted many cars and post them at Racedepartment. All new cars´s files are compiled into a single MAS file per car. I uloaded the RCD file and the folder with the MAS file, both zipped.
    However, some guys complained that they can´t see the AI cars with my skins or that they look completely white. I have checked everything and everything seems to be fine here. Here a screenshot I took at the start at S397 Sebring with almost all the AI cars in the grid, and they look ok. Some guy suggested I should include only DDS files and no MAS.
    Any idea about what could be wrong? or what should I do to avoid this problem?
    GRAB_000.JPG
     
  8. Depco

    Depco Registered

    Joined:
    Jun 16, 2014
    Messages:
    854
    Likes Received:
    523
    We have a number of league members who are having the same issue. I am not a modder or skinner so I don't really know what the fix is for this. It would be good to get an answer so I can help our struggling members.
     
  9. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    821
    Likes Received:
    1,209
    try adding the .veh file to the update package & dds files
    example:
    driver1.veh
    driver1.dds
    driver1extra5.dds
    driver1helmet.dds
    driver1windows.dds

    driver2.veh
    driver2.dds
    driverextra5.dds
    ...
     

    Attached Files:

  10. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    138
    Likes Received:
    116
    But why do I need a VEH file for a painting I did? VEHs are used only by S397 cars.
     
  11. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    821
    Likes Received:
    1,209
    the loading of skins in the settings directory I think is causing problems when starting rfactor2. I think that if instead of using the system always creates an update package is easier to manage for the core of the game and therefore should cause fewer errors.
    P.D. about the .veh file, I mean the structure that Studio uses for the skin package. You can try to create an update package without the veh. vehicle
     
    Last edited: Jun 7, 2019
    MaD_King likes this.
  12. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,830
    Likes Received:
    611
    I agree with @Art_Pereira the Virtual Ride have to work correctly, it's a feature of the game, so why forcing people to create "package update" when there is already a mean to do it without "version constraint packaging followup".
     
  13. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    138
    Likes Received:
    116
    I think that creating a package update each time a new car is painted and added is way too much complicated. The procedure to add a car seems to be simple, but for some reason, sometimes it works and sometimes not. What is worrying me is that sometimes cars packed into MAS files created with the rFactor2 utility don´t work and are shown as white cars.
     
    Corti likes this.
  14. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    138
    Likes Received:
    116
    A bug in rFactor2 perhaps? This must be worked out. Otherwise, painting a car for rF2 is a waste of time since nobody can be sure about the results, and I am not talking about the painting being good or bad. I am talking to see the car in the track properly.
     
    Corti likes this.
  15. Slamfunk3

    Slamfunk3 Registered

    Joined:
    Jan 6, 2012
    Messages:
    270
    Likes Received:
    126
    The white car thing is usually caused by an incorrectly done regions.json file, or an outdated one as there have been some format changes to it recently. Also I believe the server being setup for "skin transfer" instead of "virtual driver" transfer could cause the car to show white. Personally i have loose files and a .mas file for each of my skin, loose files work for single player while the .mas is for online.

    TK
     
    Art_Pereira likes this.
  16. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    821
    Likes Received:
    1,209
    I agree. My intention is to rule out possible failures o_O, lately my settings folders are full of small files (but thousands of them) when loading the skins of other players :eek:. With the edition of the "teams" of the mod or an update package these files do not appear because there is no transfer of skins. :rolleyes:
     
    Art_Pereira likes this.
  17. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    138
    Likes Received:
    116
  18. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,039
    Likes Received:
    2,340
    The Dev's are aware off the issues (I say issues because each car seems to have it's know unique ones) and are working on it.
     
    mr.Sw1tchblade likes this.
  19. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    138
    Likes Received:
    116
    Thank you!
     
  20. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    821
    Likes Received:
    1,209

    Attached Files:

Share This Page