Recurrent NVIDIA Driver Crashes and Erratic GPU Usage

Discussion in 'Technical & Support' started by ECAR_Tracks, May 9, 2016.

  1. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,089
    Likes Received:
    440
    Yes, it was crashing after 2.5 laps. But tbh, this seems for me track related and have nothing to do with rF2 or Nvidia nor AMD.

    I tried this combos today:

    TigerMoth (v1.02), SaoPaulo (v1.01), Senormen`s new Imola (v1.1), Sebring (v2.02) and the Bugatti Track (v0.95)

    Setting max, 25 AI, rMegane WT Mod, i`ve done on each track 5 Laps. No single freeze, everything flawless.

    Apologies in advance for this dumb comparison...but if you trying to play a cd on your cd player and it fails, while 10 other cd`s are playing fine, what would you believe what is the broken part?

    Just for the record, i loaded Le Mans on my office pc, where a AMD R9270x is working and rF2 was crashing within the first lap.

    By the way, the side stripes (tarmac) of Le Mans are a good place to brake your wheel, a hell of rattling...
     
  2. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    I am not the one with the problem, my game can run hours in Le Mans 1991, there is no broken CD`s in my game :) I believe that errors are triggered by a Windows service called 'Timeout Detection and Recovery' (TDR)and would like to know why this is more common in rFactor2 then other games and find good fix to it which can help OT and community.
     
  3. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,089
    Likes Received:
    440
    OK, but why all other tracks are not crashing, is there any (possible) explanation left? No offense, just out of curiousity...
     
  4. guod

    guod Registered

    Joined:
    Oct 5, 2010
    Messages:
    533
    Likes Received:
    78
    To reduce the variables involved, what video sync?

    None
    Software
    GPU
    Video

    Video sync may not have a thing to do with it, but referencing the setting could divulge something.
     
  5. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    To many people also ISI components are crashing with default settings, if Le Mans 91 don`t work it is not big deal but it is good benchmark how good fixes are working.
     
  6. Ronnie

    Ronnie Registered

    Joined:
    Jun 15, 2012
    Messages:
    1,121
    Likes Received:
    296
    Tried that and absolutely no change. My game freezes for 3-8 s and then continues to run perfectly... freeze (stutter) for few seconds and again go smoothly. It's so bad that I can't complete 1 lap without at least one freeze/stutter. I'm going mad right now. I also tried capping my fps to 65 (was running 120-180 with everything set to max) and tried TDR solution. Nothing. It makes me so desperate :(
     
  7. stonec

    stonec Registered

    Joined:
    Jun 19, 2012
    Messages:
    3,399
    Likes Received:
    1,489
    Is that on every car/track combo? For most users it's only on specific tracks where the problem gets really bad, so you are indeed unlucky if it stutters like that everywhere.
     
  8. Ronnie

    Ronnie Registered

    Joined:
    Jun 15, 2012
    Messages:
    1,121
    Likes Received:
    296
    Yes. Tried Sebring, Silverstone, Mills and few others.
     
  9. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
  10. Ronnie

    Ronnie Registered

    Joined:
    Jun 15, 2012
    Messages:
    1,121
    Likes Received:
    296
    Right now the only thing that doesn't seem to be ok from that list is nvidia driver. It's either really bad combo rf2/368.22 driver or it's corrupted. My line of solving will be trying new driver that JUST came out. If it still makes rF2 (and it is ONLY rF2 that works like that. Every other title works perfectly. Witcher 3, Diablo 3, Payday 2 and others) run like crap with ultra high fps but with still those dreadful stutters/freezez I'm going to wipe out whole nvidia driver and install last stable driver which I really need to work out which was working flawlessly. Gonna be a chore unless someone gives me a hand.
     
  11. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    I think it is this from that list: "A badly written driver or piece of software" Nvidia support say`s that game by it self which is poorly optimized and there are some statements from ISI devs that Nvidia hardware and drivers are full of hacks and Nvidia SLI is piece of ****.
    I have tested all Nvidia drivers since release of rF2 and it is possible to play rF2 with every single driver but there are loads of all kind of hick ups like stutters game is hanging few secs,crashes etc.
    The best performing driver to rF2 is 353.30 but of course this driver is one year old and it don`t work as it should any more with 3D vission and you must also use fixes to your OS to get 353.30 to work.
    rFactor2 is fine game with huge potential and it is same to see that many people who are using Nvidia cards are struggling with all kind of issues. NVidia profile (rFactor2 Mod Mode.exe, rFactor2.exe) is created 2011-09-22 and it soon going to have fifth anniversary and it is badly outdated. Maybe new game profile can solve some of the issues and give better game experience to waist majority of Nvidia owners?
     
  12. Ronnie

    Ronnie Registered

    Joined:
    Jun 15, 2012
    Messages:
    1,121
    Likes Received:
    296
    I have to agree with you. Biggest problem with rF2/nvidia is you are slowly getting so paranoid about every single new build paring it with new driver that you can almost hear youself yelling: "WHAT'S IN THE BOX!?!?!" using Brad Pitt's voice. I've had my own periods of rF2 running flawlessly on my old PC then dreadful, then good again. After upgrade I had moments of really cool performances and very bad ones. I always have found solutions to my problems before, while right now I feel so helpless that I feel like a small kid left alone in a mall by my mom looking at avocados thinking: what the hell am I gonna do now?!

    EDIT: I have just run a test with newest nvidia driver 368.39 and I believe this driver fixed the issue. I want to be so happy but I just don't want to get my hopes up. I did a 10 lap run without any even slightest stutter/freeze. Smooth as silk. I will try again on thursday and after that I will be able to comment more on that. But initially it seems that new driver is working. Please, please, please! Let this be true!

    EDIT2: Unfortunately it only made things better not perfect. I still get stutters here and there but no where near as many as before. Used to get 6-7 per lap some of them 8 s long! Now 1-2 stutters every couple of laps 1-2 s long max. Bitter sweet improvement. Ech.
     
    Last edited by a moderator: Jun 12, 2016
  13. Wozza_UK

    Wozza_UK Registered

    Joined:
    Apr 23, 2014
    Messages:
    59
    Likes Received:
    15
    I would like to add my support to this thread. I also get regular system crashes and have tried everything I can to stop it. I made a thread here back in March:
    http://isiforums.net/f/showthread.php/28522-Regular-system-crashes-with-rF2

    I can assure you this is not just an Nvidia problem. My card is AMD and it crashes a lot. I play lots of games/sims but this is the only one with the problem. I've tried all the usual stuff like updating drivers etc.

    My system:
    OS: Windows 7 (64bit)
    CPU: Intel i5 4670K @4Ghz
    GPU: Radeon HD7850 (2Gb) TwinFrozr
    Ram: 8Gb Crucial Ballistix

    This problem makes me not want to play rF2. I play Raceroom, Assetto Corsa etc for hours on end with no problem. That suggest to me rF2 is the problem, not my system.

    Tx.
     
  14. WhiteShadow

    WhiteShadow Registered

    Joined:
    Feb 16, 2015
    Messages:
    681
    Likes Received:
    3
    Try this one maybe it helps.
    Download link Wagnard TDR manipulator: http://www.wagnardmobile.com/DDU/dow...tor v1.1.zip
    Open TDR manipulator > (TdrLevel) > Disabled > Apply > restart your PC. Don`t mess with those other values.

    Download CCleaner: http://ccleaner.no.softonic.com/
    Go to registry tab > Scan for issues > Fix selected issues.

    Launch rF2 ............
     
  15. nipzon

    nipzon Registered

    Joined:
    Dec 23, 2011
    Messages:
    247
    Likes Received:
    35
    Wonder if ISI looks at things like this bug found by the automobilista?
    "Fixed error which caused dust smoke from the dirt side of the road to be almost invisible (might actually resolve some performance / stuttering issues too)"
     
  16. Knackko Lovitch

    Knackko Lovitch Registered

    Joined:
    Feb 22, 2013
    Messages:
    22
    Likes Received:
    0
    Last week-end, as co-organizer of 20x45min races event with classic cars on rfactor1, many drivers had black screens, most during night. I had it too, no matter the graphical settings ingame . So this week I began some testing to determine if it comes from the mod or the track. Tests was 5h to 7h long, 25AI, by night, on Circuit de la Sarthe 2012, black screens occurrences appear after test in windows events log (Display category).

    With endurance series mod (not the mod used during last event) and the track of the event, after more than 5h, no black screen, so for me the issue doesnt come from the track.

    With the classic car mod, it appear several times. So to continue testing, I've removed most of cars parts in .gen file, only collidable box and tires were rendered + cockpit and no headlights: black screens appeared after some hours, but several times within one hour.

    At this time, my tests are not finished, and I don't know if there will be any results and if it is very relevant but next step is to do tests with no tires rendered and rf shaders only (no SRPL or SSRT shaders). Maybe I will test it without any particles/dusts too.

    For your info, my GPU is a Nvidia 750 Ti 2Go
     
  17. Rui Santos

    Rui Santos Registered

    Joined:
    Jan 8, 2012
    Messages:
    1,095
    Likes Received:
    1,225
    After windows clean install, black screen issue came back after 3 weeks, this time at new Oulton Park 1.2 version during a Porsche Super Cup race at race2play. THIS ONLY HAPPENS IN rFactor2!!!!! Can you please get your sh*t together ISI/nVidia guys??? I DON'T KNOW WHAT TO DO!! DO I HAVE TO WASTE MONEY IN NEW PC PARTS AND STILL GET THOSE PROBLEMS??? I can't do that because it only happens with your software!!! :mad:
     
  18. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,089
    Likes Received:
    440
    Oulton is still WIP, try stock content.
     
  19. Rui Santos

    Rui Santos Registered

    Joined:
    Jan 8, 2012
    Messages:
    1,095
    Likes Received:
    1,225
    I'm having those problems for more than half year now with lots of different track/mod combination. As you can read a LOT around internet, there's hundreds of other users with this problem! rFactor2 is bugged as hell, time for ISI to look at this problem and solve things seriously...
     
  20. Rui Santos

    Rui Santos Registered

    Joined:
    Jan 8, 2012
    Messages:
    1,095
    Likes Received:
    1,225

Share This Page