[REL] Realistic Gearshift - version 2

Discussion in 'Other' started by Seven Smiles, Apr 25, 2019.

  1. avenger82

    avenger82 Registered

    Joined:
    Dec 29, 2016
    Messages:
    668
    Likes Received:
    236
    It's not working for me and I don't know why. When I don't use clutch I do hear grind sound, but Numpad 0 isn't pressed and neutral isn't selected at all. I think I set everything correctly: set Numpad 0 as neutral in rF2 etc. Even got the Configurer.exe from older version, to set shifter and clutch values because they weren't detected. Here is my gearshift.ini:

    upload_2020-2-13_23-47-55.png

    Anyone has ideas what is missing?
     
  2. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    876
    Likes Received:
    921
    I think there were problems with Numpad 0 in some cases, try using N instead. It’s one of those things that works perfectly on my PC but there are so many subtle differences on other PCs, other languages, other peripherals...
     
  3. avenger82

    avenger82 Registered

    Joined:
    Dec 29, 2016
    Messages:
    668
    Likes Received:
    236
    Thanks, I'll try it today and let you know
     
  4. avenger82

    avenger82 Registered

    Joined:
    Dec 29, 2016
    Messages:
    668
    Likes Received:
    236
    So I tried different keys in both gearshift.ini file and rF2, different controller file, disabled reshift:
    upload_2020-2-18_23-10-4.png

    But nothing works. In all cases I see Neutral selected once after shifting without clutch but looks like it's immediately overridden by selected shifter gear.
     
  5. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    57
    Likes Received:
    42
    Have you tried this:
    I have realized that gearshift.exe must be started on win10 as ....run as administrator.. (right mouse click) even the user is administrator, otherwise it will not function stable.
     
  6. avenger82

    avenger82 Registered

    Joined:
    Dec 29, 2016
    Messages:
    668
    Likes Received:
    236
    I tried it once when Neutral was set to numpad0, I believe.
     
  7. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    601
    Likes Received:
    170
  8. Sebastien Sestacq

    Sebastien Sestacq Registered

    Joined:
    Jan 11, 2016
    Messages:
    854
    Likes Received:
    1,437
    Unfortunately, I've never been able to get it to work. I'm so lame...:oops:
     
  9. avenger82

    avenger82 Registered

    Joined:
    Dec 29, 2016
    Messages:
    668
    Likes Received:
    236
  10. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    601
    Likes Received:
    170
    if you get the latest version to work please let me know how you managed it.
     
  11. Tnadz

    Tnadz Registered

    Joined:
    Nov 2, 2017
    Messages:
    107
    Likes Received:
    61
    I wasn't able to get the new or old versions to work. They half work, just as described, where the grinding sound will play and the engine will rev, but neutral doesn't get spammed. Oddly enough, the car engine will rev BUT I continue to build speed instead of losing speed like the car would do when it's in neutral.
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,909
    Likes Received:
    4,064
    I still have V1.5.27, and with it running (as normal.. no admin...) I can run notepad, put the shifter into gear without a clutch, and notepad gets spammed with 0's. If you can't get the same something isn't setup correctly.
     
  13. Tnadz

    Tnadz Registered

    Joined:
    Nov 2, 2017
    Messages:
    107
    Likes Received:
    61
    So I did that and it is pressing 0 once per incident and only if I clear it (clutch, neutral). If I just jam into another gear, it will not put out another 0. And I did confirm that KP 0 is the correct 0. I've also tried with other letters and it has the same result. Shouldn't the program send 0 a whole bunch? Like several times a second?
     
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,909
    Likes Received:
    4,064
    Yeah, I get maybe 5 per second in notepad. Are you using that same version?

    @Tnadz just to be clear, it should do it when you put the stick into gear without touching anything else. Otherwise you might need to reverse the clutch axis.
     
  15. Tnadz

    Tnadz Registered

    Joined:
    Nov 2, 2017
    Messages:
    107
    Likes Received:
    61
    3.1.58
     
  16. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,909
    Likes Received:
    4,064
    @Tnadz I'm not that familiar with the latest versions, but I've stuck with the one I have because it works better for me than the newer ones at the time. It only interfaces directly with the controllers (doesn't try to read from the game), and I like the behaviour when it starts 'grinding'.

    If you're going to try an old version, grab the same one I have.
     
  17. Tnadz

    Tnadz Registered

    Joined:
    Nov 2, 2017
    Messages:
    107
    Likes Received:
    61
    So I went back and compared both the newest and the one you posted. The one you have just pushes the neutral button more often. There is no other difference that I can tell. I've tested across several different car mods. I did find that this just seems to be an issue with H pattern (I'm running G27). The shifter has the gear locked in so the N is overridden almost immediately. If it were to spam the Neutral button dozens of times a second, I think this might make it perform the desired function.
     
  18. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,909
    Likes Received:
    4,064
    It's worked fine for me, same shifter.
     
  19. Tnadz

    Tnadz Registered

    Joined:
    Nov 2, 2017
    Messages:
    107
    Likes Received:
    61
    In that case, I'm at a loss. We did a test today with 8 other guys running this reporting the same issue. To confirm, when you force a gear, it goes to neutral and just stays there even though you have the gear engaged physically on the shifter?
     
  20. Tnadz

    Tnadz Registered

    Joined:
    Nov 2, 2017
    Messages:
    107
    Likes Received:
    61
    So as a follow-up, I went through and manually hammered the neutral key I have set (N in this case) and I can hear it kicking into neutral in rFactor2 but the gear stays engaged as long as I am applying accelerator input. If I let off the accelerator, even with the gear physically engaged on my shifter, it will go to neutral. But as soon as I apply throttle, it goes into gear, barely blipping the N on my HUD despite how fast I hammer the N key. So it seems like it's something related to the hardware itself. As I understand it, Grinding Tranny only spams the neutral button and doesn't also send some type of other override command to stop seeing the gear selection? I have no clue how it was able to work before as it clearly has for people, but it doesn't now.
     

Share This Page