[REL] Realistic Gearshift - version 2

Discussion in 'Other' started by Seven Smiles, Apr 25, 2019.

  1. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    657
    Likes Received:
    713
    That old version is still there https://github.com/TonyWhitley/gearshift/releases/tag/V1.5.27

    There is a new version V3.1.59 with the clutch bite point fixed. It also checks the neutral button matches the one in controller.ini
    And just for you @Lazza (except you won't use this new-fangled version :D) I've embedded the version in the .exe file.
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    @Seven Smiles If you get the Reshift option working I'll update :D (I do like the lack of graunching when the engine has already stalled!)
     
    Seven Smiles likes this.
  3. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    520
    Likes Received:
    134
    A little confused, presiing keypad zero on the keyboard produces the missed shift sound and neutral is activated in game but with the shifter not pressing the clutch produces the missed gear sound but neutral is not activated so i can just keep shifting with no clutch needed. Using latest version
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    This sounds a bit like the earlier discussion. Easy to confuse num 0 and kp 0.
     
  5. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    657
    Likes Received:
    713
    I'm confused too, pressing keypad zero on the keyboard does not produce the missed shift sound, that only happens if you miss a gear - the program then makes the sound and starts pounding the Neutral key.

    This is how it works:
    rFactor -> shared memory -> Gearshift reads gear and clutch state -> start graunch sound, start repeated Neutral key presses
    then repeat
    rFactor gets Neutral key press, puts gearbox in neutral, shifter is still in gear, rFactor selects gear, rFactor gets Neutral key press...

    If you get the graunch but it stays "in gear" then either the key being sent is not what rFactor is using (the new version V3.1.59 pops up a message box warning about that) or rFactor is not getting the key.
     
  6. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    657
    Likes Received:
    713
    Yes, try using another key like rFactor's default N
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    If the car is in-gear, and the user manually taps Neutral, the car will flick to Neutral and back into gear, the graunching will start, but if the wrong key is assigned Neutral won't be automatically pressed.

    Might take an rF2 restart to catch up with .json changes?
     
    Seven Smiles likes this.
  8. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    40
    Likes Received:
    20
    I have the same issue,pressing Num_0 on the keyboard neutral is shortly activated, grinding noise appears , can only stop it by pressing clutch and change gear.
    Gear mismatch is newly not detected I can only hear the grinding.
    if I start the new version get the massage controller.json does not match gearshift.ini neutral button entry,which controller.json have different one ?
     
  9. elbo

    elbo Registered

    Joined:
    Feb 19, 2012
    Messages:
    520
    Likes Received:
    134
    Tried other keys, same result, graunching sound but no neutral is being sent;
    [clutch]
    controller = Logitech G27 Racing Wheel USB
    axis = 4
    reversed = 0
    bite point = 90
    [shifter]
    controller = Logitech G27 Racing Wheel USB
    1st gear = 8
    2nd gear = 9
    3rd gear = 10
    4th gear = 11
    5th gear = 12
    6th gear = 13
    7th gear = 0
    8th gear = 0
    reverse = 14
    [miscellaneous]
    shared memory = 1
    damage = 1
    shifter = 1
    double declutch = 0
    preselector = 0
    reshift = 0
    neutral button = DIK_NUMPAD0
    ignition button = DIK_APOSTROPHE
    wav file = Grind_default.wav
    debug = 0
    mock input = 0
    test mode = 0
    controller_file = D:\Steam\steamapps\common\rFactor 2\UserData\player\controller.json
    upload_2019-11-17_15-48-52.png

    The old version available here works as it should...
    That old version is still there https://github.com/TonyWhitley/gearshift/releases/tag/V1.5.27
     
    Last edited: Nov 17, 2019
  10. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    657
    Likes Received:
    713
    If you get that message it won't work.

    The default in gearshift.ini is
    Code:
    controller_file = %ProgramFiles(x86)%/Steam/steamapps/common/rFactor 2/Userdata/player/controller.json
     
  11. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    40
    Likes Received:
    20
    yes, I get the message and wont work.
    I found out my keyboard creates in the ...json for
    empty the number 0,89 ,
    Numpad_0 0,11 same as KP0,
    it seems that 0,11 is wrong for gearshift.
    http://www.penticoff.com/nb/kbds/ibm104kb.htm
     
  12. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    40
    Likes Received:
    20
    after restart I have this effect


    neutral has Numpad_0 [0,11]
    camera tilt left KP0 [0,82]
     
  13. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    40
    Likes Received:
    20
    If I set in the Controller.JSON the neutral manually to [0,82] the Error message from gearshift disappear, so I think [0,82] is the right value.This I have done in my controller myname.JSON that is under the folder ....steam\steamapps\common\rfactor2\userdata\controller.
    the tilt left could be an alternative way for signaling wrong shifting.
     
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    @jual 0,11 is the 0 key, next to the 9 key.

    KP 0 is the same as Numpad 0, which is 0,82. It's a completely different key to Num_0.


    This program is pressing 0,82 , so it's working when you set Neutral to 0,82. But if your Cam Tilt Left is set to 0,82 it will press that too (it's just pressing KP 0 - the game sees that and activates all controls assigned to it).

    The program is doing what it's meant to do, you need to use the right keys.
     
    Seven Smiles likes this.
  15. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    40
    Likes Received:
    20
    that's correct, the confusion occurs when you use a keyboard which has no obviously Numpad field.
    A possible workaround ist to configure it [0, 82] in the mycontroller.json
     
  16. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,667
    Likes Received:
    2,537
    Indeed.

    The easier option would be to set Neutral in the game, and tell Realistic Gearshift to press that same key (instead of Numpad 0).
     
  17. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    40
    Likes Received:
    20
    I have realized that gearshift.exe must be started on win10 as ....run as administrator.. (right mouse click) even the user is administrator, otherwise it will not function stable.
    An second point gearshift.exe effected other programs, example if gearshift.exe is running before simfeedback ist startet simfeedback software do not initialize the hardware.
     
  18. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    657
    Likes Received:
    713
    I don't have to "run as administrator" (I am using an account that has administrator privileges).
    No idea why it should affect other programs unless it's something to do with both using the Shared Memory plugin. The only thing I run that uses that is Crew Chief and that works OK with both gearshift.exe and headlights.exe.
     
  19. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    40
    Likes Received:
    20
    Maybe it differs between Operation System (Win10...) configuration and versions. I suppose it has something to do with UAC (user account control) that the program had to tell the OS what integrity level is required.
    Even the administrator had to confirm a popping message field, that happens always if the administrator uses the method run as administrator.
    If anybody had problems with the program this method could solve this.
    In my case in the last time I used it, it works and sometimes not.
     

Share This Page