Random rF2 Freezes destroying the fun

Discussion in 'Technical & Support' started by Satangoss, Feb 15, 2015.

  1. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,786
    Likes Received:
    1,571
    I don't know if it can help one of you, some time ago, when a member of our community had similar problems and he could solve it (if i remember right) with a suggested solution from THIS website.
    Use it at your own risk. ;)

    EDIT Click on the "9 Steps" button right besides the pdf Download button to get the 9 Steps buttons.
     
  2. Tony H

    Tony H Banned

    Joined:
    Oct 5, 2010
    Messages:
    82
    Likes Received:
    1
    Last edited by a moderator: Jun 22, 2015
  3. Tony H

    Tony H Banned

    Joined:
    Oct 5, 2010
    Messages:
    82
    Likes Received:
    1
  4. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
    Thanks I'm looking into it.
     
  5. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
  6. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
    Tony, I managed to keep my CPU below 60º. In addition, the Windows message is quite clear "video hardware error", so it's not the CPU. Thanks anyway, I'll do some tests tonight.
     
  7. Panigale

    Panigale Banned

    Joined:
    May 30, 2012
    Messages:
    427
    Likes Received:
    4
    LOL is there a reading issue on this thread? Did you even read what I posted to you now twice? You are discovering the exact thing I told you is likely the issue...I also told you how to fix it...
     
  8. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
    I got mistaken with your post... I read it months before and then suddenly the issues have gone. But now is back, and I re-read your first post and you're right, you were referring to 90% usage and not 90º C.

    My mistake, sorry! I lost it because there's a while ago from that.

    In any cases, the software runs normally until it gets exactly 100% of usage, then I have a crash instantly.

    [​IMG]
     
  9. Panigale

    Panigale Banned

    Joined:
    May 30, 2012
    Messages:
    427
    Likes Received:
    4
    100% looks like a red herring. One indicator is the immediate temp drop when it hits 100%. Unless it is out of sync it should not already show a temp change. i.e. It isn't maxed at that point anymore but just basically dead or unresponsive so the GPU shows as 100%. It stays that way while the temp continues to drop so again, it isn't actually pegged at 100% there.

    Back up a few lines and what do you see?

    I see a usage peak of 96, which is very similar to my peak of 98 in my testing. Now what I see after that is a drop to 90 then 91 from 96, yet the temp is still the same. That tells me your card is beginning to exit stage right. It throttles a bit and then it dies.

    I can recreate this behavior in minutes with aggressive overclocks. Play for an hour pegged and it basically does the same thing. Moving to driver 350.xx helps but if you insist on running your GPU at over 90% for any significant duration it will crash. Every single one of my Nvidia cards has done this.

    Read this part carefully: You can underclock your card and probably avoid this but since many cards are OC'd from the factory, they leave little to no room for extended usage at over 90%. A stock ref card would probably be fine at over 90%. My money would be that you are on a factory OC'd card. My Strix is and unlike the "special" cards sites like Guru3D get sent to them from Asus and others, there is zero room left for additional overclocking. (Silicon lottery my arse.) So the jist is you can have a nice OC'd card from a board partner but don't run it at over 90% for long. Don't know what else to tell ya. That has been my consistent experience. Hence why my nephew is getting my 970 and I'm upgrading. I don't need a 980 ti to run rF2 maxed at 1080p but I do need a 980 ti if I want it to stay below 75% usage while running rF2 maxed.

    Turn down your settings, stay below the 90% usage mark and you won't have random freezes. Cheers.
     
  10. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
    Panigale, your analysis sounds perfect to me. If the crash was because the 100% usage the temperature should take a while before drop down, so it really seems the crash was few seconds before and the 100% usage would represent the OS trying a communication ang get a "no response" from GPU.

    Your money is yours, it's a GTX 980 SC (superclocked) so it runs higher than the base Nvidia clock.

    Firstly I'm trying to underclock it to 1300 Mhz instead of 1380 and see what happens. I'm avoiding to low rF2 settings down because it doesn't look very taste so.

    I'll post my results here, thank you very much for your help, really apreciated.

    (Thanks for the "red herring" stuff, I didn't know this idiomatic expression lol)

    Edit: Another solution would be use SLI: I got less than 60% of usage for each GPU when I enable it, but no fun: it stutters and makes the driving impossible.
     
  11. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
    Well, report of the day: no luck.

    I underclocked my GPU to 1280 Mhz (instead of factory's 1380 Mhz), lost a lot of FPS and still get freezes all the time (the GPU usage starts lower when I decreased the clock: around 70%, but as the race laps go, it go increasing until reach 96 or so and crashes as it did using default clock).

    The bad news is Assetto Corsa ran without problems for 2 hours under 98% of GPU usage (and it doesn't float: it keeps 98% all the time) and no crashes at all.

    I'll keep testing tomorrow but very sure is something with rFactor 2 graphics engine.
     
  12. Panigale

    Panigale Banned

    Joined:
    May 30, 2012
    Messages:
    427
    Likes Received:
    4
    Hey Satangoss, something isn't adding up.

    A 980 Classified, has a base clock of 1291 and a boost clock of 1393. You should be underclocking your core/base clock. I don't think your card has a 1380 base clock because that would even make the KingPin look bad. At least I'm not aware of a card with a factory base clock that high.

    So first thing, use something like Afterburner, it will show you your base and boost clocks and the core clock slider is what you want to move. If you are somehow reducing your boost clock, that is likely not going to stop the GPU from crashing under load.

    That said, yes, this is mostly rF2 specific. AC does run a lot more stable with the GPU maxed. I never had a GPU freeze with AC.
    So my two cents, reduce the core clock by 100, if it is say 1240, make it 1140. If that doesn't work then try reducing AI or shadows or something just to see if staying under 90% resolves it. Cheers.

    ...One extra thing, usage should peak coming across the pit straight then dip back again. If it is steadily increasing that is odd behavior. I use max frames in the plr, so ideally the pit straight/race start are the peak usage points and the card gets a break during most of the lap. If you don't use max frames (could also use vsync but that adds horrible lag so I don't recommend using it) then the GPU will be asked to work as hard as it can the whole time, which isn't good. In that example reducing shadows won't matter because the GPU will just render more frames.
     
    Last edited by a moderator: Jun 23, 2015
  13. peterchen

    peterchen Registered

    Joined:
    Oct 25, 2011
    Messages:
    2,099
    Likes Received:
    287
    Sorry to kick in....not all read.
    What build?
    Player.JSON "Sim Processor Thresh":255, ? (under GameOptions)?
     
  14. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
    Hello,

    Build 946
    New PLR, so Sim Processor Thresh = Default of vanilla installation.

    I should add the scenario of my last batch of tests> URDs cars, Sebring, 4 PXs, 31 GTs, starting to back of the grid (36th) at 18h00 and going through the night. It's demanding, but I think stressing the hardware is the way to test the stability of something. I have seen dozens and dozens of people reporting their "excellent" rF2 performance and stability or doing benchmarks racing alone in the track at 12h00 AM (few shadows) or using few AIs. There's no point on doing it, rF2 is a complete simulator and is intended to be comprehensively explored in its all features. I should add rain, by the way. rF2 should work in heavy situations, it's not a lap simulator as other sims.

    Back to my drama, in fact Panigale, 1393 is the "turbo" clock that my EVGA was pushing at. Tried to fix it to 1291 MHZ tops using Precision X, it has crashed too, this time after 1h11min which was a improvement, but still no good.

    Finally I found a band-aid which is to use SLI to distribute the GPU processing. It's not a ideal solution because rF2 always performed better with single GPU than multi-GPU for 2D emulation (people are reporting significant SLI performance using 3D or Multiview, not my case). In addition, it won't help many many people with Nvidia issues since I guess few of them use SLI setups.

    In any cases, the 350.03 Nvidia drivers reduce significantly the rF2 SLI stuttering and "jumpy" behavior, it's much more fluid now, which is good. Single GPU is still more fluid, but SLI is acceptable now. There's still no FPS gain at all by using SLI (which is weird) but at least is playable. I'm listing below what I had to set in order to achieve to finish an 8 hours race at the scenario described above.

    Nvidia Inspector Profile

    SLI Compatibility Bits = 0x02402003
    Vertical Sync Smooth AFR Behavior = OFF
    Vertical Sync Tear Control = OFF
    Vertical Sync = Force off
    Antialiasing Mode = Override any application setting
    Antialiasing Setting = 4x [4x Multisampling]
    Antialiasing Transparency Multisampling = Enabled
    Antialiasing Transparency Supersampling = Off / Multisampling
    Toogle FXAA on/off = Off
    Anisotropic Filter Setting = Off [Point]
    Texture Filtering (Negative LOD Bias) = Clamp
    Texture Filtering - Quality = Quality
    Power Management Mode = Prefer maximum performance
    Antialiasing - SLI AA = AA_MODE_SELECTOR_SLIAA_ENABLED
    SLI Rendering Mode = SLI_RENDERING_MODE_FORCE_AFR_OF_SFR__FALLBACK_3AFR

    All the others are untouched (default Nvidia settings)

    In-Game Options

    All maxed except:
    Opponents Detail: High (not Full)
    Shadow Blur: Optimal
    Visible Vehicles: 20

    Test Results

    8 hours racing (AI controlling the player car) = Passed
    Local Test Temperature: 17 - 21ºC
    Maximum CPU Cores Temp: 52/55/58/54

    [​IMG]

    *Note: GPUs usage reach 98% and no crash as the single GPU did in all previous tests.

    rF2 Config

    Resolution: 1920 x 1080 p
    Vsync: OFF
    AntiAlias = OFF
     
    Last edited by a moderator: Jun 24, 2015

Share This Page