Rain Update Solved

Discussion in 'Technical & Support' started by vegaguy5555, Jan 3, 2018.

  1. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    624
    Likes Received:
    263
    I hear some people talking about the rain update but rain still comes through the windshield for me.

    Is it out? If so, how do I get it to work?

    Thanks!

    I tried, verifying integrity, the new GT3"s on Silverstone and maxing out all settings, which run quite smooth now!:)
     
  2. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    444
    Likes Received:
    165
    Confirm If you're on dx11 and using an official car that have been updated.
     
  3. Mibrandt

    Mibrandt Registered

    Joined:
    Apr 4, 2013
    Messages:
    533
    Likes Received:
    141
    I have this problem with rain inside the cockpit but only with some cars. Eg. Nissan 370z gt4. The GT3's are ok. I have deleted Cbash and shaders folders.
     
  4. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,195
    Likes Received:
    1,247
    Shaders aren't the issue. The no rain mesh will be.
     
  5. Mibrandt

    Mibrandt Registered

    Joined:
    Apr 4, 2013
    Messages:
    533
    Likes Received:
    141
    Interesting. Can I fix that?
     
    vegaguy5555 likes this.
  6. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,195
    Likes Received:
    1,247
    You could but would get errors online.
     
  7. Mibrandt

    Mibrandt Registered

    Joined:
    Apr 4, 2013
    Messages:
    533
    Likes Received:
    141
  8. GrimDad

    GrimDad Registered

    Joined:
    Oct 9, 2010
    Messages:
    310
    Likes Received:
    156
    Opt out of betas by selecting none right click rF2 in steam list / properties / betas

    Unsubscribe from affected cars run game to remove them then close game and resubscribe.
    Old cars dont get removed if you have vmods/rfmods that use them
     
    vegaguy5555 likes this.
  9. Mibrandt

    Mibrandt Registered

    Joined:
    Apr 4, 2013
    Messages:
    533
    Likes Received:
    141
    I am out of Beta and I have the rain effects plus wipers working, so I guess the cars are up to date?
     
    GrimDad and vegaguy5555 like this.
  10. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    624
    Likes Received:
    263
    My wipers work but I thought the GT3's would work.

    I will check and make sure I'm in DX11.
     
    Last edited: Jan 4, 2018
    GrimDad likes this.
  11. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    461
    Likes Received:
    283
    Also check what version of the 370Z you have too.....should be v1.93. Easiest way to check is look in ....\Steam\steamapps\common\rFactor 2\Installed\Vehicles\Nissan_370z_2012\ and the should be a folder named 1.93 under that.
     
    vegaguy5555 and GrimDad like this.
  12. GrimDad

    GrimDad Registered

    Joined:
    Oct 9, 2010
    Messages:
    310
    Likes Received:
    156
    vegaguy5555 likes this.
  13. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    624
    Likes Received:
    263
    Won't Opting out of betas revert me back to DX9?

    Edit: That fixed it. Thanks! But I thought default was still DX9?
     
    Last edited: Jan 5, 2018
    GrimDad likes this.
  14. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    2,853
    Likes Received:
    947
    Nope, DX11 became default now. You should only ever use betas if you want something other than default.
     
    vegaguy5555 and GrimDad like this.
  15. Flaux

    Flaux Registered

    Joined:
    Oct 5, 2010
    Messages:
    778
    Likes Received:
    241
    Can you add the "solved" to your opening thread post Vega? Would be appreciated.
     
    vegaguy5555, GrimDad and bwana like this.
  16. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    624
    Likes Received:
    263
    Do we have to delete shaders for the new rain update? And where is the file? I forgot!
     
  17. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,220
    Likes Received:
    824
    vegaguy5555 likes this.
  18. Jego

    Jego Registered

    Joined:
    Feb 18, 2016
    Messages:
    117
    Likes Received:
    43
    I just tried the GTE cars with rain for the first time, I was amazed at the performance I get in VR with my gtx980 and a maxed out grid. It's running with 45fps with ASW and once the field spreads I can go to 90fps even if I choose too....

    However I still get all the spray into my car (and also dust). I am running the latest update of the GTE car and I was in the BMW.
    I thought this was fixed? :(
     
  19. Jego

    Jego Registered

    Joined:
    Feb 18, 2016
    Messages:
    117
    Likes Received:
    43
    So I am bumping this. Especially since I now know that other people using VR are not getting spray inside the cockpits.

    I have deleted shaders, cbash, resubbed the cars, checked integrity. Only tested this with the GTE cars for now.

    I have most settings on low or medium, but I don't believe this has anything to do with this problem.
     

Share This Page