[REL] RaceRfactor Montreal 2013 DX11

Discussion in 'Locations' started by McNolo, Jun 2, 2017.

  1. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    The track does not have night lights, but the car should have lights.

    Let me run some tests and I tell you more.
     
    F1Aussie likes this.
  2. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,424
    There is a line in the gdb where you say if lights are required at night. If this feature is on you will get DQ if you don't turn lights on. I think it can be overriden later in the rfm.
     
    F1Aussie and McNolo like this.
  3. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    Yes, it's true. I have made some test and this is the cause.

    I'm going to upload a new version (2.03) to solve the problem.

    Thanks.
     
    F1Aussie, SPASKIS, Slamfunk3 and 3 others like this.
  4. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    Version 2.03 uploaded and ready with night lights problem solved.
     
    Max Dralle, Gupster, Louis and 7 others like this.
  5. F1Aussie

    F1Aussie Registered

    Joined:
    Apr 1, 2011
    Messages:
    630
    Likes Received:
    270
    excellent, thanks for the quick response
     
    McNolo likes this.
  6. fernando.chicozamora

    fernando.chicozamora Registered

    Joined:
    Apr 8, 2015
    Messages:
    9
    Likes Received:
    1
    Gracias!
    Excelent track!!
     
    McNolo likes this.
  7. zuber

    zuber Registered

    Joined:
    Jun 16, 2016
    Messages:
    12
    Likes Received:
    0
    No steam version ?
     
  8. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    No, have you any problem with the steam version?
     
  9. Gupster

    Gupster Registered

    Joined:
    May 19, 2013
    Messages:
    404
    Likes Received:
    25
    McNolo likes this.
  10. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,732
    Likes Received:
    2,097
    @McNolo Thanks for the update to DX11 the track looks great, there are a couple of AI issues though:
    1. On a Rolling Start the AI brake heavily when crossing the S/F line, the waypoints may need to be "smoothed" or tweaked.
    2. Even though a BLOCK path exists it is not working correctly (tried with two different mods, one official), this may have an adverse effect on #1 perhaps but either way the AI do not utilise it.
    3. The AI (in both mods I tried) are far too slow on the final Hairpin, I'm able to gain 1second on them (100% strength) from Braking to Turning to Exit, so the FAST path will need to be tweaked accordingly if possible.
    Many Thanks, keep up the great work :)
     
    McNolo likes this.
  11. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    Thanks for the feedback.

    I'll test it and try to improve it as soon as possible.
     
    Mulero and MarcG like this.
  12. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    Marc, Can you tell me a mod with which you have these problems (official better)?. It's for reproduce it and see what's going on.
     
  13. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,732
    Likes Received:
    2,097
    GT-R Nissan (official)
    Enduracers Mod v1.50 (unofficial)
     
    McNolo likes this.
  14. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    Ok MarcG, I've made some test with diferent mods and this:

    ...works fine for me, I don't have this problem. Have you another version of Montreal installed besides this one that might be interfering?

    The Block path, effectively, it seems that don't works. I don't know why, because all seems ok, but the IA seem that don't want to use it. I've made a new path and now works fine.

    About the slow IA in the final Hairpin, I still haven't been able to test it.
     
  15. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,732
    Likes Received:
    2,097
    Sorry it wasa a Fast Rolling start with a field of 28 cars, no other Montreal installed only this one added this morning or late last night can't quite remember!
    Glad you fixed the block path thanks for that :)
     
  16. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    Published 2.06 version.

    Okay, after some several testings I've seen that effectively the AI was braking on the start/finish line. I have had to watch the slow motion replay because with some cars (open wheels) you don't see this. It's really just a little, it's not a big braking, but it exists. It was not a problem with the smoothness of the routes, which were correct.

    Seeing that the AI was not using the block path, I assumed that there could be problems with others paths also and indeed, that was the problem, although I do not know why, they were just not working well, although theoretically were correct.

    Now everything works fine, although some cars (those that need a greater braking distance) still slow down when passing the line, but it is by the proximity of the turn, they need to brake.

    I've made two more changes. I have configured the AI to be more determined when it comes to pass, they will not wait too long to try it.

    The second change is due to a serious problem that I have also detected with AI. In the last chicane, if there are two cars rolling near and the back car go to pits, their braking point is later than the front car and literally run over him. I've modified the driveway to the pits to make the cars brake before the chicane, it's the only way to avoid this problem.

    About speed on the final Hairpin or anywhere else, that's the best I can do. I do not know if it will have improved, but I can not do it better. There are aspects of AI that we can not do anything about. If it is too slow, I recommend that you force the AI to use better setups, to raise the strength and / or to raise the drivers skills.

    Regards.
     
  17. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,732
    Likes Received:
    2,097
    Many thanks @McNolo for your response and update it's greatly appreciated, I'll check out the new version tonight :)
     
    McNolo likes this.
  18. Hazi

    Hazi Registered

    Joined:
    Jan 15, 2012
    Messages:
    827
    Likes Received:
    99
    THX for your quick response and your fixes! Great work!
     
    McNolo likes this.
  19. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    839
    At race, Drs was working in any track place with FISI 2012 since race starts (ai already starts with drs enable). Did not tested other mods yet
     
    McNolo likes this.
  20. McNolo

    McNolo Registered

    Joined:
    Oct 5, 2010
    Messages:
    476
    Likes Received:
    945
    I just did a test right now with the same mod and it works fine for me. They begin to use DRS from lap 3 and only in the permitted zones.

    Do you have installed any other track version that might be causing conflict?
     

Share This Page