R Factor will not run

Discussion in 'Technical & Support' started by lewis167678678, Apr 8, 2020.

  1. lewis167678678

    lewis167678678 Registered

    Joined:
    Apr 8, 2020
    Messages:
    1
    Likes Received:
    0
    When I click on the game it opens up but when I try go into a game it brings up the R Factor logo then brings me back to the menu
     
  2. dbell76

    dbell76 Registered

    Joined:
    Dec 5, 2014
    Messages:
    25
    Likes Received:
    8
    having the same problem....

    by clicking on the singleplayer icon on the launcher it loads the screen then kicks me back to desktop laucher
    i made a total new install of rf2

    made a fresh install of rf2 now
    i could launch the sim
    went in a car on track
    made 2,3 laps
    choosed a other car
    same track....then whilst loading the track kicks me back to launcher
    launched again,same combo
    again while loading track kicked me back to launcher

    this error message came up one time
    (json) failed to perform operation, unsupported type
     
  3. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    2,013
    Likes Received:
    1,362
    Go to your player folder located here:
    \Steam\steamapps\common\rFactor 2\UserData\player
    Find the: player.JSON and delete it.

    Start rF2 and the game will generate a new player.JSON when loading.

    When the Launcher is on screen select Settings, (the cog icon on the left)
    Select Video Settings and set the GPU to your graphics card, don't leave it set to Auto.
    Cross fingers, start game.
     
  4. liam tollard-williams

    liam tollard-williams Registered

    Joined:
    Apr 11, 2020
    Messages:
    6
    Likes Received:
    1
    hey guys also having the exact same issue downloaded and ran it fine last week then ever since then I haven't been able to use it at all. unfortunately deleting the .JSON file doesn't seem to work either does anyone know of any other fix for this ?
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,768
    Likes Received:
    5,540
    You can try deleting the other .json files in that folder, or to cast an even wider net you can delete/rename the entire UserData folder, then verify files in steam, and then try again.
     
    liam tollard-williams likes this.
  6. liam tollard-williams

    liam tollard-williams Registered

    Joined:
    Apr 11, 2020
    Messages:
    6
    Likes Received:
    1
    thanks ill try that option and see how we go
     
  7. jual

    jual Registered

    Joined:
    Oct 15, 2018
    Messages:
    61
    Likes Received:
    43
    Have similar effect when an configured Th8a shifter is absent.
     
  8. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    2,013
    Likes Received:
    1,362
    In your control profile json see if these two entries help.

    "Detect Rearranged Controllers":true,
    "Detect Rearranged Controllers#":"set to 1 if you change controller connections often and your wheel or pedals are sometimes enumerated differently",

    "Realtime Controller Detection":true,
    "Realtime Controller Detection#":"whether to check for new controllers while in realtime (0 to disable if it causes any problems)",
     

Share This Page