Question for Modder, Photoshop users.

Discussion in 'Off-Topic' started by D.Painter, Jan 29, 2019.

  1. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    870
    Likes Received:
    1,466
    Hi all.
    I've recently re-installed Photoshop CS6 to my PC and now having a issue with the copy/pasd not working. The commands in the tools drop down are grayed out (not available). Also the Ctrl+C to copy and Ctrl+V to pasd are not working for Photoshop. This method works for every other application. Is there anyone else having this issue? I am thinking it's a Windows update that has broken it but can't be sure. Google search has found nothing on the subject to help. Was working prier to a reform of PC. Tried fresh install a number off time with the same result.

    Running;
    Windows 10 Home. 64bit
    i7-7700 intel
    16 GB Ram
    nVidia 1070
     
  2. woochoo

    woochoo Registered

    Joined:
    Nov 3, 2010
    Messages:
    1,096
    Likes Received:
    1,853
    i've had issues with ctrl+C conflicting with rF2/PS5.5
    Example:
    If i'm working on textures, I've got PS open, and i go to test the texture in rF2.
    Then i alt-tab back to windows and when i press ctrl+C (not sure about right-click copy) to copy a part of an image into PS, or even i think just copying a file in explorer, PS will lockup entirely. I have to close rF2, and then PS unlocks.
    That might not be your issue, but there's something weird, and i think it started around the early days of DX11
     
  3. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    870
    Likes Received:
    1,466
    Been mucking around with it more and now the pasd is working. Can copy a layer in Paintshop Pro so it's on the clipboard, then pasd it to a image in Photoshop but still can't copy from Photoshop. Want generate a image to the clipboard or replace the one existing. Strange how this has happened.
     
  4. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,705
    Likes Received:
    530
    I have the same issue since long time, like rFactor2 locks the access to files when running (copy/paste).
     
  5. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    870
    Likes Received:
    1,466
    Not sure I can blame rF2 for this. It's the same when rF2 isn't running. I can copy / pasd from all other apps. It's only Photoshop that is having any problems.
     
  6. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,705
    Likes Received:
    530
    So it's not the same issue you are so. Sorry, I have not the version you use.
     
  7. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    396
    Likes Received:
    207
    I wonder if you're trying to copy the background layer? This layer is partially locked in PS.
     
  8. FuNK!

    FuNK! Registered

    Joined:
    May 26, 2013
    Messages:
    392
    Likes Received:
    206
    This is just something that came to my mind; Maybe the clipboard is working, but PS cannot access it because of whatever reason. So maybe you can try a clipboard software like ClipboardMaster?

    Other than that, maybe not the quickest and easiest solution, you could try to use VirtualBox and set up a virtual Windows (or Linux with WINE) and install PS there. If you don't want to use that for productivity work (and I'm certain you won't because it requires a lot of your PC's resources) you can still test if the Clipboard works within a bare Windows environment.
     
  9. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    396
    Likes Received:
    207
    Wondering how you got on with this? Did you get a result or can you still not copy?
     
  10. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    870
    Likes Received:
    1,466
    Still not working right. I can pasd a image, even a Channel (Alpha) if I copy it from another program. Photoshop want Copy to clipboard.
    The copy in the tools drop down is grey, not black as it would if it was active. The short cup Ctrl + C to copy dosen't work from Photoshop. Works everywhere else.
     
  11. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    396
    Likes Received:
    207
    @D.Painter could you post a screen shot of this portion of your screen showing the layers toolbar PSclip.JPG
     
  12. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    628
    Likes Received:
    299
    If you start your pc and open only photoshop, is it still the same problem?
     
  13. Liquid4653

    Liquid4653 Registered

    Joined:
    Sep 30, 2013
    Messages:
    188
    Likes Received:
    40
    Hey Doug;),

    The thing with PS, if you have nothing selected in the image window, the copy/paste options will be grey, if you don't have the layer highlighted in the layers area, first make sure your on the layer that you want to copy, use the marquee tool to select a test area or Ctrl+A to select all, then you can copy no problem, if there are multiple layers you can use copy merged to take all visible combined layers. With just the layer selected, it should have the 'copy' option available without using the marquee tool, unless like someone said here already, it's the background layer.
     
    Last edited: Feb 4, 2019
  14. Liquid4653

    Liquid4653 Registered

    Joined:
    Sep 30, 2013
    Messages:
    188
    Likes Received:
    40
    That sounds like a memory running out issue to me, I have seen this on my machine when i have multiple programs open - typically 3dsmax, PS, and rF2, all running and switching back and forth.
     
  15. woochoo

    woochoo Registered

    Joined:
    Nov 3, 2010
    Messages:
    1,096
    Likes Received:
    1,853
    I've got 32GB. The RAM meter seems ok. It feels like a focus issue.
    If it's a RAM issue or not, I have a deep sense that it was something changing in rF2 that started the issue. It was fine before whatever change I'm choosing to associate with the issue. Don't know if related to implementing DX11, or if there were changes to the rF2 system performance monitor that use the ctrl-c combo.
     
  16. Liquid4653

    Liquid4653 Registered

    Joined:
    Sep 30, 2013
    Messages:
    188
    Likes Received:
    40
    ah ok, is not ram problem with 32GB lol, maybe try running windowed mode and see if any different, or if you are, run full screen mode to see if that helps.
     
  17. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    870
    Likes Received:
    1,466
    For me it's only Photoshop clipboard that want copy from. All other applications work fine. If it was rF2 related you'd think it would affect all application.

    Tried Photoshop on it's own with nothing else apart from start up programs and it still has the same problem.

    I can copy a image, layer or channel from Paintshop Pro to the clipboard and it will Crtl + V (Pasd) into Photoshop. It's a strange one, that's for sure. It's only started doing this after a PC re-boot and had to re-install all my applications.
     
  18. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    628
    Likes Received:
    299
    Just an idea, did you try it with running photoshop as administrator, rightclick on the shortcut and select 'run as administrator' then?
     
  19. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    870
    Likes Received:
    1,466
    Tried the Clrt + A then Clrt + C and it did copy the single layer. Normally I'd use Clrt + A then Clrt + C to add the Alpha channel because if you didn't use Clrt + A first it would only copy one part, even after the multi layers made for the channel was merged but that was normal.

    Anyway, it work for one layer if I use Clrt + A then Clrt + C, better than nothing.
     
  20. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    870
    Likes Received:
    1,466
    Some program like 3D Max needs to be run as Admin when your changing or setting up your preferences. It's the only way to make them stay as start up default.
    Photoshop isn't the same but if it was the Clrt + C preference is set by default by install. I have checked that and it's stayed as preset.
     

Share This Page