Released Q2 Update and DLC Released

Discussion in 'News & Notifications' started by Paul Jeffrey, May 9, 2022.

  1. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    268
    Likes Received:
    306
    Well, you don't need them to tell you that. It's enough to open any car to know that. And this term is actually not used for such a soft guarantee.
    In X-Plane for instance, which guarantees backwards compatibility when your plane used to work and doesn't work on a new version it's treated as a bug. If something used to work and uses documented API/features has to continue working in a new version unless otherwise mentioned.

    That's what worries me.

    And where do you see them saying that? Because I can see them saying something exactly opposite in the changelog. The fact that it's not true is the reason I have an issue with that.

    If they did say that this is how it is. New sound engine, you need to update the cars at least they would be honest.
    The didn't say that.
     
    Dady Cairo likes this.
  2. dazzer

    dazzer Registered

    Joined:
    Feb 3, 2018
    Messages:
    513
    Likes Received:
    1,641
    I say this as a person who makes modifications for fun, we assume to create content on a platform that is in continuous development, I have updated more than 10 times materials and adjusted textures due to IBL changes, but I'm not complaining accept this fact, myself I moved from Assetto corsa to Rfactor 2 due to ongoing development, if you want to make or view content that will not change RF2 is not the platform for you at the moment unfortunately.

    I understand your frustration at seeing the sounds fail like this. But I also don't think that backward compatibility should weigh down development so that old content remains compatible, this same section weighed down the simulator for a long time, people who preferred to have the old content working instead of updating its modifications.

    at least this is my opinion, I'd rather see drastic changes with proper documentation (which I know is not available at the moment) than waste time keeping old content "compatible"

    I also understand that we all have different points of view :D, I hope that soon the proper documentation can come out so that we can update our content to the new sound engine.
     
    Havner likes this.
  3. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    268
    Likes Received:
    306
    Neither do I, but they could be at least honest about that. Instead they say/suggest something completely opposite. And at this point I don't even know as a consumer. Are they lying or is the engine simply still buggy?
     
    Dady Cairo likes this.
  4. dazzer

    dazzer Registered

    Joined:
    Feb 3, 2018
    Messages:
    513
    Likes Received:
    1,641
    More than a bug, this must be caused as the sound effects were played in a very old fashioned way, obviously this clashes with the new engine.
    For now I have only been able to solve it by lowering almost all the sound effects. But obviously this will vary depending on the mod and or dlc since as I said before not everyone uses the sound samples in the same frequencies or same channels, I have come across mods that use mixed files between stereo and mono, all this disorder can cause the problem What are you seeing, at least that is my theory according to what I have seen and tested in devmode
     
  5. Neil Tyler

    Neil Tyler Registered

    Joined:
    Nov 15, 2020
    Messages:
    31
    Likes Received:
    5
    Hi,
    I don't know if this is the right thread for reporting issues with the Q2 update, so apologies in advance:
    1.
    Since the update on Monday, when I host an online race, all the cars of the AI and the other players disapear as soon as I try to enter the server. The server still list them as being in the game, but no cars are visible on track for me or any of the other racers.

    2.
    There is a high-pitched squealing noise (think dial-up modem, or Comadore 64 game loading from a tape deck if you are old enough) when the cars (AI and player) are loading from a dedicated server.

    Anyone else having these issues?
     
  6. Luprosx

    Luprosx Registered

    Joined:
    Apr 6, 2013
    Messages:
    173
    Likes Received:
    111
    Yes, great Q2 update.
    Tracks and cars pack fully ok.
    The only thing that sucks is the sound problem with different mod cars.
    Some have the good onboard sound, others the very quiet dull.
    The mod groups have to improve that, otherwise it won't work.
    It's just a shame because whenever they improve something, some other things don't work the way they used to.
    Well, let's just wait for improvement!
     
    avenger82 likes this.
  7. GTClub_wajdi

    GTClub_wajdi Registered

    Joined:
    Feb 28, 2012
    Messages:
    3,169
    Likes Received:
    526
    Any response from Studio397 about AI sound being so low?
     
    Dady Cairo likes this.
  8. MiguelVallejo

    MiguelVallejo Registered

    Joined:
    Nov 28, 2016
    Messages:
    368
    Likes Received:
    1,659
    Can we no longer move the camera freely with mouse?
    It's amazing how every time something is added to the game a previous thing is damaged
     
    Dady Cairo likes this.
  9. Foxtrot

    Foxtrot Registered

    Joined:
    Nov 2, 2011
    Messages:
    207
    Likes Received:
    29
    I think I've only seen 3 people even mention it, everyone else seems to be praising the new sound.
    Maybe we have a bug. It's so weird, in the RC I could tell what side cars were approaching on by the sound alone, was pretty hyped.

    Regards.
     
    Dady Cairo likes this.
  10. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,902
    Likes Received:
    3,434
    Old sound engine, Max 64 channels, new sound engine , max 256 channels. (SOME of those will be generic sounds for every car like rocks and stones making noise if you run off track, some will be mostly generic incar sounds like gears and shifter noises. But most cars currently have stereo sounds as a default while the new system takes mono sounds and positions them. Talk to @Frederick Alonso. He seems to be well versed in sound editing and he might add some clarity. The end result, you cannot take a 10 year old sound engine and expect it to play nice with a much more modern module. You CAN try and balance some things, but others will need manual adjusting.
    Oh, and btw, as far as backward compatibility goes....DX9 anyone? 32bit?
     
    Last edited: May 11, 2022
  11. Maiki0767

    Maiki0767 Registered

    Joined:
    May 29, 2020
    Messages:
    6
    Likes Received:
    0
    I have the same problem with IR18 and Formula Pro
     
  12. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,966
    Likes Received:
    1,541
    Do you have a mod with a skin pack made prior to the update? Or is it in the previous version? If so, the changes will not work
     
    Maiki0767 likes this.
  13. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,902
    Likes Received:
    3,434
    Your cars haven't updated. Unsubscribe to both, then exit and restart rF2. The new versions will download, you get the shifting, sounds, sparks, grey rainspray etc etc. Correct version # for rFPro is v1.19 & the IR 18 is v1.43.
     
    Maiki0767 likes this.
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,618
    Likes Received:
    5,422
    If you have the new camera controls assigned the mouse won't do anything in freelook. It's either mouse OR controller/keys.

    Presumably this avoids accidental mouse movements.
     
    MiguelVallejo likes this.
  15. Lars

    Lars Registered

    Joined:
    Apr 29, 2017
    Messages:
    59
    Likes Received:
    28
    Hi Neil,

    today i have had the same issue with disappearing AI etc. and was almost getting mad., then i realized the network settings in my game (client) have been set down to 126kbps dl and upload (who needs such connection speeds??) due to the update! so i have raised this to about 6 and 3 MBit and everything was fine!..

    cheers
    Lars
     
    Last edited: May 10, 2022
  16. Lars

    Lars Registered

    Joined:
    Apr 29, 2017
    Messages:
    59
    Likes Received:
    28
    Had an issue (?) today with indycar and push to pass at LongBeach. It was only working at the beginning of the race and stopped working for me and another client after about 15 minutes even though it shows about 120 sec left .....my bro had about 80 sec left... ?! is it somehow adjusted to the race length (42 laps) ...?
     
  17. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,902
    Likes Received:
    3,434
    might be on to something, I ran a practice session at Portland, P2P said I had 150 seconds, it would run for 20 seconds each time no matter when I applied the brakes(or at least the P2P message took 20 seconds to say it's was off. But after 120 of those 150seconds, it just stopped responding. 30 seconds left, no more P2P.
     
  18. Hinyaldee

    Hinyaldee Registered

    Joined:
    Nov 24, 2021
    Messages:
    96
    Likes Received:
    26
    I tried to adjust those sliders but to no avail. It might have come from the mod. I will try another one to see
     
  19. Binny

    Binny Registered

    Joined:
    Jan 19, 2019
    Messages:
    279
    Likes Received:
    257
    Forget the comparisons. You have posted the info i needed to keep having a break from RF2 the optimization is still not any better.
     
    darkojovanoski1986 likes this.
  20. burgesjl

    burgesjl Registered

    Joined:
    Feb 2, 2013
    Messages:
    258
    Likes Received:
    461
    Both @davehenrie and @juanchioooo are onto the solution here.

    In the first case, you may still have the old version (1.25) installed, and a car of that version selected as your car to drive; if you go into your Opponents list in single player you may see two entries for a given car, e.g. the #06, with 2 different version numbers. The version 1.43 does work. One possible reason for the old version still being on your system, is that it is being referenced by another mod (skin pack, maybe) or also from you having subscribed to the Competition System Indy Open series in the past season/quarter. Davehenrie gives you the link for how to find the cars and unsubscribe from the Workshop. The exact same approach can be taken to unsubscribe from the CS series, which you find an entry called "CS Indy Open" or similar in the list of content subscribed to from the Workshop (because that's what happens when you register for a series in the CS, in the background). Just remove that subscription as well, and restart. You may have to both restart Steam and the game multiple times before it all gets straightened out and everything updated.
     
    Maiki0767 and juanchioooo like this.

Share This Page