+profile still broken

Discussion in 'Technical Archives' started by Noel Hibbard, Jul 17, 2014.

  1. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    28
    It's still not possible to host multiple servers via multiple player profiles and the +profile command line option.
     
  2. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    824
    I confirm this also.
     
  3. DocJones

    DocJones Registered

    Joined:
    Jan 26, 2011
    Messages:
    403
    Likes Received:
    4
    Here's hoping this will be fixed soon... :/
     
  4. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,799
    Likes Received:
    558
    +1, this is the only important feature for hosting with only one installation !!!!
    Please fix this, we are locked since b770 with only one server running, not good to make normal races and beta tests in same time !!!
     
  5. Ricklandia

    Ricklandia Registered

    Joined:
    Mar 12, 2012
    Messages:
    111
    Likes Received:
    0
    +1 as well.
    Quite honestly, until this is fixed I could care less about other issues. Sadly, this issue is again slowly squeezing the interest of our league away from RF2. Trying to admin a league when essential functions such as this get broken needlessly are extremely frustrating. Sorry for the vent but had to get it off my chest.
     
  6. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,864
    Likes Received:
    292
    +1, same here. Our League stucks on B660 because of this problem. I can`t believe, that this well known bug exists since B770 without fixing.
     
  7. Jeremy Miller

    Jeremy Miller Former ISI Senior Programmer

    Joined:
    Oct 5, 2010
    Messages:
    276
    Likes Received:
    3
    its fixed in builds 796 and above. However, changed to +profile= instead of +profile
     
  8. Rich Goodwin

    Rich Goodwin Registered

    Joined:
    May 3, 2012
    Messages:
    1,217
    Likes Received:
    8
    Awesome, thank you! :D
     
  9. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,864
    Likes Received:
    292
    Good News, thanks. Just to make clear for me, the player.JSON wouldn`t be overwritten from B796, if it was renamed?
     
  10. Ricklandia

    Ricklandia Registered

    Joined:
    Mar 12, 2012
    Messages:
    111
    Likes Received:
    0
    WOOT!
    Many thanks!!!
     
  11. Jeremy Miller

    Jeremy Miller Former ISI Senior Programmer

    Joined:
    Oct 5, 2010
    Messages:
    276
    Likes Received:
    3
    I don't how it worked in past. I changed to how I think it should work

    You need to copy Userdata/player/* to userdata/newplayer and rename /userdata/newplayer/player.json to /userdata/newplayer/newplayer.json then use +profile=newplayer
     
  12. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,864
    Likes Received:
    292
    Thanks Jeremy for your fast reply. That means, the player.json file should allways named "player.json". Because at the moment i`m working with different (player1, player2 etc.) file names. With Build 660 it was not overwritten, with Build 789 it is. Everytime ich change player.json to player1.json and start the server, the file is rebuild as player.json. It`s not a problem, just to know how it`s working now. Again, thanks.
     
  13. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,799
    Likes Received:
    558
    Fixed in 798 : http://isiforums.net/f/showthread.p...-build-770-798?p=294073&viewfull=1#post294073
     
  14. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    28
    You have to rename the folder and the json file to match. I just tested a path like this UserData\Server 2\Server 2.json and it isn't creating a player.json. When using +profile="Server 2", it's updating the "Server 2.json" as expected.

    Edit: nevermind, you are referring to 789... duh. It's fixed in 798 as MaD_Kind said.
     
  15. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,864
    Likes Received:
    292
    Thanks Noel, yeah, i was reffering to B789. Now I updated our Game Server to B798 and everything (except SLS) went fine.
     

Share This Page