problemi all'avvio di RF2

Discussion in 'rFactor 2 Support (Supporto Tecnico)' started by leo4855, Jun 16, 2014.

  1. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    sera a tutti ,vi chiedo aiuto,
    ho un problema all'avvio di rf2 , non parte proprio , mi da subito errore,
    A monte l ho installato e funzionava bene almeno per un po , poi si è bloccato il pc e di conseguenza lo riavviato , ma dopo ciò rf2 nn mi parte più , ho tentato anche a disinstallarlo e reinstallarlo di nuovo ma niente da fare come posso fare ? grazie
     
  2. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Cerca il file del log dell'errore ... Pannello di Controllo--->Strumenti di Amministrazione--->Visuazzatore Eventi--->Riepilogo Eventi Aministrativi--->Errore

    e copialo qui.

    A naso il blocco del PC ha corrotto qualcosa, ma senza sapere quale è l'errore è difficile capire cosa si è corrotto e se c'è un modo per risolvere.
     
  3. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    ok grazie controllo e lo posto
    ho controllato
    Nome evento problema: APPCRASH
    Nome applicazione: Launch rFactor.exe
    Versione applicazione: 0.0.0.0
    Timestamp applicazione: 533ef889
    Nome modulo con errori: MSVCR110.dll
    Versione modulo con errori: 11.0.51106.1
    Timestamp modulo con errori: 5098858e
    Codice eccezione: 40000015
    Offset eccezione: 000a327c
    Versione SO: 6.1.7601.2.1.0.256.1
    ID impostazioni locali: 1040
    Informazioni aggiuntive 1: 69ff
    Ulteriori informazioni 2: 69ff892513f5af2adb74f5393cb8d939
    Ulteriori informazioni 3: c530
    Ulteriori informazioni 4: c530475c3705b4a3bd063feac9e502ee

    Leggere l'informativa sulla privacy online:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0410

    Se l'informativa sulla privacy online non è disponibile, leggere quella offline:
    C:\Windows\system32\it-IT\erofflps.txt
     
    Last edited by a moderator: Jun 17, 2014
  4. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    sera ho controllato

    Nome evento problema: APPCRASH
    Nome applicazione: Launch rFactor.exe
    Versione applicazione: 0.0.0.0
    Timestamp applicazione: 533ef889
    Nome modulo con errori: MSVCR110.dll
    Versione modulo con errori: 11.0.51106.1
    Timestamp modulo con errori: 5098858e
    Codice eccezione: 40000015
    Offset eccezione: 000a327c
    Versione SO: 6.1.7601.2.1.0.256.1
    ID impostazioni locali: 1040
    Informazioni aggiuntive 1: 69ff
    Ulteriori informazioni 2: 69ff892513f5af2adb74f5393cb8d939
    Ulteriori informazioni 3: c530
    Ulteriori informazioni 4: c530475c3705b4a3bd063feac9e502ee

    Leggere l'informativa sulla privacy online:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0410

    Se l'informativa sulla privacy online non è disponibile, leggere quella offline:
    C:\Windows\system32\it-IT\erofflps.txt
    questo è il dettaglio dell'errore
     
  5. Rik

    Rik Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,172
    Likes Received:
    9
    Windows 8.1 ?
     
  6. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    no 7
     
  7. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    errore rfactor.exe
     
  8. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    raga come posso risolvere per favore :confused:
     
  9. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    rFactor.exe è l'errore dell'applicazione o l'errore del modulo?

    Se è l'errore del modulo meglio così, nel senso che non sembra essere un problema di DirectX o altre rogne.

    Se l'errore del modulo invece è un altro, riportalo qui.

    Dunque, se l'errore rF2.exe è nel modulo, tieni rF2 in due percorsi, cioè le cartelle Data stanno in Documenti?
    Se si, quando hai reinstallato rF2 le cartelle Data sono rimaste quelle vecchie, e magari si è solo corrotto il player o qualcosa nella cartella Installed.

    La prova più veloce da fare è quella di spostare la cartella player (che si trova in Documenti/rFactor2/UserData) in una cartella temporanea o sul desktop, poi aprire rF2.

    Se parte abbiamo individuato il problema e prima di buttare il vecchio player potresti voler copiare nel nuovo la cartella Setting (per non perdere i setup e le livree personalizzate).

    Se questo non risolve, la prova successiva è di spostare in una cartella temporanea, o sul desktop, l'intera cartella rFactor2 che si trova in Documenti, poi installare almeno una mod perché senza contenuti rF2 non parte.

    Se così rF2 parte, puoi rimettere la vecchia cartella Packages e provare a reinstallare via via tutti gli altri contenuti.

    Nel caso invece che l'intera installazione di rF2 sia in un unico percorso io proverei due cose: la prima è quella di staccare la periferica e poi provare a lanciare rF2, per vedere se è un problema della periferica, driver o che altro.

    Se non risolve, proverei a inserire la linea di comando

    +nosound // completely disable sound to diagnose problems

    che spero funzioni anche in rF2, per vedere se fosse un problema di audio.

    Per usare la linea di comando vai nella tab Advanced nel launcher, attiva, cliccandoci, la tab

    Single Player CLI

    e scrivi nel campo bianco subito sotto

    +nosound

    poi clicca su Save Parameters.

    (Ricordati poi di cancellare il comando, altrimenti in single player rF2 partirà sempre senza audio)
     
  10. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    mi sa fare queste prove sara difficile perchè con il pc sono una frana
     
  11. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    La prima cosa da capire è se il modulo che ha causato il primo errore è rFactor.exe o qualcos'altro.

    Se è rFactor.exe e se hai installato rF2 seguendo i due percorsi standard la prima prova è semplice: sposti la cartella player sul desktop e provi a lanciare rF2.

    Ci sta che questo risolva, ma non c'è certezza ... purtroppo bisogna andare per tentativi.

    Se il modulo non è rFactor.exe, sapere quale modulo ha causato l'errore può essere utile.
     
  12. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    mi dice rfactor.exe ha smesso di funzionare
     
  13. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    ma è normale che la cartella Packages èvuota?
     
  14. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Se guardi l'installer di rF2, vedi che ti fa scegliere due percorsi di installazione, uno per il "core" e l'altro per i "data".

    Core contiene le cartelle e i files che sono il nucleo del programma, Data contiene le cartelle e i files dei dati relativi a rF2 (piste e vetture installate, player e i vari ini ecc).

    Dividere l'installazione in due differenti percorsi, con quello dei Data in Documenti, è il modo di risolvere le magagne causate da UAC.

    http://it.wikipedia.org/wiki/User_Account_Control

    La cartella Packages è vuota nel percorso "core", ma è una cartella di dati, come "Installed", "UserData" e altre, e queste cartelle Data si trovano in

    Utenti/nome_del_tuo-utente/Documenti.

    In pratica nella cartella Documenti che si trova nel desktop c'è una cartella chiamata rFactor2 che contiene tutte le cartelle Data, compresa la cartella Packages, e quella cartella dovrebbe contenere tutti files rfcmp e rfmod.
     
  15. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    Nome evento problema: APPCRASH
    Nome applicazione: Launch rFactor.exe
    Versione applicazione: 0.0.0.0
    Timestamp applicazione: 533ef889
    Nome modulo con errori: MSVCR110.dll
    Versione modulo con errori: 11.0.51106.1
    Timestamp modulo con errori: 5098858e
    Codice eccezione: 40000015
    Offset eccezione: 000a327c
    Versione SO: 6.1.7601.2.1.0.256.1
    ID impostazioni locali: 1040
    Informazioni aggiuntive 1: 69ff
    Ulteriori informazioni 2: 69ff892513f5af2adb74f5393cb8d939
    Ulteriori informazioni 3: c530
    Ulteriori informazioni 4: c530475c3705b4a3bd063feac9e502ee

    Leggere l'informativa sulla privacy online:
    http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0410

    Se l'informativa sulla privacy online non è disponibile, leggere quella offline:
    C:\Windows\system32\it-IT\erofflps.txt
    raga questo è il dettaglio dell'errore
     
  16. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Ok, adesso è tutto più chiaro.

    MSVCR110.dll è un file di sistema relativo alla libreria Runtime.

    Prova ad andare nella cartella

    Documenti/rFactor2/Support/Runtimes

    e a fare un doppio clic con il sinistro del mouse su

    vcredist_x86.exe

    Si aprirà una finestra con dei bottoni, uno dei quali è "Repair": cliccaci con il sinistro del mouse, aspetta che finisca il setup poi riavvia il PC.

    Fammi sapere se questo risolve.
     
    Last edited by a moderator: Jun 20, 2014
  17. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    Max ma in documenti non ho nessuna cartella rFactor2
     
  18. Rik

    Rik Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,172
    Likes Received:
    9
    Se non è in documenti prova a vedere dov'è, da qualche parte c'è sicuramente ;)
     
  19. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Ma quando hai installato rF2 hai cambiato i percorsi di installazione?
    Mi sembrava di aver capito di no!

    Cmq, apri il launcher e vai nella tab Advanced.

    In basso a destra, lo spazio bianco del Data Path ti indica dove sono le cartelle Data.
    Se vai li troverai anche la cartella Support, con dentro la sottocartella Runtimes
     
  20. leo4855

    leo4855 Registered

    Joined:
    Jun 16, 2014
    Messages:
    26
    Likes Received:
    0
    raga tutto fatto ma niente ,:confused: e mo cosa facciamo ?
     

Share This Page