Problem with rearview mirrors

Discussion in 'Track Modding' started by Nuno Lourenço, Aug 3, 2014.

  1. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    Hello guys. I need some help. Does anyone know why this happens with mirrors?

    [​IMG]

    And if i turn HDR off

    [​IMG]

    This is a bug or am I missing something?

    Thanks in advance
     
  2. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I have not used dev mode for a while so I am not sure if I used HDR or not.

    Can you confirm the build you are using so that we can try it and feedback?

    Does it work Ok in regular online/offline when you pack it?

    It kind of reminds me to the black screen bug we suffered when we used only hdr and no fxaa or no fxaa and only hdr quite long ago. I would say it was B249 but not sure of that.
     
  3. wgeuze

    wgeuze Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,608
    Likes Received:
    63
    I'm wondering about this too as I am experiencing the very same thing in Devmode.

    The track I'm working has it both in single-and multiplayer. When I load up ISI Silverstone with
    the same car, the problem is gone. Is there maybe a mirror multiplier in the HDR profiles somewhere? Thinking
    out loud here though :p
     
  4. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    It happens in devmode and in single/multi Player. In devmode it don't happens with joesville from ISI.

    It happens with and without HDR specific profile.

    I'm out of ideas.... :(
     
  5. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    Anything odd in the header of the scn? Did you try to use an ISI track heading of the scn where rearview mirror settings are defined?
     
  6. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    Yep, tried right now without sucess.

    :confused:
     
  7. Tosch

    Tosch Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,872
    Likes Received:
    51
    There is a pitmirror defined in the scn. It uses a mirror.bmp as texture. File name is the same for vehicles and that's the problem.
    Comment the pitmirror out in scn and you are good to go.

     
  8. wgeuze

    wgeuze Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,608
    Likes Received:
    63
    That does sound very plausible actually. However, this isn't the case with Zolder, which suffers the same issue.
     
  9. Tosch

    Tosch Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,872
    Likes Received:
    51
    Zolder looks good to me. Never had any problems with the mirrors there.

    [​IMG]

    btw if you press "Ctrl + n" in devmode (maybe viewer too) you can check the normals.

    [​IMG]
     
  10. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    You're the MAN!!!

    Thank you m8
     
  11. wgeuze

    wgeuze Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,608
    Likes Received:
    63
    What the.. That is just odd, I have the problem with atleast two cars, one of which being an ISI car (Skippy).. Weird!

    Giant looking sleeping policeman you've got there, funny perspective I guess :p
     
    Last edited by a moderator: Aug 4, 2014
  12. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    Does this mean that if a track and a car share the name of a texture we might have problems? Or foes it only happen with certain objects as mirrors? Do you know if these also applies to gmts?

    If so this should be fixed since we cannot know which names are using other components when we are modding a car or a track.


     
  13. Liquid4653

    Liquid4653 Registered

    Joined:
    Sep 30, 2013
    Messages:
    202
    Likes Received:
    46
    That's absolutely correct, I have had big issues with car and track material names in the IFS3 mod, thankfully eliminated in my latest internal build, had missed a couple of items despite sweeping through twice already lol.

    There really is no need for this to happen, why can't each element can't be contained to it's relative owner - this way the 'chance' element is impossible to have, no matter how unique you could get a clash for the silliest of reasons, it's not a very intelligent system but then it could be still in development. Surely we could have the cars and tracks and everything in it's own bubble rather than mixing all together.

    This is another additional headache to deal with, making sure everything has unique name all the time.

    This a is potentially big problem in the future because of the hardcoded names we have to use which cannot be altered or prefixed.

    What we gonna do when a track uses the same material names by mistake then?

    What we need is a small engine change to allow prefixing on ALL hardcoded wildcards and material names, that way we can guarantee this cannot happen so easily in the future, but it's still another step making you go back and forth un-necessarily.

    A car or track should go ingame and have exclusive access to it's own textures and namings, and not be able to use other name clashing resources in separate content.

    This change would be ideal since we would not have to concern ourselves with it and could name everything the same all day long with no issue.

    I won't hold my breath though, I am still waiting for a working default standard ui front end to be put in moddev from the single player build:rolleyes:
     
    Last edited by a moderator: Aug 4, 2014
  14. Liquid4653

    Liquid4653 Registered

    Joined:
    Sep 30, 2013
    Messages:
    202
    Likes Received:
    46
    Hey wgeuze,

    The problem can also relate to the cars themselves and differences in moddev and single player.

    the mirror is not too fussy about which shader you put it on, in the sense that plenty work with different side effects. In earlier builds having it on a T1 shader would make them flicker for example, other shaders would gamma out the mirror in moddev and then be perfect in single player build, even now.

    With the environment state changing hdr wise through builds, we have had to be careful to avoid that awful whiting out that can happen like in the picture.

    In the end I now put all my mirrors on the 'no lighting tex' shader, and this tend to give reliable results in both moddev and single player build for me the way they are set up.

    I believe you could still make the mirrors have bad side effects which show differently between the 2 versions of the engine, I say 2 versions because the moddev build is not identical to the single player build.
     
    Last edited by a moderator: Aug 4, 2014
  15. wgeuze

    wgeuze Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,608
    Likes Received:
    63
    Thanks for the clarifications, my best guess is that there is an object somewhere which has a setting that upsets the mirrors of the cars, if it is not a driver issue. I fail
    to understand however how Tosch has no problem at all with the track and nobody else complained about it either. To be continued :)
     
  16. Liquid4653

    Liquid4653 Registered

    Joined:
    Sep 30, 2013
    Messages:
    202
    Likes Received:
    46
    got to be car issue mate and the way their mirrors are set up, if it was your track, it would be happening in every car regardless. Tosch's screenshot shows that particular car has it's mirrors set correctly shader wise.

    The skippy, well I don't even want to say when that was built lol, but it again points to the way the skippy was prepared.
     

Share This Page