[SOLVED] Problem with new Terrain Shader

Discussion in 'Track Modding' started by Nuno Lourenço, Jan 19, 2015.

  1. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    Hello guys, I was trying to implement new terrain shader in my Milagres Kart track but something is not working as it should.

    I set up all four textures
    - Clean grass (Channel 1)
    - Rough grass (Channel 2)
    - Dirt (Channel 3)
    - Pattern to multiple with all 3 (+ alpha with second pattern) (Channel 4)

    The three first with Specular map in Alpha as described in Track PDF.

    After that I created the normal maps with alpha maps too use as "blend pattern" as described too.

    I set up everything in max and start the blend with vertex color as described in PDF too...

    After seeing the result in game something strange happened... The first two textures (Clean grass + rought grass) blend perfectly but the third map (dirt) becomes blurry... all mapping was done correctly in 3ds Max for the 4 channels.

    I did a test changing rought grass to stage 3 and it becomes blurry too. When I put dirt in stage 2 it becomes perfect...

    Any idea? I'm not in home now so I can't show you a screen shot but later I will post one.

    Thank you

    Edit: Screenshots from problem

    [​IMG]

    [​IMG]

    [​IMG]
     
    Last edited by a moderator: Feb 1, 2015
  2. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    Added screenshots... One with grass, other with soil and the third one mapped in 3ds max...
     
  3. Luc Van Camp

    Luc Van Camp Track Team Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    1,030
    Likes Received:
    14
    Are you using the UVW Map/XForm/Unwrap modifiers to map the channels (good), or are you using the Tiling and Offset parameters in the gTex panel (bad)?
     
    Sergio Loro likes this.
  4. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    I tried two ways and then when I was saving a print of my settings in mx i found the problem.... Facepalm...

    [​IMG]

    Bias was positive.... I usually use bias -2 but i must have clicked wrong yesterday in a hurry and didn't realise that this was bad... now with -2 all went fine

    [​IMG]

    Thank you very much Luc ;)
     
  5. Luc Van Camp

    Luc Van Camp Track Team Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    1,030
    Likes Received:
    14
    Good to see you got it to work :) . Have fun experimenting with the shader -- it does take a bit of time to develop some ... Fingerspitzengefühl.

    By the way, negative MIP Map bias is blasphemy on this forum :) .
     
  6. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    Why is that? :)
     
  7. Luc Van Camp

    Luc Van Camp Track Team Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    1,030
    Likes Received:
    14
    It's a leftover from the old days when people couldn't afford to run 16x Aniso, and is now the biggest cause of aliasing when you do run Aniso. Recent ISI tracks use MIP Map bias 0.0 for nearly all materials; exceptionally -0.5 or -1.0.
     
  8. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63
    Hum... Understood! I will do some experiments to get the better compromiss...

    Thanks again ;)
     
  9. Guimengo

    Guimengo Guest

    Holy crap dang damn, that sandy grass dune looks super cool.
     
  10. raul999

    raul999 Registered

    Joined:
    Dec 23, 2014
    Messages:
    88
    Likes Received:
    0
    nuno what is the name of the shader to use to create this terrain effects? thanks
     
  11. Nuno Lourenço

    Nuno Lourenço Registered

    Joined:
    Oct 19, 2010
    Messages:
    592
    Likes Received:
    63

Share This Page